Jump to content


About a bug in UFO Defense


19 replies to this topic

#1 Guest_Daniel_*

Guest_Daniel_*
  • Guests

Posted 29 October 2002 - 07:24 PM

Hi every one...
I was playing my X-Com and something weird happened:
When I put my scientists to work on Sectoid Medic
everything seems to be fine, but when they discover, the geme shows the image with the Alien and when I press OK the game exits...

Does someone used to have the same problem as mine???

If someone wants, I can send the save game...

Tnks for all
Daniel

#2 gangsta

gangsta

    Colonel

  • Forum Members
  • PipPipPipPipPip
  • 2,203 posts

Posted 29 October 2002 - 10:45 PM

The game just exits like that on a fairly regular basis. There really isn't any thing you can do about it I think. Just save keep alot of save games so you can recover. And save monthly and mid monthly. I think it is just a case of bad programming personally since the amiga version has the exact same problem too.
Posted Image

#3 Guest_stewart_*

Guest_stewart_*
  • Guests

Posted 30 October 2002 - 12:31 PM

Does it do it everytime? XCOM is quirky.

#4 gangsta

gangsta

    Colonel

  • Forum Members
  • PipPipPipPipPip
  • 2,203 posts

Posted 30 October 2002 - 02:31 PM

It does it sometimes when a pregenerated event happens and all the save files around that time are useless. That happened to me once and the only one that wasn't close enough was the monthly save. In that case I decided to rather start the game over than load the monthly.
Posted Image

#5 Guest_stewart_*

Guest_stewart_*
  • Guests

Posted 30 October 2002 - 03:10 PM

Yeah that's the usual thing and the usual treatment. Sometimes the game goes nuts and throws you into battlescape of the last battle you saved.

#6 gangsta

gangsta

    Colonel

  • Forum Members
  • PipPipPipPipPip
  • 2,203 posts

Posted 30 October 2002 - 05:51 PM

never did that for me. It exits that way in the battlescape sometimes too though. U can usually stop that if you saved and then find the right alien to kill.
Posted Image

#7 Guest_micahdg@xcomufo.com_*

Guest_micahdg@xcomufo.com_*
  • Guests

Posted 31 October 2002 - 12:27 AM

Daniel: You need to load your saved game before the research is complete and change the research to something else. This will avoid the "research bug crash."

#8 Guest_Daniel_*

Guest_Daniel_*
  • Guests

Posted 31 October 2002 - 02:29 AM

that's what I did....

So the DOS version is MUCH better than the windows version...
i'll get the DOS... but i remebered that runs so fast that in battle was terrible to play...

#9 Guest_stewart_*

Guest_stewart_*
  • Guests

Posted 31 October 2002 - 03:04 PM

never did that for me.  It exits that way in the battlescape sometimes too though.  U can usually stop that if you saved and then find the right alien to kill.

It's an old known bug. So I image Microprose or whoever fixed it a long time ago. My version is old enough to vote now. So all those old bugs still have a home in my machine. :(

#10 Guest_stewart_*

Guest_stewart_*
  • Guests

Posted 31 October 2002 - 03:05 PM

Daniel:  You need to load your saved game before the research is complete and change the research to something else. This will avoid the "research bug crash."

How do you do that? Just stop the research and leave it hanging?

#11 Guest_stewart_*

Guest_stewart_*
  • Guests

Posted 31 October 2002 - 03:07 PM

that's what I did....

So the DOS version is MUCH better than the windows version...
i'll get the DOS... but  i remebered that runs so fast that in battle was terrible to play...

I've heard people complain about speed problems; what exactly runs to quickly. Sorry for being ignorant but the fastest machine I've played XCOM on was about 250 MHz and I experienced no speed problems.

#12 gangsta

gangsta

    Colonel

  • Forum Members
  • PipPipPipPipPip
  • 2,203 posts

Posted 31 October 2002 - 03:39 PM

never did that for me.  It exits that way in the battlescape sometimes too though.  U can usually stop that if you saved and then find the right alien to kill.

It's an old known bug. So I image Microprose or whoever fixed it a long time ago. My version is old enough to vote now. So all those old bugs still have a home in my machine. :(

nope that happens in the Collector's Edition. Isn't that the last version that came out? oh wait :) you talking about what you previously posted. ok nevermind :blink:
Posted Image

#13 gangsta

gangsta

    Colonel

  • Forum Members
  • PipPipPipPipPip
  • 2,203 posts

Posted 31 October 2002 - 03:43 PM

that's what I did....

So the DOS version is MUCH better than the windows version...
i'll get the DOS... but  i remebered that runs so fast that in battle was terrible to play...

I've heard people complain about speed problems; what exactly runs to quickly. Sorry for being ignorant but the fastest machine I've played XCOM on was about 250 MHz and I experienced no speed problems.

I had a k6-2 400mhz and to get the game to work on it I had to put it on the slowest speed setting available in the options. It still went a bit fast but was playable. Now on my athlon without that xcom1fix the game would have been impossible to play.
Posted Image

#14 Guest_stewart_*

Guest_stewart_*
  • Guests

Posted 31 October 2002 - 03:48 PM

never did that for me.  It exits that way in the battlescape sometimes too though.  U can usually stop that if you saved and then find the right alien to kill.

It's an old known bug. So I image Microprose or whoever fixed it a long time ago. My version is old enough to vote now. So all those old bugs still have a home in my machine. :(

nope that happens in the Collector's Edition. Isn't that the last version that came out? oh wait :) you talking about what you previously posted. ok nevermind :blink:

Que?

#15 Guest_stewart_*

Guest_stewart_*
  • Guests

Posted 31 October 2002 - 03:49 PM

that's what I did....

So the DOS version is MUCH better than the windows version...
i'll get the DOS... but  i remebered that runs so fast that in battle was terrible to play...

I've heard people complain about speed problems; what exactly runs to quickly. Sorry for being ignorant but the fastest machine I've played XCOM on was about 250 MHz and I experienced no speed problems.

I had a k6-2 400mhz and to get the game to work on it I had to put it on the slowest speed setting available in the options. It still went a bit fast but was playable. Now on my athlon without that xcom1fix the game would have been impossible to play.

Yes anouther add for F*cking add for Athlons but you didn't actually answer the question you quoted! :blink:

#16 gangsta

gangsta

    Colonel

  • Forum Members
  • PipPipPipPipPip
  • 2,203 posts

Posted 31 October 2002 - 11:15 PM

:P THe whole game moves at super sonic speeds and it scrolls at those speeds too.
Posted Image

#17 Guest_stewart_*

Guest_stewart_*
  • Guests

Posted 01 November 2002 - 11:05 AM

I guess 250MHz machine is still too slow for those effects to show-up, because it seemed the same as when I played it in University on 60MHz machines.

#18 gangsta

gangsta

    Colonel

  • Forum Members
  • PipPipPipPipPip
  • 2,203 posts

Posted 01 November 2002 - 11:16 PM

I never seen how fast it moves on the athlon because by that time I changed graphic cards and needed the xcom1fix to play. but on my k6-2 400mhz system It moved too fast untill I went to the options and put it on its slowest setting. What the xcom1fix does I think is call an interupt every so often to pause the program. Makes the geoscope a little strange cause you can feel he pauses there but good for the battlescape.
Posted Image

#19 Orac

Orac

    Sergeant

  • Forum Members
  • PipPipPip
  • 25 posts

Posted 02 November 2002 - 05:45 PM

hey,

I can totally understand wanting to play the dos version instead. There's some things going for it that the windows version doesn't. Also seems like you can avoid many of the bugs by using custom config.sys and autoexec.bat and playing in true dos (i.e. dos boot disk, or multi-config). That way you can load only the drivers you need into upper memory. Like just your mouse driver, smartdrive, and your memory manager. Be careful about the memory manager you use though. Xcom seems to misbehave with many third party ones. So I'd recommend sticking with good old EMM386.EXE (along with the "NOEMS" parameter since xcom seems to favor XMS and there isn't any need to waste that extra memory on a 64k page).

Here's a copy of my config.sys and autoexec.bat in case anyone wants a good template for their own uses.

CONFIG.SYS
=====================================================
[menu]
menuitem=dos,MS-DOS 7
menuitem=arachne,Arachne
menuitem=windows,Windows 98 SE
menuitem=xcom,X-com
menudefault=windows,10

[dos]
DOS=HIGH,UMB,AUTO
DEVICEHIGH=C:\WINDOWS\HIMEM.SYS
DEVICEHIGH=C:\WINDOWS\EMM386.EXE NOEMS

[xcom]
DOS=HIGH,UMB,AUTO
DEVICEHIGH=C:\WINDOWS\HIMEM.SYS
DEVICEHIGH=C:\WINDOWS\EMM386.EXE NOEMS


[arachne]
DEVICEHIGH=C:\WINDOWS\HIMEM.SYS /numhandles=64
DEVICEHIGH=C:\WINDOWS\EMM386.EXE NOEMS
DEVICEHIGH=C:\WINDOWS\RAMDRIVE.SYS 16384 512 512 /E
DOS=HIGH,UMB,AUTO
FILESHIGH=40

[windows]

[common]


AUTOEXEC.BAT
====================================================
@ECHO OFF
PROMPT $P$G
GOTO %CONFIG%

:dos
SET BLASTER=A220 I5 D1 H1 REC3 T6 P330
PATH C:\MOUSE;C:\ARACHNE
LH C:\MOUSE\MOUSE.COM
LH C:\WINDOWS\Command\DOSKey /I
rem - By LC - LH C:\A4SOUND\A4INIT.EXE C:\A4SOUND
GOTO end

:xcom
c:\windows\smartdrv
SET BLASTER=A220 I5 D1 H1 REC3 T6 P330
PATH C:\MOUSE
LH C:\MOUSE\MOUSE.COM
LH C:\A4SOUND\A4INIT.EXE C:\A4SOUND
GOTO end

:arachne
c:\windows\smartdrv
SET BLASTER=A220 I5 D1 H1 REC3 T6 P330
PATH C:\MOUSE;C:\ARACHNE
LH C:\MOUSE\MOUSE.COM /H75 /V100
LH C:\WINDOWS\Command\DOSKey /I
SET TEMP=D:\TEMP
MKDIR %TEMP%
GOTO end

:windows
path %path%;c:\at-slow
WIN
GOTO end

:end
cls


* Main part you're interested in is the xcom sections. But I pasted the whole thing to demonstrate how to go about a dos multiboot.


As for the game running too fast:

I'd recommend using the slow down util called "Moslo'". There's also many others that may work even better in other cases. Of course the best option is to temporarily disable your caches in your BIOS (i.e. L2, or external cache etc). That will achieve the smoothest slowdown, but the tradeoff is that it can be rather inconvenient going into your BIOS that much depending upon how you use your system though. Like might be ideal if you plan to play alot of long sessions of xcom.

Anyway, now you know I how I go about playing xcom. I pretty much swear by this method, because I have yet to encounter a single show stopping bug (most definitely it's never crashed nor corrupted a save game yet. Then again ya never know, I may just be getting real lucky.) This configuration even works flawlessly for me in MS-DOS 7.XX (the version that comes with windows 98SE, can't remember the exact version hence the "XX")

* notice how I have at-slow in my path for windows :P

:P

#20 Guest_stewart_*

Guest_stewart_*
  • Guests

Posted 04 November 2002 - 11:35 AM

I remember when I played on Pre-95 machines there was a bug in the buying stuff page or manufacturing page where you would select number of units and it would be stuck on "on" and you'd have sellected thousand of things.

Now running in a 95+ dos window that doesn't happen. But I get this cursor stalling bug where I move the mouse and sometimes the cursor sits there. Leaving battlescape map is particularly annoying.



Reply to this topic