Jump to content


Eqp Or Srt Strip Type Strings From Name...

  • Please log in to reply
2 replies to this topic

#1 kwalsh



  • New Forum Members
  • Pip
  • 0 posts

Posted 11 May 2008 - 07:34 AM

I'm using xcomutil 9.6 with a DOS version (1.2) of the original UFO.

I append my own equipment types to the ends of the names, for example:

Jungo Hunger//HR

For a "Heavy Rifle" type troop. I've got an EQP file that defines HR and others.

Now, if I run xcomutil GAME_x SRT:EQP WRT it does in fact sort the soldiers, but it also removes their type strings! Name after I run this is Jungo Hunger/.

Similarly if I get the name setup correctly again and run xcomutil GAME_x EQP WRT it does arm the soldiers correctly but again strips their names.

I've also tried Jungo Hunger/HR (just one slash) and the behavior is the same, but name ends up as Jungo Hunger (no slash).

Basically, SRT:EQP or EQP strip the trailing slash and characters which is not what I expected. Nothing in the docs indicate the names should change at all with these commands and in fact this behavior makes the commands pretty useless "one time" commands.

Am I doing something wrong here? Any ideas?



#2 kwalsh



  • New Forum Members
  • Pip
  • 0 posts

Posted 11 May 2008 - 12:49 PM

OK, so it would appear that in the EQP case the names get stripped during combat but then reapplied after combat. so that works OK I guess.

But for SRT:EQP (which is run not in combat) it does strip the equipment types from the names.

Any hints?

#3 BladeFireLight



  • Moderators
  • PipPipPipPip
  • 809 posts

Posted 21 July 2008 - 07:47 PM

I will add it to my bug list.

Any chance you can give me a copy of your saved game and what version of xcom, and if your useing a fan made executable.

-Blade FireLight
Combat is very simple, there is a first place and second place, second place is laying face down in the mud, sometimes, so is first place.