Jump to content


Photo

Xcom Tftd (et-version 20/01/2005)


155 replies to this topic

#51 Guest_TFTD Guy_*

Guest_TFTD Guy_*
  • Guests

Posted 09 September 2004 - 12:50 PM

Theres still a few bugs that need to be fixed:

Game constantly crashes when Aliens (especially ones with Thermal Shok Launchers) react to your movements.

If one of your bases gets invaded, and you lose, not only do you lose that particular base, but the base icon of your original base will disappear off the geoscape. You can still access that base from the Bases button, but you cant send the subs from there on missions, and you cant transfer (interact with in general) items to that base, etc.

#52 max

max

    Sergeant

  • Forum Members
  • PipPipPip
  • 21 posts

Posted 10 September 2004 - 02:40 AM

Hi,

thanks for the resopnse, the crash bug has been located, but i can't work on it until about two weeks, I didn't know about the base problem, is this only with et patch? please post your save game, thanks.

#53 Ros

Ros

    Sergeant

  • Forum Members
  • PipPipPip
  • 18 posts

Posted 12 September 2004 - 12:02 PM

Hi,

thanks for the resopnse, the crash bug has been located, but i can't work on it until about two weeks, I didn't know about the base problem, is this only with et patch? please post your save game, thanks.

<{POST_SNAPBACK}>

Could you do that patch compatible with XcomUtil or just an .exe file with fixed Geoscape time (compatible with XcomUtil)? I'm playing CE version and it's really annoying slowing the game each time. Please :D
Ros

#54 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 13 September 2004 - 09:13 AM

Just want to say I have the same error as others posted : the moment an alien with Thermal Shock launcher fires, the game crashes to desktop. Didn't save it in time, sorry.

Otherwise, damn good patch, allowed me to play it at least. :)

#55 BattleKnight

BattleKnight

    Squaddie

  • Forum Members
  • PipPip
  • 6 posts

Posted 14 September 2004 - 03:32 PM

Just registered and was wondering if there was a solution to the 'crash' bug? I can only play TFTD with the patch from Max, but the game seems to crash when an alien tries to use a blaster launcher (I know it's a blaster launcher since there is a huge explosion and then the game crashes to desktop).

So, is there a fix for this?

#56 max

max

    Sergeant

  • Forum Members
  • PipPipPip
  • 21 posts

Posted 15 September 2004 - 02:44 AM

BattleKnight, please send/post savegame ith instructions to repeat the crash and we'll try fix it, thanks.

#57 cyrano

cyrano

    Squaddie

  • Forum Members
  • PipPip
  • 2 posts

Posted 17 September 2004 - 08:09 AM

Hello ppls !

Thx you for your hard work =)

I play to terror from the deep windows version.Patch and everything i can find is installed.

Well, my problem is:
I crash when i kill an alien.. like some other ppl i think...
It s a random crash. not when i kill the first alien .. or the second.. it come randomly.. but it comes.

Too bad ... this game is just incredible .. and the programation isn t working on any configuration or pc.. Patch or not . Perhaps with linux a day.
It s crazy to see this game so much corrupted =)

I hope everything will be fixed a day .. but i don t think so.
We needa new game with a new engine and programs.

Thx you all again for your work again.. Everytime i see a new patch it give me hope... =)

Regards,


///edited///

Doh.. only max works on it? Should be a lot of work for only one man to fix the unlimited number of bug in this game

Edited by cyrano, 17 September 2004 - 08:25 AM.


#58 Guest_Guest_mindance_*_*

Guest_Guest_mindance_*_*
  • Guests

Posted 17 September 2004 - 02:32 PM

using the 09-04-04 version my geoscape acts incredibly choppy. any suggestions? the rest of the game runs at perfect timing.

#59 Guest_Ranma_*

Guest_Ranma_*
  • Guests

Posted 18 September 2004 - 09:40 PM

Yeah the geoscape is not nearly as smooth as it was before the patch, but other then that its a damn fine addition :)

#60 max

max

    Sergeant

  • Forum Members
  • PipPipPip
  • 21 posts

Posted 23 September 2004 - 05:56 AM

I can't reproduce the carshes posted, please send a save game at these situations.

about the geoscape, the time runs in the correct ration of 1 real second to 5 game seconds, but the updates are only posted every second, 'enemy unknown' et version has a smotth implementation which will be included for the older tftd et version.

#61 Fangs

Fangs

    Rookie

  • Forum Members
  • Pip
  • 0 posts

Posted 26 September 2004 - 04:41 AM

I have the same problem with the game crashing when the enemy gives reaction fire. I have included saved game attachment as asked, work your magic Max :LOL:

Apart from the new bug, i love the changes keep up the good work :LOL:

Attached Files



#62 BattleKnight

BattleKnight

    Squaddie

  • Forum Members
  • PipPip
  • 6 posts

Posted 26 September 2004 - 12:37 PM

Yeah, the bug indeed has to do with reaction firing.

Here's my savegame. Just load it, go to the aquanaut named 'Nico Vancamp'. Make him move to the left (towards the crashed USO) by about 3 squares. Once he sees the Aquatoid, make him kneel and do an Autoshot. The alien won't die and then turns for a reaction fire. Then, CTD.

Do your stuff Max, I know you can do it. :)

Attached Files



#63 max

max

    Sergeant

  • Forum Members
  • PipPipPip
  • 21 posts

Posted 29 September 2004 - 04:18 AM

Hi,

update uploaded, post if there any problems,
Fangs, could not get your save game to crash, please try latesty version to verify, thanks.

#64 Fangs

Fangs

    Rookie

  • Forum Members
  • Pip
  • 0 posts

Posted 30 September 2004 - 04:00 AM

Fangs, could not get your save game to crash, please try latesty version to verify, thanks.

<{POST_SNAPBACK}>


That seemed to do the trick. ^_^

Thanks max.

#65 Guest_Mikaus_*

Guest_Mikaus_*
  • Guests

Posted 08 October 2004 - 11:19 AM

How is it that you are making these modifications?

#66 jekman

jekman

    Squaddie

  • Forum Members
  • PipPip
  • 3 posts

Posted 17 October 2004 - 05:02 PM

Hello

When I use the "patches" my CPU starts to work at 100%, this makes the games very slow. I have no problem with the CE-version.

Using AMD 1700, 256mb RAM and winXP on a laptop.

Thanks

#67 Guest_Burning_*

Guest_Burning_*
  • Guests

Posted 18 October 2004 - 11:28 AM

Hello, first, I'm german so don't wonder about my english ^^

I've a problem with this patch,even when I send the Triton to a crashsite theres the message "All Allien have been died in caus of the Crash" (I hope i translate it right) - and then the game crashed to the desktop.

Can someone help me?


Burni form Germany ^^

#68 max

max

    Sergeant

  • Forum Members
  • PipPipPip
  • 21 posts

Posted 19 October 2004 - 02:04 AM

Please post your savegame with instructions to reproduce the crash.
(save just beofre the crash), thanks.

#69 max

max

    Sergeant

  • Forum Members
  • PipPipPip
  • 21 posts

Posted 29 November 2004 - 04:41 AM

Thanks for your game, Skippy. I tried it and could not get it to crash. - They were sent to T'l.. if we can't fix the problem because we can't reproduce it, perhaps I could post your game just after they are sent to T'l..

#70 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 30 November 2004 - 12:04 PM

Thanks for looking max, someone else sent me a saved game right after getting to T'leth but it also crashed as soon as I destroyed all 8 of the power things on level 3. I don't know why my version is crashing when it seems most others are working. Luckily, all I'm missing are the ending blurbs and movies / slideshows about T'leth. It still bugs me but at least I know I beat the game. Any ideas on what might be causing the crash? Any plans to release more patches (or any patches for Apocalypse)? Thanks again.

#71 Jonaleth Irenicus

Jonaleth Irenicus

    Captain

  • Forum Members
  • PipPipPipPip
  • 147 posts

Posted 30 November 2004 - 03:33 PM

You are having problems playing the in game movies. Both instances where you say the crash happened are times when an in game movie shows up. I would look into the movie files to see if something is out of the ordinary with them.
Passenger ship terror site, first turn, I open the door of my Triton, there is a Tasoth up on the next floor (his back is facing the screen so I don't know what weapon he has).

One of my guys fire at him, hit, he reaction fires with Thermal Shock Launcher. The whole crew stunned. Mission over.

#72 max

max

    Sergeant

  • Forum Members
  • PipPipPip
  • 21 posts

Posted 01 December 2004 - 07:35 AM

I did't realise it was related to displaying movies - my version doesn't display movies ..., so can't trap that error, sorry.

#73 Skippy

Skippy

    Rookie

  • Forum Members
  • Pip
  • 0 posts

Posted 06 December 2004 - 02:35 AM

Thanks for the replies guys. About the movie files, I checked but couldn't find any that I recognised (what's the extension?) but since this is the only copy I have I wouldn't know what would constitute unusual files. Maybe I could play them with some 3rd party player to see if they worked? Anyway, as annoying as it is at least I was able to beat the game so it's not a major problem (or a major rush). Thanks.

#74 Jonaleth Irenicus

Jonaleth Irenicus

    Captain

  • Forum Members
  • PipPipPipPip
  • 147 posts

Posted 06 December 2004 - 05:17 AM

max, have you checked whether your patch works on the CE and displays movies. What I mean is, has anyone successfully installed your patch and viewed the movies while playing the game like that?

If you are doing patch work on a version that doesn't have movies, couldn't that create problems for the version that has movies?

(BTW, the movies are not really that good anyway).
Passenger ship terror site, first turn, I open the door of my Triton, there is a Tasoth up on the next floor (his back is facing the screen so I don't know what weapon he has).

One of my guys fire at him, hit, he reaction fires with Thermal Shock Launcher. The whole crew stunned. Mission over.

#75 max

max

    Sergeant

  • Forum Members
  • PipPipPip
  • 21 posts

Posted 07 December 2004 - 07:38 AM

Yes, it could create problems - or we won't be able to trap errors that exist with playback. - I don't remember reading any feedback regarding movies. Didn't want to say it, but my version was downloaded... the patch was written for myself - for that version. would like to help with the problem but can't :(

#76 SupSuper

SupSuper

    Programming Department

  • Xenocide Programming Department
  • 2418 posts

Posted 11 December 2004 - 03:49 PM

i thought the version of tftd on the web had movies. at least the one i got has :wacko:

too bad, now you will never know the ancient secrets of supsupers long gone avatar ;)

Posted Image

Posted Image

#77 wee_mad_arthur

wee_mad_arthur

    Rookie

  • New Forum Members
  • Pip
  • 0 posts

Posted 11 December 2004 - 05:58 PM

Hi, i'm new to the forums, i got addicted to both xcom games a few years back and i've been wanting to play them for ages, except i got the garbled graphics on this pc running XP, so i;ve got max's patch, unfortunatly the graphics aren't quite right for me as parts of the screen get chopped off the top and the bottom! This is rather annoying because i can't see the intercept button on the world view thingy. Any idea how to fix this problem? :(


Edit: I've got CE version installed - not sure if this is relevant.

If you can fix this for me max i'll fluffle you into oblivion. :MakeOut: x 1000

Edited by wee_mad_arthur, 11 December 2004 - 06:27 PM.


#78 j'ordos

j'ordos

    Alien Concept Task Force

  • Xenocide Artwork Department
  • 5059 posts

Posted 11 December 2004 - 06:40 PM

try : http://www.xcomufo.com/xcom2fix.exe

Edited by j'ordos, 11 December 2004 - 06:40 PM.

"You can't trust your eyes if your imagination's out of focus" - Mark Twain
"The mind is like an umbrella, it functions best when open" - Walter Gropius
Posted Image
SNEKK BLOG U-LAR MEKHH! GAHGHH! RK!
GRRGH RGGHH SNORRTT GHACKHGG

Now presented in DoubleVision™ (where drunk)

#79 wee_mad_arthur

wee_mad_arthur

    Rookie

  • New Forum Members
  • Pip
  • 0 posts

Posted 11 December 2004 - 06:45 PM

Error: Could not load patch.dll

:Cry:

#80 wee_mad_arthur

wee_mad_arthur

    Rookie

  • New Forum Members
  • Pip
  • 0 posts

Posted 11 December 2004 - 06:53 PM

Error: Could not load patch.dll

:Cry:

<{POST_SNAPBACK}>


Ok, i got the patch.dll from fodders loader, but i still have the same problem. :(

#81 j'ordos

j'ordos

    Alien Concept Task Force

  • Xenocide Artwork Department
  • 5059 posts

Posted 12 December 2004 - 05:17 AM

hmm, chopped off you say? Try using your monitor screen buttons to fix it.
"You can't trust your eyes if your imagination's out of focus" - Mark Twain
"The mind is like an umbrella, it functions best when open" - Walter Gropius
Posted Image
SNEKK BLOG U-LAR MEKHH! GAHGHH! RK!
GRRGH RGGHH SNORRTT GHACKHGG

Now presented in DoubleVision™ (where drunk)

#82 Powerc80

Powerc80

    Rookie

  • Forum Members
  • Pip
  • 0 posts

Posted 24 December 2004 - 04:46 PM

I wonder when the next version of max's patch will be out? I really liked what he did for the Geoscape in X-Com 1 and hope he does the same for X-Com 2.

#83 Vvictor

Vvictor

    Squaddie

  • Forum Members
  • PipPip
  • 5 posts

Posted 30 December 2004 - 09:32 AM

I have just installed the patch from Sep, 29.

Unfortunately I can not run it because of the video problem. I run it under Win2000. I have golden edition with two running files in the catalog: terror ... .exe and ldr_xcom2.exe Originally if I run terror, I have this problem with video (I can not see anything, many lines...) , but running Ldr_xcom2 fixes it. With this new patch, it does not work: I can not see anything on the screen no matter what file I run.

The same is with CE. By the way, I even did not understand what is the difference between these two.

PS Max, thank you very much for giving me a hope!!! I have been dreaming of playing terror from the deep without crashes!!! It seems that now my dream has nearly become a true :-)

Please, help me with the bug!

#84 max

max

    Sergeant

  • Forum Members
  • PipPipPip
  • 21 posts

Posted 01 January 2005 - 08:29 AM

Update posted, please try and post if there are any problems, thanks!

Edited by max, 02 January 2005 - 03:30 AM.


#85 Kloreep

Kloreep

    Sergeant

  • Forum Members
  • PipPipPip
  • 47 posts

Posted 10 January 2005 - 04:28 PM

CE=Gold :)

Don't know which folder they would be in, but assuming it's programmed to handle missing movies by skipping them, just find them and give them an extra extension like .NOUSE

#86 M&M

M&M

    Rookie

  • Forum Members
  • Pip
  • 0 posts

Posted 12 January 2005 - 09:05 AM

ahh, thanks.

but where the heck do i find those movies, there is just TOO MANY files. It takes ages just to find the executable :D (ok not really) but there is too many.
what extension are they in...etc ? perhaps i could find them that way, and do i simply change the extensions (if i find them) ?

im presuming they are already missing, thats the cause of the crash. but they could be corrupt too, who knows.

#87 j'ordos

j'ordos

    Alien Concept Task Force

  • Xenocide Artwork Department
  • 5059 posts

Posted 12 January 2005 - 09:13 AM

Well, they should be in the 'ANIMS' folder, two files, intro.ani and intro.idx (well, there are other files too, but we're only talking about the intro now), removing even one of these files causes the game to use the slideshow instead.
"You can't trust your eyes if your imagination's out of focus" - Mark Twain
"The mind is like an umbrella, it functions best when open" - Walter Gropius
Posted Image
SNEKK BLOG U-LAR MEKHH! GAHGHH! RK!
GRRGH RGGHH SNORRTT GHACKHGG

Now presented in DoubleVision™ (where drunk)

#88 Guest_Guest_M&M_*_*

Guest_Guest_M&M_*_*
  • Guests

Posted 13 January 2005 - 08:19 AM

how nice, i dont have that folder at all :).
the intro does start in slide show, its the t'leth movie im concerned about.

all the folders i have (other then save folders) are:
GEODATA - GEOGRAPH - MAPS - SOUND - TERRAIN - ROUTES - UFOGRAPH - UNITS - MISSDAT.

and then there is the executables and fixes as files.

so probably as i suspected im missing the movies alltogether, slideshow works at the beginning of the game but apparently xcom doesnt figure out how to do that when im going to t'leth.
i set up an empty folder just incase it might solve the problem (sorta like the save game problem from xcom3)

perhaps someone can be kind enough to upload those movies if they arent to big ? :P

#89 Powerc80

Powerc80

    Rookie

  • Forum Members
  • Pip
  • 0 posts

Posted 14 January 2005 - 06:32 PM

:Deleted:

Edited by Powerc80, 16 January 2005 - 06:03 PM.


#90 Powerc80

Powerc80

    Rookie

  • Forum Members
  • Pip
  • 0 posts

Posted 16 January 2005 - 06:08 PM

Update posted, please try and post if there are any problems, thanks!

<{POST_SNAPBACK}>

Great job on the geoscape and new resolutions Max :) , but I did notice some bugs in this version.

1) The "Graphs" button no longer displays proper information. However, this is not that much of a problem, as I rarely use this.

2) When on the "BattleScape", my soldiers no longer take any damage from Sonic Pistols/Blasta-Rifles (but they still take damage from Sonic Cannons, grenades, lobsterman claws, etc). My soldiers can hurt Aliens with Sonic Guns, though.

3) The French (Francais) language no longer works. Not that much of a problem for me since I speak/read/write English just as well, but may be a problem for others.

Thanks again for listening!

Edited by Powerc80, 16 January 2005 - 06:09 PM.


#91 max

max

    Sergeant

  • Forum Members
  • PipPipPip
  • 21 posts

Posted 17 January 2005 - 04:50 AM

Hi, thanks
I'll removing any patches that affect damage (i'm not sure if there were any). the graph problem was reported before but I didn't realize it was the patch causing it. will give it a look but no fix soon.
Nothing against French of course, will try sort the problems out. thanks again for the feedback!

#92 max

max

    Sergeant

  • Forum Members
  • PipPipPip
  • 21 posts

Posted 20 January 2005 - 04:59 AM

update posted, damage problem should be corrected. please post any problems or suggestions. thanks!

#93 Powerc80

Powerc80

    Rookie

  • Forum Members
  • Pip
  • 0 posts

Posted 21 January 2005 - 06:22 PM

The damage bug is now gone. Great job max =b!

#94 Inteck

Inteck

    Squaddie

  • Forum Members
  • PipPip
  • 2 posts

Posted 21 January 2005 - 09:56 PM

:Coffee: This is a good place to put this fix.....For those of us that are observant, (and a little nitpicky) This file replaces the interception screen which shows the wrong images of the "Battleship"(Ufo Terror Ship) and the "Fleet Supply Ship" **The interception screen images that comes with the the game are reversed as opposed to the ones in the Usopaedia** All thanks go to Daishiva's Editors for making it possible. Attached File  INTERWIN.rar   10.76K   604 downloads Should work on ALL versions both Dos and Windows.

Edited by Inteck, 22 January 2005 - 10:01 AM.


#95 Powerc80

Powerc80

    Rookie

  • Forum Members
  • Pip
  • 0 posts

Posted 21 January 2005 - 09:59 PM

As well, I figured out how to remove the incorrect "Graphs" error. First, this error is caused incompatabilites with f0dder's loader. It can be fixed by deleting the "patch.dll" and the "ldr_xcom2.exe" found in the main directory (if you downloaded from HOTU or installed f0dder's patch) and then applying your patch. Then start a new game and everything should be fine. Unfortunately, French (Francais) still doesn't work...

My (English) "game experience" is now bug-free :D! Thanks again for fixing the damage bug!

Edited by Powerc80, 21 January 2005 - 10:03 PM.


#96 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 26 January 2005 - 08:55 PM

I just wanted to say thank you so much! I wanted to play this game really bad, ya see, and I was pulling my hair out with the crashes.

#97 FrickenMoron

FrickenMoron

    Squaddie

  • Forum Members
  • PipPip
  • 6 posts

Posted 01 February 2005 - 08:28 AM

Im having quite a problem/bug with the 1/20/05 version combined with the CE version of tftd. The aliens which carry sonic pistols/rifles have gained unlimited reaction fire shots, and when they run out of ammo they keep shooting harpoon bolts :/ really weird.

#98 max

max

    Sergeant

  • Forum Members
  • PipPipPip
  • 21 posts

Posted 01 February 2005 - 09:50 AM

Hi, that is a result of a crash work around, it would be great to have a save game where this situation could be reproduced to further work on the problem. thanks.

#99 FrickenMoron

FrickenMoron

    Squaddie

  • Forum Members
  • PipPip
  • 6 posts

Posted 01 February 2005 - 10:53 AM

Okay i got a saved game, if you move Uta Unger 1 square down it triggers a reaction fire frenzy with the newest version, in an older game version nothing happens.

Save File

Hope thats helps.

Oh also another question that has nothing to do with your patch but with the game in general, on port terror raids i NEVER can walk to the top third floor of the towers, it just wont let me completely climb the last stair. I always have to bomb away the floor if an alien hides in there, this happens regardless which version of tftd i use, are there any solutions for it?

Edit: Thats the Square which i cant move on no matter what. It even crashd one time when i tried to move there. Im on Windows98SE by the way.

Edited by FrickenMoron, 01 February 2005 - 10:56 AM.


#100 max

max

    Sergeant

  • Forum Members
  • PipPipPip
  • 21 posts

Posted 04 February 2005 - 09:17 AM

Hi, thanks very much, will use it to find a peaceful solution. don't know about the top stairs problem, it was not a problem for me.



Reply to this topic