Jump to content


Photo

Error While Compiling "0.7.1086" Under Archlinux


  • Please log in to reply
4 replies to this topic

#1 Wiesel

Wiesel

    Squaddie

  • Forum Members
  • PipPip
  • 9 posts

Posted 05 September 2007 - 08:21 AM

hi
as mentioned above i cant compile the current beta.
till now i tryed it 2 times.
first without dumb(since i didnt found the forum entry where the make-depends are listet)
i came to server_config.cpp:44 where some error with an DB_* variable was mentioned, the script abortet.

on the second try i thought it MAYBE was because of that missing lib even if the config mentioned that it will simply disable sound, so i downloaded "dumb" too.
now the compiling process kills itself eve3n earlier:
src/dumbogg/dumbogg.c: In function 'ogg_start_sigrenderer':
src/dumbogg/dumbogg.c:353: error: too few arguments to function 'dumb_reset_resampler'
scons: *** [.build-dir/src/dumbogg/dumbogg.o] Error 1
i already searched a bit about these errors in the forums but found nothing.
help or links with topics that handles these problems would be welcome

EDIT
the same happens while compiling the stable version

Edited by Wiesel, 05 September 2007 - 08:27 AM.


#2 bamb

bamb

    Captain

  • Forum Members
  • PipPipPipPip
  • 155 posts

Posted 05 September 2007 - 09:05 AM

I don't know, but sounds like some library version mismatch? (The argument number difference in a function.)
Did you get the libraries from the zip provided in the forums or did you DL dumb separately?

#3 Wiesel

Wiesel

    Squaddie

  • Forum Members
  • PipPip
  • 9 posts

Posted 05 September 2007 - 09:17 AM

if i need older versions of the listed libs then its because of that.
i installed every required lib via my package manager, thus i got only the newest versions available, probably not the ones i need

#4 Guest_Azrael Strife_*

Guest_Azrael Strife_*
  • Guests

Posted 05 September 2007 - 09:38 AM

if i need older versions of the listed libs then its because of that.
i installed every required lib via my package manager, thus i got only the newest versions available, probably not the ones i need


From the bugtracker:

Currently UFO2000 uses DUMB library version 0.9.2. But now the latest version of DUMB is 0.9.3 which broke API compatibility


Just follow The Instructions to the letter and you shouldn't have a problem.

#5 Wiesel

Wiesel

    Squaddie

  • Forum Members
  • PipPip
  • 9 posts

Posted 05 September 2007 - 12:55 PM

ok, everything worked just fine.
the issue with server*.cpp could shut of by NOT using scons^^
thank you for your help