Jump to content


Photo

Playing Replays


  • Please log in to reply
7 replies to this topic

#1 marshall

marshall

    Squaddie

  • Forum Members
  • PipPip
  • 2 posts

Posted 22 February 2006 - 10:30 PM

Hi all,

I'm having trouble replaying replays. When I load a replay, the first half-turn (ie. one team) plays, then the TU/health/armour table beneath the mini-map updates, but then nothing else happens! Am I missing something here? These are replays I've saved myself, using the very same version of the game (which is 0.7.1000).

Any help would be much-appreciated. Thanks.

#2 Blood Angel

Blood Angel

    Captain

  • Forum Members
  • PipPipPipPip
  • 513 posts

Posted 23 February 2006 - 03:09 PM

Try looking at where the other team are? Seriously. If it loads and the stattables still work, then it would appear that the whole thing is running OK.

#3 marshall

marshall

    Squaddie

  • Forum Members
  • PipPip
  • 2 posts

Posted 23 February 2006 - 05:18 PM

Try looking at where the other team are? Seriously. If it loads and the stattables still work, then it would appear that the whole thing is running OK.

<{POST_SNAPBACK}>


It's definitely not running OK: the second team never moves.

Also, upon closer inspection, the stat table isn't working quite right: while the first team is moving, the table displays information about the second team. Once the first team is done moving, the table updates to show the first team's data (which appears to be correct).

After the table update, nothing else happens. There's no secret "replay the next turn" command I don't know about, is there?

I'm running the game under Windows. I've tried three different replays, including both network and hotseat games, all with the same result.

#4 Kratos

Kratos

    UFO2000 Staff

  • Moderators
  • PipPipPipPipPip
  • 4,113 posts

Posted 23 February 2006 - 05:42 PM

There no possible way for individual players to fix these issues without contributing to internal programming. :( However, we will look into improvements for replays since they are quite new compared to Ufo2000 stable. At this moment, it isn't a high priority due to that much higher programming issues are requested such as full custom unit implementation, other lua feature enhancements, and basic AI. We appreciate you raising this issue, could you report this in our bugtracker for future reference? :)

#5 Hobbes

Hobbes

    UFO2000 Staff

  • Moderators
  • PipPipPipPip
  • 719 posts

Posted 23 February 2006 - 07:05 PM

Also, upon closer inspection, the stat table isn't working quite right: while the first team is moving, the table displays information about the second team. Once the first team is done moving, the table updates to show the first team's data (which appears to be correct).

<{POST_SNAPBACK}>


There's definitely a problem with the replays. I'll post a report on bugtracker ASAP.

#6 nachtwolf

nachtwolf

    UFO2000 Staff: Leader

  • Moderators
  • PipPipPipPip
  • 310 posts

Posted 24 February 2006 - 10:03 AM

Also, upon closer inspection, the stat table isn't working quite right: while the first team is moving, the table displays information about the second team. Once the first team is done moving, the table updates to show the first team's data (which appears to be correct).

<{POST_SNAPBACK}>


There's definitely a problem with the replays. I'll post a report on bugtracker ASAP.

<{POST_SNAPBACK}>


Actually there's no way to access the changelog and / or repository so we have no tool to know what went wrong and when it went wrong. I remember replays were working back around Beta r960...
Posted Image

#7 Forsaken32

Forsaken32

    Squaddie

  • Forum Members
  • PipPip
  • 6 posts

Posted 28 May 2006 - 10:33 PM

im actually having the same turn, even when i record a replay when im playing a hotseat game for 2 turns by myself as a test. after the first guy ends his turn, the replay stops. i can cycle thru his units but nothing happens. end turn doesnt work.

#8 Sporb

Sporb

    UFO2000 Staff

  • Moderators
  • PipPipPipPip
  • 739 posts

Posted 29 May 2006 - 09:12 PM

replays are still broken AFAIK