Jump to content


Photo

Naming Scheme For Xnet Entries


  • Please log in to reply
10 replies to this topic

#1 rincewind

rincewind

    Programming Department

  • Xenocide Programming Department
  • 541 posts

Posted 10 December 2004 - 03:38 PM

Hi,

those who have followed the appropriate threads in the Programming forum and the one about the xnet-webinterface in CTD already know, that we well have to assign each xnet entry a symbolic name. In the xml file for the xnet this will replace the current name string.
The name to show in he GUI will be looked up in a language file.
The symbolic name will for example be used to assign each entry the right model and for being able to link the right xnet-entry to an inventory item.

Sp what we should agree on her is some form of naming scheme for those names so it doesn't get too confusing.

For now, the generel direction goes somewhere towards ITEM_PLASMA_CANNON, ALIEN_GREY, ALIEN_GREY_AUTOPSY, etc. But there has never been official talk about it.

So here's room for discussion, now...

Greetings,

Rincewind
Posted Image

I love boost!!! The next best thing since the invention of C++.

#2 Guest_Azrael_*

Guest_Azrael_*
  • Guests

Posted 10 December 2004 - 04:46 PM

Hi,

those who have followed the appropriate threads in the Programming forum and the one about the xnet-webinterface in CTD already know, that we well have to assign each xnet entry a symbolic name. In the xml file for the xnet this will replace the current name string.
The name to show in he GUI will be looked up in a language file.
The symbolic name will for example be used to assign each entry the right model and for being able to link the right  xnet-entry to an inventory item.

Sp what we should agree on her is some form of naming scheme for those names so it doesn't get too confusing.

For now, the generel direction goes somewhere towards ITEM_PLASMA_CANNON, ALIEN_GREY, ALIEN_GREY_AUTOPSY, etc. But there has never been official talk about it.

So here's room for discussion, now...

Greetings,

Rincewind

<{POST_SNAPBACK}>


IMO we should keep it simple, if it's not going to be shown to the player, then we should follow a pattern like that you suggested. We could group them in:

ALIEN_[] (live and autopsies)
WEAPON_[] (both Human and Alien, though they could be in two categories)
TANK_[] (tanks)
ITEM_[] (miscellaneous equipment, both Alien and Human, ditto WEAPON)
SHIP_[] (Human aircraft)
UFO_[] (Alien Craft)
FACILITY_[] (Base Facilities)
COMPONENT_[] (UFO components)
RESEARCH_[]

#3 kander

kander

    Sergeant

  • Forum Members
  • PipPipPip
  • 23 posts

Posted 11 December 2004 - 01:11 AM

The idea:

Category and name as taken from the XML file, for simplicities sake. All in uppercase, spaces replaced with underscores, apostroph's (in UFO's) stripped.

WEAPON_HUMAN_PISTOL
WEAPON_LIGHT_RIFLE
WEAPON_HEAVY_RIFLE
WEAPON_AUTO_CANNON
WEAPON_ROCKET_LAUNCHER
WEAPON_GRENADE
WEAPON_PROXIMITY_GRENADE
WEAPON_LASER_PISTOL
WEAPON_LASER_RIFLE
WEAPON_HEAVY_LASER_RIFLE
WEAPON_PLASMA_PISTOL
WEAPON_PLASMA_RIFLE
WEAPON_HEAVY_PLASMA_RIFLE
WEAPON_FUSIONBOMB_LAUNCHER
WEAPON_ALIEN_GRENADE
WEAPON_STUN_LAUNCHER
AMMO_PLASMA_RIFLE_CLIP
AMMO_HEAVY_PLASMA_RIFLE_CLIP
AMMO_STUNBOMB
AMMO_FUSION_BOMB
AMMO_PISTOL_CLIP
AMMO_LIGHT_RIFLE_CLIP
AMMO_HEAVY_RIFLE_CLIP
EQUIPMENT_HIGH_EXPLOSIVE
EQUIPMENT_STUN_BATON
EQUIPMENT_MOTION_SENSOR
EQUIPMENT_FIELD_MEDICAL_KIT
EQUIPMENT_PSIONIC_AMPLIFIER
EQUIPMENT_FLASH_POD
EQUIPMENT_STANDARD_ISSUE_UNIFORM
EQUIPMENT_LIGHT_ARMOR
EQUIPMENT_HEAVY_ARMOR
EQUIPMENT_FLIGHT_ARMOR
EQUIPMENT_PSIONIC_PROBE
EQUIPMENT_SMOKE_GRENADE
FACILITY_BARRACKS
FACILITY_ACCESS_LIFT
FACILITY_SMALL_RADAR
FACILITY_LARGE_RADAR
FACILITY_MISSILE_DEFENSE
FACILITY_LASER_DEFENSE
FACILITY_PLASMA_DEFENSE
FACILITY_FUSION_DEFENSE
FACILITY_GENERAL_STORES
FACILITY_ALIEN_CONTAINMENT
FACILITY_PSIONIC_TRAINING_LAB
FACILITY_GRAV_SHIELD
FACILITY_MIND_SHIELD
FACILITY_HYPERWAVE_DECODER
FACILITY_LABORATORY
FACILITY_HANGAR
FACILITY_WORKSHOP
ARMAMENT_SIDEWINDER
ARMAMENT_TITAN
ARMAMENT_CANNON
ARMAMENT_LASER_CANNON
ARMAMENT_PLASMA_CANNON
ARMAMENT_FUSION_MISSILE_LAUNCHER
AUTOPSY_MORLOCK
AUTOPSY_SATYRIAN
AUTOPSY_VIPER
AUTOPSY_SILABRATE
AUTOPSY_ARTOPOD
AUTOPSY_CLOAK
AUTOPSY_GREY
AUTOPSY_SPAWN
AUTOPSY_RAPTOR
AUTOPSY_VENTRICULANT
AUTOPSY_TERROR_DISK
AIRCRAFT_XC-1
AIRCRAFT_XC-11
AIRCRAFT_XC-2
AIRCRAFT_XC-22
AIRCRAFT_XC-33
RESEARCH_ALIEN_ORIGINS
RESEARCH_MARTIAN_SOLUTION
RESEARCH_CYDONIA_BUST
RESEARCH_ALIEN_RESEARCH
RESEARCH_ALIEN_ABDUCTIONS
RESEARCH_ALIEN_RETALIATION
RESEARCH_ALIEN_SUPPLY
COMPONENT_XENIUM_122
COMPONENT_ALIEN_ALLOY
COMPONENT_NAVAGATION
COMPONENT_XENIUM_REACTOR
COMPONENT_UFO_CONSTRUCTION
COMPONENT_ALIEN_FOOD
COMPONENT_ALIEN_ENTERTAINMENT
COMPONENT_ALIEN_SURGERY
COMPONENT_ALIEN_REPRODUCTION
COMPONENT_ALIEN_EXAMINATION_ROOM
UFO_SMALL_SCOUT
UFO_MEDIUM_SCOUT
UFO_LARGE_SCOUT
UFO_BATTLESHIP
UFO_INTIMIDATOR
UFO_HARVESTER
UFO_SUPPLY_SHIP
UFO_ABDUCTOR
XCAP_CANNON_TANK
XCAP_ROCKET_TANK
XCAP_LASER_TANK
XCAP_PLASMA_HOVERTANK
XCAP_LAUNCHER_HOVERTANK
WEAPON_SYSTEM_LASER
WEAPON_SYSTEM_PLASMA
ALIEN_MORLOCK
ALIEN_SATYRIAN
ALIEN_VIPER
ALIEN_SILABRATE
ALIEN_ARTOPOD
ALIEN_CLOAK
ALIEN_GREY
ALIEN_SPAWN
ALIEN_RAPTOR
ALIEN_VENTRICULANT
ALIEN_TERROR_DISK
INTERROGATION_SOLDIER
INTERROGATION_MEDIC
INTERROGATION_COMMANDER
INTERROGATION_LEADER
INTERROGATION_NAVIGATOR

Edited by kander, 11 December 2004 - 01:18 AM.

&lt; /post&gt;

#4 guyver6

guyver6

    Captain

  • Xenocide Programming Department
  • 599 posts

Posted 11 December 2004 - 06:18 AM

The idea:

Category and name as taken from the XML file, for simplicities sake. All in uppercase, spaces replaced with underscores, apostroph's (in UFO's) stripped.

WEAPON_HUMAN_PISTOL
WEAPON_LIGHT_RIFLE
WEAPON_HEAVY_RIFLE
WEAPON_AUTO_CANNON
WEAPON_ROCKET_LAUNCHER
...cut

<{POST_SNAPBACK}>

That looks impressive, Kander :). Thou please consult that names with Xenocide names, becouse we're not using original UFO names anymore (copyright issues).

Anyway, what about naming Xnet topics different way, as sometime ago Red Knight proposed. In example XNET_* or TOPIC_*, like XNET_WEAPON_AUTO_CANNON (I don't know our name for that weapon :blush1: ). Why? Here comes why:

For items this scheme for naming xnet entries is quite enough. But take an example of RESEARCH_LIVE_NAVIGATOR (example), this can reveal informations about any of the aliens ships, so UFO_something. Having XNET_UFO_* topics distinguish them as xnet entries from UFOs flying around earth. Or an alien research. Researching live alien gives you live alien xnet entry, researchin dead alien gives you an autopsy. How to name researches for those? ALIEN_* or AUTOPSY_*? Having XNET_LIVE_* or XNET_AUTOPSY_* gives you far more flexible design IMHO.

Anyway the researches design isn't quite ready becouse when we was making schemas for static data definition, we've encountered few problems (like everyone of us - Red Knight, Rincewind and me - saw the problem of researches in different way), so as I can remember we have delayed the discussion.

So, my propositios:

ITEM_* - all items, this includes categories like:
ITEM_WEAPON_*,
ITEM_AMMO_*,
or leave it as separate
WEAPON_*
AMMO_*
becouse the "class" of the item is taken from xsd:type attribute in xml file, but we have to make XNet entries names separate from the rest of names, so:
XNET_*, like:
XNET_WEAPON_*, XNET_AMMO_*, etc.

My 2 cents. :)

Guyver
Posted Image
Sourceforge: guyver6
LinkedIn: Andrzej Haczewski
"A good business idea, they say, can be explained in one sentence. Similarly, each program entity should have one clear purpose."

Join #xenocide at irc.freenode.net.

#5 rincewind

rincewind

    Programming Department

  • Xenocide Programming Department
  • 541 posts

Posted 11 December 2004 - 06:25 AM

<snip/>
(discussion of prefixing xnet- entries with XNET_


I'm not quite sure if prefixing them poses other problems, if you have for example a dead alien in your inventory, it would be nice to offer a button leading right to the appropriate xnet-entry (if researched).
If the name is different, we would need another xml-file relating aliens (or items) to their appropriate xnet-entries.
On the other hand, this would allow for more flexibility...

Hmmm....

Rincewind
Posted Image

I love boost!!! The next best thing since the invention of C++.

#6 rincewind

rincewind

    Programming Department

  • Xenocide Programming Department
  • 541 posts

Posted 11 December 2004 - 10:40 AM

<snip/>
(discussion of prefixing xnet- entries with XNET_


I'm not quite sure if prefixing them poses other problems, if you have for example a dead alien in your inventory, it would be nice to offer a button leading right to the appropriate xnet-entry (if researched).
If the name is different, we would need another xml-file relating aliens (or items) to their appropriate xnet-entries.
On the other hand, this would allow for more flexibility...

Hmmm....

Rincewind

<{POST_SNAPBACK}>

Just had a look at basic.xsd. there, most of the prefixes are already defined, once for all kinds of stuff ITEM_, FACILITY_, etc. But also XNET_*.
So I guess, we'll have to use an XNET_-prefix for the xnet-entries and then later have to relate them somewhere to the actual items, etc.

Rincewind
Posted Image

I love boost!!! The next best thing since the invention of C++.

#7 guyver6

guyver6

    Captain

  • Xenocide Programming Department
  • 599 posts

Posted 12 December 2004 - 05:41 AM

<snip/>
(discussion of prefixing xnet- entries with XNET_


I'm not quite sure if prefixing them poses other problems, if you have for example a dead alien in your inventory, it would be nice to offer a button leading right to the appropriate xnet-entry (if researched).
If the name is different, we would need another xml-file relating aliens (or items) to their appropriate xnet-entries.
On the other hand, this would allow for more flexibility...

Hmmm....

Rincewind

<{POST_SNAPBACK}>

I will be possible. That way or another we need to be able to tell that when we have dead alien in store then we can research it and we need to tell what xnet entries are being actived. So this can be easily used for that feature also.

Just had a look at basic.xsd. there, most of the prefixes are already defined, once for all kinds of stuff ITEM_, FACILITY_, etc. But also XNET_*.
So I guess, we'll have to use an XNET_-prefix for the xnet-entries and then later have to relate them somewhere to the actual items, etc.

Rincewind

<{POST_SNAPBACK}>

You know, what is now in schemas doesn't have to stay there forever :D. If something looks like it could be changed, why wouldn't we do that?

Greetings,
Guyver
Posted Image
Sourceforge: guyver6
LinkedIn: Andrzej Haczewski
"A good business idea, they say, can be explained in one sentence. Similarly, each program entity should have one clear purpose."

Join #xenocide at irc.freenode.net.

#8 red knight

red knight

    Xenocide Project Leader

  • Xenocide Inactive
  • 3,310 posts

Posted 12 December 2004 - 08:22 AM

That is part of the refactoring, if you need to change anything better to do it in the beginning. So in short in the scheme now doesnt means in stone.

Greetings
Red Knight
Sourceforge Nick: flois - Federico Andres Lois
Visit my blog at: flois.blogspot.com

Posted Image

Pookie cover me, I am going in.

#9 Guest_Azrael_*

Guest_Azrael_*
  • Guests

Posted 12 December 2004 - 11:07 AM

But some of the names in the XML file are not final yet, so that eventually will have to be changed, like

RESEARCH_MARTIAN_SOLUTION
RESEARCH_CYDONIA_BUST
RESEARCH_ALIEN_RESEARCH
RESEARCH_ALIEN_ABDUCTIONS
RESEARCH_ALIEN_RETALIATION
RESEARCH_ALIEN_SUPPLY
COMPONENT_XENIUM_122
COMPONENT_ALIEN_ALLOY
COMPONENT_NAVAGATION
COMPONENT_XENIUM_REACTOR
COMPONENT_UFO_CONSTRUCTION
COMPONENT_ALIEN_FOOD


Alien Alloys, UFO construction and Cydonia or Bust names haven't yet been decided. I'm not sure how this affects your work, but I'd just let you know :innocent:

#10 guyver6

guyver6

    Captain

  • Xenocide Programming Department
  • 599 posts

Posted 14 December 2004 - 01:30 PM

But some of the names in the XML file are not final yet, so that eventually will have to be changed, like

RESEARCH_MARTIAN_SOLUTION
<cut>
COMPONENT_ALIEN_FOOD


Alien Alloys, UFO construction and Cydonia or Bust names haven't yet been decided. I'm not sure how this affects your work, but I'd just let you know :innocent:

<{POST_SNAPBACK}>


This doesn't affect our work right now, just becouse it's yet to be programmed, so don't worry, the names will be developed in time, and when something will be needed then I'm sure that we'll ask you (CTD) to deliver proper name ;).

Guyver
Posted Image
Sourceforge: guyver6
LinkedIn: Andrzej Haczewski
"A good business idea, they say, can be explained in one sentence. Similarly, each program entity should have one clear purpose."

Join #xenocide at irc.freenode.net.

#11 mikker

mikker

    Artwork Department

  • Xenocide Artwork Department
  • 2,211 posts

Posted 15 December 2004 - 10:49 AM

What about the "get more types - get more info" idea of the live alien research?

so an alien could go into categories:

Field data: Reports from field

Autopsy: Autopsy details

Specimen: Any live

Bagground: Live Leader/Commander

(medic and engineer too)

That would then become.......

ALIEN_GREY_FIELD
ALIEN_GREY_AUTOPSY
ALIEN_GREY_SPECIMEN
ALIEN_GREY_STORY

(I'd imagine that they'd follow each other in 1 doc)

Edited by mikker, 15 December 2004 - 10:50 AM.

Some people say that dreams are a portal to the subconscious. If that is so, I am a very disturbed person.

the truth about scientology