Jump to content


Photo

Sound Initialization Error At Ufo2000 Start Up


  • Please log in to reply
13 replies to this topic

#1 brian-o

brian-o

    Sergeant

  • Forum Members
  • PipPipPip
  • 38 posts

Posted 12 December 2005 - 10:52 PM

the sound used to work on my ufo2000, but when ufo2000 was upgraded to a certain version like almost a year ago, I started getting this error message and the sound stopped working..


"install_mouse
Initializing sound...
Error Initializing sound system: Failed to init digital sound driver
Failed.
initvideo
initpck units"


it was right about the time that the ufo2000 display was changed so that you could see a lot more of the map, the game slowed down a lot about then too and the movement animations started looking off.


any ideas on how I can get the sound working again on ufo2000? I have already tried reinstalling...

#2 Kratos

Kratos

    UFO2000 Staff

  • Moderators
  • PipPipPipPipPip
  • 4,113 posts

Posted 12 December 2005 - 11:03 PM

Does this happen in the latest beta? Getting rid of nasty bugs is a good idea. :wink1:

I am not exactly sure how to fix this problem, sorry. Maybe Serge, our project leader, or somebody with helpful knowledge here can tell you.

#3 brian-o

brian-o

    Sergeant

  • Forum Members
  • PipPipPip
  • 38 posts

Posted 12 December 2005 - 11:17 PM

Does this happen in the latest beta? Getting rid of nasty bugs is a good idea. :wink1:

I am not exactly sure how to fix this problem, sorry. Maybe Serge, our project leader, or somebody with helpful knowledge here can tell you.

<{POST_SNAPBACK}>


getting newer beta versions never fixed it, I have the version with the snakeman and floater and stuff right now..


I'm running win98 with a pentium II 266, 98 megs of ram..

but I just purchased a new computer and maybe it wont have the same problems when I install it on that one in a couple of weeks..

#4 Jezulkim

Jezulkim

    Captain

  • Forum Members
  • PipPipPipPip
  • 194 posts

Posted 13 December 2005 - 08:53 AM

more info here: http://ufo2000.lxnt....view.php?id=368 and probably a solution for you.
That's my team in my avatar!

#5 brian-o

brian-o

    Sergeant

  • Forum Members
  • PipPipPip
  • 38 posts

Posted 13 December 2005 - 01:16 PM

more info here: http://ufo2000.lxnt....view.php?id=368 and probably a solution for you.

<{POST_SNAPBACK}>



thanks! that solution gave me sound again..

however, I have a new set of error messages with that solution, yet I don't know what these errors affect..

now it says:

"install_mouse
Initializing sound...
Loading '$(xcom)/sound/sound1.cat'
loaded ok
Loading '$(xcom)/sound/sound2.cat'
loaded ok
Loading '$(xcom)/sound/sample.cat'
can not load, skipping.
Loading '$(xcom)/sound/sample2.cat'
can not load, skipping.
Loading '$(xcom)/sound/sample3.cat'
can not load, skipping.
initvideo
initpck units"

#6 Blood Angel

Blood Angel

    Captain

  • Forum Members
  • PipPipPipPip
  • 513 posts

Posted 14 December 2005 - 12:05 PM

looks like your samples aren't working. It wouldn't cause any crashes, and if you don't notice any adverse effects on gameplay, win.

#7 brian-o

brian-o

    Sergeant

  • Forum Members
  • PipPipPip
  • 38 posts

Posted 14 December 2005 - 12:49 PM

looks like your samples aren't working. It wouldn't cause any crashes, and if you don't notice any adverse effects on gameplay, win.

<{POST_SNAPBACK}>


what are samples?

#8 Llyr

Llyr

    Sergeant

  • Forum Members
  • PipPipPip
  • 83 posts

Posted 14 December 2005 - 04:00 PM

in this context small portions of sound i'd say ;)

#9 Sporb

Sporb

    UFO2000 Staff

  • Moderators
  • PipPipPipPip
  • 739 posts

Posted 14 December 2005 - 04:14 PM

doesnt UFO use a single raw sample that split into smaller chunks for use in game? perhaps its bung

#10 Serge

Serge

    Project Leader: UFO 2000

  • Xenocide Programming Department
  • 785 posts

Posted 14 December 2005 - 10:47 PM

There are two different sets of sounds for x-com, one is used in dos version, another in windows version:

One is:
Loading '$(xcom)/sound/sound1.cat'
Loading '$(xcom)/sound/sound2.cat'

Another is:
Loading '$(xcom)/sound/sample.cat'
Loading '$(xcom)/sound/sample2.cat'
Loading '$(xcom)/sound/sample3.cat'

So just one of these sets needs to be loaded to have sounds in the game :)

*.cat files are just containers for sound samples (small portions of sound) just like *.pck are containers for sprites. In ufo2000 directory you can find 'soundmap.xml', it describes contents of these cat files.
ufo2000 development team
http://ufo2000.sourceforge.net

#11 Blood Angel

Blood Angel

    Captain

  • Forum Members
  • PipPipPipPip
  • 513 posts

Posted 15 December 2005 - 10:39 AM

So we will either have Sound1.cat and Sound2.cat or Sample1.cat, Sample2.cat and Sample3.cat, depending on what files we have?

#12 Exo2000

Exo2000

    Colonel

  • Moderators
  • PipPipPipPipPip
  • 1,009 posts

Posted 20 December 2005 - 09:56 AM

So we will either have Sound1.cat and Sound2.cat or Sample1.cat, Sample2.cat and Sample3.cat, depending on what files we have?

<{POST_SNAPBACK}>


Indeed. :)
Posted Image

#13 frankenberries

frankenberries

    Squaddie

  • Forum Members
  • PipPip
  • 1 posts

Posted 03 October 2008 - 01:52 AM

I have the same problem...
"Error Initializing sound system: Failed to init digital sound driver"
It works on my xp machine, but when I play on my old win98 comp I get this error.

And of course, the link provided which appears to contain a fix is a broken link :)

#14 Jezulkim

Jezulkim

    Captain

  • Forum Members
  • PipPipPipPip
  • 194 posts

Posted 03 October 2008 - 09:42 AM

Luckily, that page is archived by archive.org:

http://web.archive.o...view.php?id=368
That's my team in my avatar!