Jump to content


Photo

Crosscompilation Woes


  • Please log in to reply
2 replies to this topic

#1 dromede

dromede

    Squaddie

  • Forum Members
  • PipPip
  • 2 posts

Posted 15 December 2007 - 09:12 AM

Hello there. I'm having some problems trying to crosscompile ufo2000. My crosscompile host is a ubuntu box and my target is a sharp zaurus pda. this is what i get:

/usr/bin/ld: skipping incompatible /opt/cross/arm/3.4.6-xscale-softvfp/armv5tel-cacko-linux/lib/libexpat.so when searching for -lexpat
/usr/bin/ld: skipping incompatible /opt/cross/arm/3.4.6-xscale-softvfp/armv5tel-cacko-linux/lib/libvorbisfile.so when searching for -lvorbisfile
/usr/bin/ld: skipping incompatible /opt/cross/arm/3.4.6-xscale-softvfp/armv5tel-cacko-linux/lib/libvorbisfile.a when searching for -lvorbisfile


I'm guessing that this has to do with library version mismatch but i'm not sure. Can anyone help me with this?

Edited by dromede, 15 December 2007 - 09:13 AM.


#2 Kraplax

Kraplax

    Sergeant

  • Forum Members
  • PipPipPip
  • 24 posts

Posted 15 December 2007 - 09:51 AM

Well, i've just tried to compile the game during this night. compilation - no prolems. well, except weird dependencies: with ve Mandriva 2007.0 Free i had to download:
HawkNL168src.tar.gz
liballegro4.2-devel-4.2.0-3mdv2007.0.rpm
+allegro-4.2.0-3mdv2007.0.rpm
+liballegro4.2-4.2.0-3mdv2007.0.rpm
+asked libsvgalib1-1.9.24-2mdv2007.0.rpm
libexpat0-devel-1.95.8-3mdk.rpm

Everything else i could get throug local 4CD-repository of installation disks.
Just remember few things when compiling:
if you're trying to compile something make sure you have all the dependencies wtih their corresponding "devel" packages!
Mind the version - i've tried to get around some dependencies installing their elder or newer versions of "devel" packages, but all i've got - is a great headache.

I suppose you've got this error messages because you've installed libexpat-devel with the version that is not the same as in the libexpat, or just too new/old version, that is not usable to compile this game with.

But, i'm still a newbie in all this, so, that's might be not the answer.

#3 dromede

dromede

    Squaddie

  • Forum Members
  • PipPip
  • 2 posts

Posted 15 December 2007 - 10:20 AM

well, i just compiled libexpat_1.95.8 and it didn't help. I still get the same errors.