Jump to content


Photo

Checkout Problem


5 replies to this topic

#1 master

master

    Squaddie

  • Forum Members
  • PipPip
  • 3 posts

Posted 29 January 2006 - 08:34 AM

Hi,
I try to checkout soucecode from my linux-box like this:
svn co http://svn.projectxe.../xenocide/trunk

But alwas get following error:
svn: REPORT request failed on '/xenocide/!svn/vcc/default'
svn: REPORT of '/xenocide/!svn/vcc/default': 400 Bad Request (http://svn.projectxenocide.com)

I've never used subversion before, so maybe it's just matter of setup?

master

#2 Darkhomb

Darkhomb

    Captain

  • Xenocide Artwork Department
  • 628 posts

Posted 29 January 2006 - 10:25 AM

Hi,
I try to checkout soucecode from my linux-box like this:
svn co http://svn.projectxe.../xenocide/trunk

But alwas get following error:
svn: REPORT request failed on '/xenocide/!svn/vcc/default'
svn: REPORT of '/xenocide/!svn/vcc/default': 400 Bad Request (http://svn.projectxenocide.com)

I've never used subversion before, so maybe it's just matter of setup?

master

<{POST_SNAPBACK}>


Does it copy anyfiles or is that the first thing you get? is that all your typing in? don't you need a destination directory also? NM you don't it takes the base name.

But try checking this out don't know if it will help
http://www.linuxforu...m/man/svn.1.php

#3 master

master

    Squaddie

  • Forum Members
  • PipPip
  • 3 posts

Posted 29 January 2006 - 11:13 AM

Does it copy anyfiles or is that the first thing you get? is that all your typing in? don't you need a destination directory also?  NM you don't it takes the base name.

But try checking this out don't know if it will help
http://www.linuxforu...m/man/svn.1.php

<{POST_SNAPBACK}>


Subversion makes few (it's own) directories and files, but does not checkout any source. I've tried with destination directory parameter also. In fact I found working Windows copy, installed TortoiseSVN and tried again, but with same result!

master

#4 Serge

Serge

    Project Leader: UFO 2000

  • Xenocide Programming Department
  • 785 posts

Posted 29 January 2006 - 11:40 AM

Do you use proxy?
ufo2000 development team
http://ufo2000.sourceforge.net

#5 master

master

    Squaddie

  • Forum Members
  • PipPip
  • 3 posts

Posted 29 January 2006 - 12:11 PM

Finally, I found the reason. My transparent proxy (squid) rejected REPORT. I had to add:

extension_methods REPORT MERGE MKACTIVITY CHECKOUT

to my squid.conf file

master

#6 red knight

red knight

    Xenocide Project Leader

  • Xenocide Inactive
  • 3,310 posts

Posted 29 January 2006 - 08:02 PM

I was going to tell you that :D pretty common when you have a IpCop firewall :D

Greetings
Red Knight
Sourceforge Nick: flois - Federico Andres Lois
Visit my blog at: flois.blogspot.com

Posted Image

Pookie cover me, I am going in.



Reply to this topic