Jump to content


Photo

Screen Is Blurry When Running Ce Under Xp


7 replies to this topic

#1 komora2

komora2

    Rookie

  • New Forum Members
  • Pip
  • 0 posts

Posted 23 February 2009 - 05:54 AM

Hello. I have X-Com CE (windows) version of the game and when I run it either with disabled DDraw or with f0dder's loader the screen seems really blurry It is really difficult to play and my eyes hurt.

I tried using max's patched exe, it turned out to be fine (no more blurriness) but the screen shifts to the left and the geoscape seems choppy.

I can clearly remember I played X-Com 2 absolutely fine with only f0dder's loader a year ago. Now I'm getting this blurred image.

Is there any way to correct it? Increase resolution probably or anything else that helps..

#2 Andy

Andy

    Sergeant

  • Forum Members
  • PipPipPip
  • 53 posts

Posted 23 February 2009 - 07:56 AM

I'm taking a wild shot in the dark here, but maybe the resolution/refresh rate is the problem?

#3 komora2

komora2

    Rookie

  • New Forum Members
  • Pip
  • 0 posts

Posted 23 February 2009 - 08:06 AM

I'm taking a wild shot in the dark here, but maybe the resolution/refresh rate is the problem?

My monitor is 17" 5:4 LCD (Benq FP71V) and it normally runs at 1280x1024@75Hz

When running X-Com it shows the mode is 640x350@70Hz

With max's exe it shows 640x480@60Hz (when there's no any bluriness on the screen)

Edited by komora2, 23 February 2009 - 08:14 AM.


#4 Zombie

Zombie

    Colonel

  • Xenocide Creative-Text Departmen
  • 2947 posts

Posted 23 February 2009 - 08:10 AM

Aye, go Control Panel --> Display --> Settings --> Advanced --> Monitor and check if your refresh rate is 60hz. Flat panel monitors usually need to have their refresh rates adjusted in order to show proper graphics in X-COM.


Edit: I see you posted already. Anyhow, adjust your monitor to 60hz and the game should play fine. :)

- Zombie

Edited by Zombie, 23 February 2009 - 08:30 AM.

The Mr. Grognard of X-COM

Zombie: Empirical data's your only man, when formulating a research plan.
A soldier's death is never in vain if it makes the formula more plain.
A few dozen make a better case for refining that third decimal place.
They call me Zombie because I don't sleep, as I slowly struggle to climb this heap,
of corpses, data points, and trials, but from the top - I'll see for miles!


#5 komora2

komora2

    Rookie

  • New Forum Members
  • Pip
  • 0 posts

Posted 23 February 2009 - 08:24 AM

Aye, go Control Panel --> Display --> Settings --> Advanced --> Monitor and check if your refresh rate is 60hz. Flat panel monitors usually need to have their refresh rates adjusted in order to show proper graphics in X-COM.


Edit: I see you posted already. Anyhow, adjust your monitor to 60hz and the game should play fine. :)

- Zombie

Tried setting it to 60Hz, and even to 70Hz in Windows but it didn't help :-(

I can only guess the main reason is the height resolution and refresh rate - 640x350@70hz

Max's exe somehow corrects them so the game runs at 640x480@60Hz.

But what puzzles me the most is that I used to play the very same X-Com 2: Terror from the Deep on these very same PC and monitor just a year ago with no problems (just used f0dder's loader to correct garbled screen bug). I reinstalled the OS a few times so it's a fresh installation of the game.

Edited by komora2, 23 February 2009 - 08:25 AM.


#6 Zombie

Zombie

    Colonel

  • Xenocide Creative-Text Departmen
  • 2947 posts

Posted 23 February 2009 - 08:32 AM

Yeah try to get the resolution to 640x400 @ 60hz. That's my guess. :)

- Zombie
The Mr. Grognard of X-COM

Zombie: Empirical data's your only man, when formulating a research plan.
A soldier's death is never in vain if it makes the formula more plain.
A few dozen make a better case for refining that third decimal place.
They call me Zombie because I don't sleep, as I slowly struggle to climb this heap,
of corpses, data points, and trials, but from the top - I'll see for miles!


#7 komora2

komora2

    Rookie

  • New Forum Members
  • Pip
  • 0 posts

Posted 23 February 2009 - 08:32 AM

And more, I remember now I never installed monitor's drivers before but now with my new OS installation I installed them for the first time.

I am now trying to get rid of this pesky driver but windows keeps restoring it after reboot :-(

I suspect the monitor's driver is the culprit here.

#8 VPR

VPR

    Sergeant

  • Forum Members
  • PipPipPip
  • 10 posts

Posted 22 March 2009 - 08:30 PM

And more, I remember now I never installed monitor's drivers before but now with my new OS installation I installed them for the first time.

I am now trying to get rid of this pesky driver but windows keeps restoring it after reboot :-(

I suspect the monitor's driver is the culprit here.


Did you get anywhere with this? I'm now having the same trouble since upgrading my graphics card to a Sapphire ATI HD 3850. Xcom 1 & 2 used to work fine under an ATI X800 XL using Catalyst 7.11 drivers (Windows XP). Now I'm using Catalyst 8.12 drivers with this newer card and everything's blurry, resolution and refresh rate show up as 640x480 @ 60Hz, but my monitor (Samsung SyncMaster 940BF) doesn't seem to allow 640x400 yet on my old card with the same monitor this was fine, unless this new card doesn't like the resolution. :huh:

Edited by VPR, 22 March 2009 - 08:31 PM.




Reply to this topic