Jump to content


Photo

X-COM on the DOSBOX


4 replies to this topic

#1 bushwhacker2k

bushwhacker2k

    Rookie

  • New Forum Members
  • Pip
  • 0 posts

Posted 01 August 2010 - 06:34 AM

Well, I've been trying to get UFO (X-COM 1 I suppose) to work on the DOSBOX and I've only made a small amount of progress.

I installed the game to C:\MPS\UFO and try to run UFO.bat, but it lags quite a bit and never goes anywhere.

I don't really know what else to say, but help would be appreciated.

#2 NKF

NKF

    Commander

  • [Global Moderators]
  • PipPipPipPipPipPip
  • 4,798 posts

Posted 01 August 2010 - 11:50 PM

Do you mean the game doesn't even run, or it's just very sluggish?

I'll just proceed assuming the latter. No dos game is going to work out of the box with Dosbox, especially since most computers have different specs. You'll need to adjust Dosbox's emulation speeds until the game is at a speed you are comfortable with.

What you need to do is run Dosbox and the game as you would, then manually adjust the cycles in-game until the game runs at a reasonable pace. I forget the actual key combinations but the Dosbox documentation will have them.

Once you find a speed that you like, note the value down (the cycles are often mentioned the window titlebar), open dosbox's config file, or a custom config file, and replace the default cycles with the values you noted and save it. This way you only have to set it once and every time you launch Dosbox, it'll have the emulation tuned just right for you to play UFO. You can still manually adjust the cycles in game as necessary.

- NKF

Edited by NKF, 01 August 2010 - 11:52 PM.

Lord High Generalissimo Ruler Supreme of Norm's Anti Pedant Society (NAPS).

Number of members: 1

#3 bushwhacker2k

bushwhacker2k

    Rookie

  • New Forum Members
  • Pip
  • 0 posts

Posted 02 August 2010 - 09:16 PM

I actually know how to adjust DOSBOX's speed, with ctrl+F12. My problem was actually the former, it just doesn't run.

It installed fine but once I try to run it and it just goes black DOSBOX and my comp lags like crazy.

No idea where to begin, suggestions?

#4 NKF

NKF

    Commander

  • [Global Moderators]
  • PipPipPipPipPipPip
  • 4,798 posts

Posted 03 August 2010 - 01:04 AM

Not entirely sure what may be wrong, but one thing I do remember back in the old days when PCs could still run the game, the sound setup for many Dos games was a very big culprit with the games not running. EU, TFTD and Apocalypse notwithstanding.

Run the setup.exe program and try setting both the audio and music to the no-sound option and see if it can run. If it does, then all you need to do is adjust the sound settings and things will be fine.


If it was previously set to Soundblaster 16 or Soundblaster Pro, try downgrading to the basic Soundblaster.

See if any of that helps.

- NKF

Edited by NKF, 03 August 2010 - 01:11 AM.

Lord High Generalissimo Ruler Supreme of Norm's Anti Pedant Society (NAPS).

Number of members: 1

#5 bushwhacker2k

bushwhacker2k

    Rookie

  • New Forum Members
  • Pip
  • 0 posts

Posted 03 August 2010 - 11:50 AM

I tried running with no sound + no music and the problem persists : /

Any other ideas? I guess I'll try dling it somewhere, maybe it's corrupted or something...



Reply to this topic