Jump to content


Photo

Mapview+chanjmap


  • Please log in to reply
7 replies to this topic

#1 j'ordos

j'ordos

    Alien Concept Task Force

  • Xenocide Artwork Department
  • 5,059 posts

Posted 31 December 2003 - 05:01 PM

Ran into a strange problem when using chanjmap : I had the central park(city terror site map) active and was looking at the map files with mapview 1.05 when suddenly an error popped up : 'object reference not set to an instance of an object' . This happens when I try to view :
URBAN05
URBAN06
URBAN08

Also happened when I used shootout@mega mall(another city terror site map), but then it didn't happen in big field of wheat (farm map)? (currently only ones I tried)

here's the debug log attached...

Attached Files


Edited by j'ordos, 31 December 2003 - 06:49 PM.

"You can't trust your eyes if your imagination's out of focus" - Mark Twain
"The mind is like an umbrella, it functions best when open" - Walter Gropius
Posted Image
SNEKK BLOG U-LAR MEKHH! GAHGHH! RK!
GRRGH RGGHH SNORRTT GHACKHGG

Now presented in DoubleVision™ (where drunk)

#2 DaiShiva

DaiShiva

    Sergeant

  • Moderators
  • PipPipPip
  • 25 posts

Posted 31 December 2003 - 06:53 PM

I think i know why its doing this. If i remember correctly, chanjmap moves files around so certain maps will get loaded more frequently than others?

If this is the case, then the file the map editor is trying to load does not correspond with the .map file with the same name. Ive looked at those files you listed (thanks for doing that btw) and they are all different heights.

Nothing wrong with your end, i just did not account for situations such as this.

Everything should be okay with this new program i just compiled. Let me know if bad things still happen =)

Edited by DaiShiva, 31 December 2003 - 07:06 PM.


#3 j'ordos

j'ordos

    Alien Concept Task Force

  • Xenocide Artwork Department
  • 5,059 posts

Posted 31 December 2003 - 07:01 PM

Yes that's how it works, thanks. Seeing as I'm still able to continue after the error, is there any negative effect caused by this, other than the error message constantly popping up? :)

edit : on the other hand, big field of wheat didn't give any error at all, while it uses the same map constantly (wheatfield wothout fence, CULTA06 replacing everything), is that something different, because, at least the 2 level building has a different height??

Edited by j'ordos, 31 December 2003 - 07:05 PM.

"You can't trust your eyes if your imagination's out of focus" - Mark Twain
"The mind is like an umbrella, it functions best when open" - Walter Gropius
Posted Image
SNEKK BLOG U-LAR MEKHH! GAHGHH! RK!
GRRGH RGGHH SNORRTT GHACKHGG

Now presented in DoubleVision™ (where drunk)

#4 j'ordos

j'ordos

    Alien Concept Task Force

  • Xenocide Artwork Department
  • 5,059 posts

Posted 31 December 2003 - 07:07 PM

Just ran through the central park urban files with the patched mapview and everything seems to be fine. That was a VERY speedy fix :D
"You can't trust your eyes if your imagination's out of focus" - Mark Twain
"The mind is like an umbrella, it functions best when open" - Walter Gropius
Posted Image
SNEKK BLOG U-LAR MEKHH! GAHGHH! RK!
GRRGH RGGHH SNORRTT GHACKHGG

Now presented in DoubleVision™ (where drunk)

#5 DaiShiva

DaiShiva

    Sergeant

  • Moderators
  • PipPipPip
  • 25 posts

Posted 31 December 2003 - 07:08 PM

Good, good, glad to hear it =)

#6 j'ordos

j'ordos

    Alien Concept Task Force

  • Xenocide Artwork Department
  • 5,059 posts

Posted 07 January 2004 - 09:39 AM

well, after using it some more, a couple more things :) .
Every time I edit something of the map, the editor asks you to save once you move to a next tile, or exit or something like that, which is good, but it KEEPS doing that, so, for example, when I edit URBAN01, and then move to URBAN02 the editor asks me to save. Then I edit nothing of URBAN02 and move to URBAN03, but the editor again asks me to save 'because the map file has been modified'. This happens all the time now, and best is to exit and restart the program :) .

Also, but this might be something I'm missing, is there anyway to 'clear' a map, so it contains nothing? Or to select an area and edit that entire part? (in the topview I mean, when editing tiles). Would make things easier :)

Lastly, the alien routes seem to behave quite different once ingame, but it's quite complex and I'm not entirely sure of what I'm doing, that might have something to do with it ;)
"You can't trust your eyes if your imagination's out of focus" - Mark Twain
"The mind is like an umbrella, it functions best when open" - Walter Gropius
Posted Image
SNEKK BLOG U-LAR MEKHH! GAHGHH! RK!
GRRGH RGGHH SNORRTT GHACKHGG

Now presented in DoubleVision™ (where drunk)

#7 DaiShiva

DaiShiva

    Sergeant

  • Moderators
  • PipPipPip
  • 25 posts

Posted 07 January 2004 - 01:39 PM

The 'asking to save' thing falls under 'annoying' bugs. Ill try and look into that and maybe come up with a smarter way of doing it (cant do it right now as im at work). As for route maps, i suggest reading the section in the online help file that deals with route maps. I did not write it, and only have a basic understanding on how they work, so my help is limited in that respect (i just read/write the file format =)


Route maps

#8 j'ordos

j'ordos

    Alien Concept Task Force

  • Xenocide Artwork Department
  • 5,059 posts

Posted 09 January 2004 - 10:49 AM

Well, I can still live with that bug, and mapview doesn't take much time starting up anyway, so I can still get round it exiting :) . I read the online help file, otherwise I wouldn't even know where to begin, guess I'll have to try to figure out the rest myself :) .
"You can't trust your eyes if your imagination's out of focus" - Mark Twain
"The mind is like an umbrella, it functions best when open" - Walter Gropius
Posted Image
SNEKK BLOG U-LAR MEKHH! GAHGHH! RK!
GRRGH RGGHH SNORRTT GHACKHGG

Now presented in DoubleVision™ (where drunk)