Jump to content


Photo

Minimized Interceptor Bug (fixed!)


3 replies to this topic

#1 BarlowBrad

BarlowBrad

    Rookie

  • New Forum Members
  • Pip
  • 0 posts

Posted 15 August 2007 - 04:19 AM

In case it's important, I'm running WinXP, "UFO Gold" and XCOMUtil 9.60.

I've run into a bug that crashes my game to the desktop when I select a new target for my Skyranger. (I'm using XCOMUtil to allow it to carry a six person crew.)

When the game comes back to the Geoscape from my most recent completed mission (an 6-Person Interceptor against a Supply Ship) it appears that my Skyranger is in "stand-off mode" with a UFO, but it is not, it is only targeting a waypoint. When it reaches the waypoint I can select another waypoint for it to go to. But I can't return to base, can't target another UFO I have on my radar, can't target the nearby alien base I just and I can't target the UFO that just landed near the alien base. Whenever I attempt one these (and ultimately I have to return to base because of fuel) the geoscape appears to zoom out fully and then crash to the desktop.

Has anyone seen this bug before? Is there a workaround? Can it be fixed by editing the save file? If this bug is not new, can someone point me to a thread or link where it is described how to fix it?

I'm attaching the save file in case that helps anyone figure it out. I looked on the suggested Bug FAQ and UFOpaedia Wiki and didn't find anything like it mentioned. I would like to add this bug to the UFOpaedia Wiki someone will help me with it (or at least describe what is going on in more technical terms).

Thanks in advance! :)


Edit: I figured out a way to do some more in game testing to assess the situation and it appears that my Skyranger is locked in combat with a non existent UFO. I have no weapons on the Skyranger, so I can't defeat the UFO, nor can I target it with any of my Interceptors (since it doesn't exist). What seems to trigger the crash is any time the my Skyranger disengages, either through pressing the disengage button or attacking and losing. Any ideas?


Edit 2: Title changed to better reflect the name of the bug. See second post for details.

Attached Files


Edited by BarlowBrad, 20 August 2007 - 12:36 PM.


#2 SaintD

SaintD

    Captain

  • Xenocide Recruit
  • 195 posts

Posted 15 August 2007 - 11:43 AM

In case it matters, I'm running WinXP, "UFO Gold" and XCOMUtil 9.60.

I've run into a bug that crashes my game to the desktop when I select a new target for my Skyranger. (I'm using XCOMUtil to allow it to carry a six person crew.)

When the game comes back to the Geoscape from my most recent completed mission (an 6-Person Interceptor against a Supply Ship) it appears that my Skyranger is in "stand-off mode" with a UFO, but it is not, it is only targeting a waypoint. When it reaches the waypoint I can select another waypoint for it to go to. But I can't return to base, can't target another UFO I have on my radar, can't target the nearby alien base I just and I can't target the UFO that just landed near the alien base. Whenever I attempt one these (and ultimately I have to return to base because of fuel) the geoscape appears to zoom out fully and then crash to the desktop.

Has anyone seen this bug before? Is there a workaround? Can it be fixed by editing the save file? If this bug is not new, can someone point me to a thread or link where it is described how to fix it?

I'm attaching the save file in case that helps anyone figure it out. I looked on the suggested Bug FAQ and UFOpaedia Wiki and didn't find anything like it mentioned. I would like to add this bug to the UFOpaedia Wiki someone will help me with it (or at least describe what is going on in more technical terms).

Thanks in advance! :)



I think I have heard about this bug happening to interceptors sometimes. I can't recall how they get there though. Can you start up a new game and make sure your sky-ranger is OK there? You may need a new skyranger. It's not as bad as you think since the ranger you have out has infinite fuel and good radar coverage. You can use it to cover a blind spot. Of course you will lose the people and weapons stuck in it. I think your only other choice is to abandon the game.

-D

#3 BarlowBrad

BarlowBrad

    Rookie

  • New Forum Members
  • Pip
  • 0 posts

Posted 20 August 2007 - 12:01 AM

I think I have heard about this bug happening to interceptors sometimes.


You were right. I had this happen again so I went back to this post and re-read the "Known Bugs" entry in the UFOpaedia. It finally clicked when I read the section on the Minimized Interceptor Bug. This is what was happening to me.

Rather than restore to an older saved game state like I did last time, I'm going to try to fix this one. bylund posted on the UFOpaedia "This happened to me also. I fixed it by replacing "UIGLOB.DAT" in the save folder with the same file from another saved game (from the same campaign a month earlier)". After reading up a bit on the file I'm going to see if I can just make edits to it to fix the problem. If I can make it work, I'll post back here and put the instructions on the UFOpaedia as well.

Thanks SaintD. :)

#4 BarlowBrad

BarlowBrad

    Rookie

  • New Forum Members
  • Pip
  • 0 posts

Posted 20 August 2007 - 03:29 AM

FIXED IT! It took me a while to figure it out, but I did. You can see a few more details on the UIGLOB.DAT Discussion Page. Here's what I added to the Known Bugs articule under the Minimized Interceptor Bug heading.

Solution: Open up UIGLOB.DAT in a hex editor. Change hex offset 0x06 to 00. This will reset the number of minimized interceptor windows to zero. Your interceptor unit can be selected to either return to base or continue on to complete its ground assault mission. NOTE: Make sure to back up your save game before editing it.



Reply to this topic