Jump to content


Photo

Technical Question. Anyone Ever Had This Happen?


13 replies to this topic

#1 Jokerace

Jokerace

    Sergeant

  • Forum Members
  • PipPipPip
  • 22 posts

Posted 10 December 2003 - 10:07 AM

I started a new game yesterday and saved it in "save slot 1". Then When I do missions I use "save slot 8" to be able to save/restart. (yes I know this is considered "cheating" but i am still trying to "re-learn the game.)

Well anyways I had a problem on a previouis game that if I ever tried to start a new game, after I named my base, I would get a weird "code" screen (with actually code on it) and then it would "auto" load from a previous "saved mission slot"(Not a saved game slot). So what I do now is when I leave the game I "delete" all the info from any "save" folder that isn't an actual game save and it worked for a day or so until now.

Well when I did this last night and just tried to re-start my game (about 10 minutes ago and for 5 more tires there after), it went to the weird "code screen" again. But this time it went to a screen that says something along the lines of "No Data in slot_8" and all I could do was hit enter. Then after about 4 times of hitting enter it would go to the mission ending screen, but it would show that I lost everyone (as if you "abort" a mission with all your people outside of your ship).

Does anyone know a fix for this or is my game just "trashed" now and I have to start over (yet again)?

BTW, I am using the original DOS game not the CE.


P.S. Trevelyan I started this as a new thread as it has nothing to do with my other thread. However, if you think it should be added there please just "move" it over and then I will know for the future to add everything else (no matter what is concerns) to that thread. :)

#2 j'ordos

j'ordos

    Alien Concept Task Force

  • Xenocide Artwork Department
  • 5,059 posts

Posted 10 December 2003 - 10:18 AM

getting the CE seems a good option, if you're able to get it to work, or want to use it :) . Otherwise, reinstall the game, or use dosbox.
"You can't trust your eyes if your imagination's out of focus" - Mark Twain
"The mind is like an umbrella, it functions best when open" - Walter Gropius
Posted Image
SNEKK BLOG U-LAR MEKHH! GAHGHH! RK!
GRRGH RGGHH SNORRTT GHACKHGG

Now presented in DoubleVision™ (where drunk)

#3 Jokerace

Jokerace

    Sergeant

  • Forum Members
  • PipPipPip
  • 22 posts

Posted 10 December 2003 - 10:28 AM

Umm... J'ordes, your answer kind of confuses me. You are saying that I should just get the CE game?(which honestly seems a waste since I haev all (3) original games X-XOM 1,2 & 3 already) Also how would DosBox help this error? ( I have been looking for sites fo DosBox for the last 15 minutes or so, however all the sites have a bunch of file D/L's and don't exactly speficy which is for DosBox and which are other "utils")

BTW I just ran the game again to get the "exact" error.....

"Cannot open game_8/smokbit.dat
Error=no such file or directory"

Then I hit "enter" 4 times and it brings up the "failed mission" end screen.


P.S. Just for the heck of it, I "copied" everything from "Save folder 1" (where I save the game on the Geospace screen) to "Save Folder 8" (where the game says it is looking for info), hoping that it would just "kick" the game into letting me continue. however, it did NOT work, it still beings up the wierd "code", then tries to find that file in "game_8" and then puts on the "failed mission" screen.

Edited by Jokerace, 10 December 2003 - 10:33 AM.


#4 Puasonen

Puasonen

    Creative Text Department

  • Xenocide Inactive
  • 2,911 posts

Posted 10 December 2003 - 10:48 AM

This "wierd code" wouldn't happen to contain the word "page" a lot? Something like

page=08 ghgvj0w8223332
page=08 fdfnvv9vc7v6c

???
There's no need for a sig..

#5 Jokerace

Jokerace

    Sergeant

  • Forum Members
  • PipPipPip
  • 22 posts

Posted 10 December 2003 - 10:55 AM

Oh the "weird code" goes by so fast I cannot read it. It might contain that tho. If you a "fix" for that I can try it and see if that helps, or if you have a way to to "slow" that screen down I can tell you exactly what is says.

All that happens now it the game jumps to a "black" screen and the "weird code" comes up in "green" lines but flys by REAL fast.

I would assume that the "weird code" is a listing of files it is "trying" to load/find, but w/o being able to read them I can tell much else.

P.S. I finally got a version of DosBOx, v6.0, however after I punt in the lines mount c c:\xcom, then c: , and then xcom to run the game. Then DosBox changes screens lie it is going to start showing soemthing, however it just brings up a "black" screen (like where the Microprose name would come up) and just stops responding and I have to "alt-tab-delete" to close it.

Wow I am just feeling so lost now with all this. :(

Edited by Jokerace, 10 December 2003 - 11:24 AM.


#6 Puasonen

Puasonen

    Creative Text Department

  • Xenocide Inactive
  • 2,911 posts

Posted 10 December 2003 - 01:01 PM

Sorry, it means your game is corrupted and you must re-install. You can take backup copy from your save though so you don't lose anything..
There's no need for a sig..

#7 Jokerace

Jokerace

    Sergeant

  • Forum Members
  • PipPipPip
  • 22 posts

Posted 10 December 2003 - 01:59 PM

Oh ok I will just re-install then. Any idea of how this corruption happens? (ie. does saving/restarting a lot on missions make it a higher % of going "corrupt"? Or did I just happen to have bad luck? In that I was ale to get "past" this one time but this time it just stayed corrupt)

#8 Puasonen

Puasonen

    Creative Text Department

  • Xenocide Inactive
  • 2,911 posts

Posted 10 December 2003 - 02:37 PM

You never know when it will corrupt but some say the more you save/reload the higher the possibility. When I had DOS version, my saved games and the whole game corrupted many times.. :( Thanks to CE the problems hasn't come back, at least yet.. That "page error" problem is only at DOS version though so I highly recommend gettin' the CE version.
There's no need for a sig..

#9 Jokerace

Jokerace

    Sergeant

  • Forum Members
  • PipPipPip
  • 22 posts

Posted 10 December 2003 - 06:59 PM

Ok thanks Nyyperoid. However that does bring up another question, where can I get the CE versions? The computer stores around me say they don't carry it anymore and cannot order either.

I did look for posts concerning the CE on this board, but the ones I found had "dead" links now.

#10 Puasonen

Puasonen

    Creative Text Department

  • Xenocide Inactive
  • 2,911 posts

Posted 11 December 2003 - 12:08 AM

http://www.xcomufo.c...?showtopic=2329

Edited by j'ordos, 11 December 2003 - 04:15 AM.

There's no need for a sig..

#11 j'ordos

j'ordos

    Alien Concept Task Force

  • Xenocide Artwork Department
  • 5,059 posts

Posted 11 December 2003 - 04:20 AM

I did look for posts concerning the CE on this board, but the ones I found had "dead" links now.

Could you tell me which posts that would be?

the CE is an updated version of xcom for windows, thus having a higher chance of actually working properly on windows systems :) (after applying a few fixes).

Your problem with dosbox is probably because you have to disable sound in order for it to work...
"You can't trust your eyes if your imagination's out of focus" - Mark Twain
"The mind is like an umbrella, it functions best when open" - Walter Gropius
Posted Image
SNEKK BLOG U-LAR MEKHH! GAHGHH! RK!
GRRGH RGGHH SNORRTT GHACKHGG

Now presented in DoubleVision™ (where drunk)

#12 Robo Dojo 58

Robo Dojo 58

    Colonel

  • Moderators
  • PipPipPipPipPip
  • 1,001 posts

Posted 11 December 2003 - 07:04 AM

Perhaps your "Missdat" folder became corrupted?
I've only had my game corrupted once, so there may be other things going on. Whenever I did something in the battlescape, I would get code (IIRC), and it'd show me the results of the mission before, and it would return to Geoscape.
It probably happens because important files couldn't be deleted or changed between the transition from Geoscape to Battlescape(or vice-versa), so that folder became corrupted. After changing the properties of the folder to get rid of "read-only) and deleting all the files, I got it working again.

*Checking my folder* That's right, I made a backup before I did that. Here's my corrupt missdat, if anyone's interested. Note the date that the files were modified. Some were modified a day apart, while dum.bin hasn't been touched at all. I think that is what caused it. Back up your save files before using this!

Woah, here's the official file, following safer protocol. If you have dl'ed the old file, you are requested to destroy it. It doesn't have enough warnings. :naughty:

Attached Files


Edited by Robo Dojo 58, 11 December 2003 - 07:27 AM.

Posted Image Haha! I'm now the Supreme Commander of X-COM. Time to kiss Earth goodbye.

My first order of business: Homeless people make cheap rookies, and are great at opening UFO doors. Heck, they're so cheap, I'm going to replace all personel with them!
Secondly: This organisation takes too much money to run. Weapon shipments will come from Siberia from now on. Costly maintenance is to be cut on all facilities. That includes venting.
Thirdly: We have a new colonel. His name is Facehugger, he loves aliens, and I want you all to treat him with respect.
Lastly: I'll be in my condo on an undisclosed island, if you need me. Good day.

FMIX-The General Stores

#13 j'ordos

j'ordos

    Alien Concept Task Force

  • Xenocide Artwork Department
  • 5,059 posts

Posted 11 December 2003 - 07:23 AM

... it would "auto" load from a previous "saved mission slot"(Not a saved game slot). So what I do now is when I leave the game I "delete" all the info from any "save" folder that isn't an actual game save...

I thought he meant the missdat folder with the 'saved mission slot', but I could be wrong :) . In that case, that could work (deleting the missdat folder, I mean)
"You can't trust your eyes if your imagination's out of focus" - Mark Twain
"The mind is like an umbrella, it functions best when open" - Walter Gropius
Posted Image
SNEKK BLOG U-LAR MEKHH! GAHGHH! RK!
GRRGH RGGHH SNORRTT GHACKHGG

Now presented in DoubleVision™ (where drunk)

#14 Jokerace

Jokerace

    Sergeant

  • Forum Members
  • PipPipPip
  • 22 posts

Posted 11 December 2003 - 09:14 AM

Thank you to everyone for all the help. I have now gotten copies of XCOM 1 & 2 CE games. Hopefully that will fix all my problems and I won't be asking so many questions.

I just deleted all my "old" game stuff and am starting over "clean" with the CE editions.

Once again thank you to everyone for your help and kindness. :)



Reply to this topic