Jump to content


X-com 1 Color Problems


10 replies to this topic

#1 Guest_Furous George_*

Guest_Furous George_*
  • Guests

Posted 28 June 2003 - 10:44 PM

I've browsed the forum and haven't seen this problem posted yet.

I'm playing X-Com 1 with the WinXP fix and everything's fine ... except usually after a few minutes into the game the colors get all screwy. Like bright pink, yellow, purple etc. No distortion or scrambling ... just weird colors. I tried setting my desktop to lower color depths (i.e. 256, 16-bit) but it didn't work.

Anyone got any suggestions? Thanks. :huh:

#2 Micah

Micah

    Colonel

  • [[Administrators]]
  • PipPipPipPipPip
  • 2,291 posts

Posted 28 June 2003 - 11:37 PM

Does this ever happen with any other program/game? Hve you tried xcom2?

#3 Guest_Furious George_*

Guest_Furious George_*
  • Guests

Posted 29 June 2003 - 09:42 PM

Nope, only this one.

#4 c4t

c4t

    Captain

  • Forum Members
  • PipPipPipPip
  • 233 posts

Posted 30 June 2003 - 11:53 PM

ive had this problem before too, it only happens once in a while after i alt tab out, when i come back in all the colors are destorted, tell me, is your mouse blue? if it is then the probly may be fixed by alt tabbing in and out over and over again, make sure it gets fully to the desktop. does it do it at a certain point or is it random?
Rawr.

"Please, think of the kittens."

#5 Guest_CthulhuDragon_*

Guest_CthulhuDragon_*
  • Guests

Posted 20 October 2003 - 12:41 PM

I have this problem in XP as well. Happens fairly often (every 5 minutes or so). An alt-tab fixes it temporarily, but I'm hoping there is a more permanent solution somewhere.

I'm using an nVidia card if that makes any difference.

#6 j'ordos

j'ordos

    Alien Concept Task Force

  • Xenocide Artwork Department
  • 5,059 posts

Posted 20 October 2003 - 02:04 PM

Are you running a program in the background like a virus scanner or sorts? That might cause such frequent colour fückups.

Edited by j'ordos, 20 October 2003 - 02:04 PM.

"You can't trust your eyes if your imagination's out of focus" - Mark Twain
"The mind is like an umbrella, it functions best when open" - Walter Gropius
Posted Image
SNEKK BLOG U-LAR MEKHH! GAHGHH! RK!
GRRGH RGGHH SNORRTT GHACKHGG

Now presented in DoubleVision™ (where drunk)

#7 Guest_CthulhuDragon_*

Guest_CthulhuDragon_*
  • Guests

Posted 23 October 2003 - 11:23 AM

Well looks like j'ordos had the right idea. It wasn't a virus scanner, but appears to be the wallpaper changer power toy for XP, since disabling that the color hasn't gone bad once.

A big change from once every five minutes or so.

#8 Guest_DBNow_*

Guest_DBNow_*
  • Guests

Posted 10 January 2005 - 04:07 PM

I have this problem too. I cannot make any sense of it. I disabled my firewall, changed my wallpaper to a constant (non-changing image), changed my screen saver to a simpler scheme and disabled my anti-virus protection. Still, I have no luck. Any suggestions?

#9 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 30 June 2005 - 08:48 PM

I've browsed the forum and haven't seen this problem posted yet.

I'm playing X-Com 1 with the WinXP fix and everything's fine ... except usually after a few minutes into the game the colors get all screwy.  Like bright pink, yellow, purple etc.  No distortion or scrambling ... just weird colors.  I tried setting my desktop to lower color depths (i.e. 256, 16-bit) but it didn't work. 

Anyone got any suggestions?  Thanks.  :huh:

<{POST_SNAPBACK}>



I have the same problem, it occasionally happens when I play starcraft as well. Cant for the life of me figure out what the heck is causing it or how to fix it.

Only thing I can suggest is to play X-com2: Terror from the deep. The problem still happens but it tends to be localized on weapons and armor, making the game much more playable. The only other thing it effects is the UFOpedia, which is damn near unreadable unless you squint really hard.

edit: Well you looks like you solved your problem, I'll have to try shutting everything down when I get home

#10 Judge_Deadd

Judge_Deadd

    Captain

  • Forum Members
  • PipPipPipPip
  • 270 posts

Posted 01 July 2005 - 02:08 AM

Did you try DosBox?
"This is why I love subtle humour, it's as dirty or as clean as the reader's own mind." -- Sinscale17

"Just imagine if you were really the XCOM commander. You'd build defence modules like there was no tomorrow. Because if you didn't, there really would be no tomorrow!" -- Aiki-Knight

#11 Dalokar

Dalokar

    Rookie

  • Forum Members
  • Pip
  • 0 posts

Posted 03 July 2005 - 12:46 PM

I have the same problem,  it occasionally happens when I play starcraft as well. Cant for the life of me figure out what the heck is causing it or how to fix it.

Only thing I can suggest is to play X-com2: Terror from the deep.  The problem still happens but it tends to be localized on weapons and armor, making the game much more playable. The only other thing it effects is the UFOpedia, which is damn near unreadable unless you squint really hard.

edit: Well you looks like you solved your problem, I'll have to try shutting everything down when I get home

<{POST_SNAPBACK}>



yay, I fixed my copy. Turned out I didnt have it set to Windows 95 compatability and 256 color mode.

To set those, right click on the shortcut to the program and go to the "compatability" tab and check the "256 color" box, then select "windows 95" from the drop down menu.



Reply to this topic