Jump to content


Photo

Running Tftd In Dosbox - Mini Guide.


10 replies to this topic

#1 kasumimi

kasumimi

    Sergeant

  • Forum Members
  • PipPipPip
  • 16 posts

Posted 31 March 2009 - 10:19 AM

Couldn't find and solution to my issues here on the forum. Yes, I searched lots but couldn't come up with anything :x Except enjoying Xcom1 to it's fullest :)

I'd liketo share a couple of things I learned while running the DOS version of TFTD, since I never managed to play the windows one. The mouse scroll (and almost everything else) was lightning speed and never found a solution around it.

Anyway, at first I ran "terror.exe" and decreased CPU cycles by a percentage manually. Cntrl+F11 or F12. I had to bring it down to 5% to be able to play but still, the feeling was slugish and the speed wasn't smooth. After reading quite a few DOSbox threads I found out that if you set the CPU cycles manually things change.. for the best!
I now run TFTD on a 2.6(3.7) duo core with 3g and 9800gtx as smooth as possible.

Open DOSbox.conf and scroll down untill you find "Core" and "Cycles". Then set:
core=dynamic
cycles=40000


The range of the cycles differs on machines. I started from 15000 till I ended up to 40000. Don't even bother with trying and slowing your machine with ctrlF11+F12. It apparently works differently from setting the cycles manually.

But there is another thing that really made me enjoy the game even more (besides the bloody scroll and geoscape not being hyper speed...).
DOSbox includes several "scaler" options to increase resolution. There are several settings for this, I guess you need to try and find out which one fits your PC best.
Scroll down to the "render" section of DOSbox.conf. Tweak "Scaler until you find what it best". I run with "scaler=advmame3x". The resolution is as good as ET's Xcom1 patch that you get from tweaking the registry, really sweet :)

Those are really simple stuff and probably most of you already knew this. But there are many new people who use DOSbox and try play fantastic old games everyday, I hope someone finds this thread useful.

Now if anyone knows why ET's patch is giving me a blank screen when I run the game please help!

*Edit*: Typos and typos :E

Edited by kasumimi, 01 April 2009 - 06:37 AM.


#2 NKF

NKF

    Commander

  • [Global Moderators]
  • PipPipPipPipPipPip
  • 4,798 posts

Posted 31 March 2009 - 10:47 PM

Much of this will already have been discussed, but a quick and easy guide to operating (not setting up - that's another guide entirely) is definitely worth pinning for future reference.

You can change how much ctrl+F11 and F12 adjust your cycles by setting the cycleup and cycledown settings in the dosbox.conf file (or your custom conf file).

As per the comment, if you use values under 100, it'll act as a percentage and adjust the current cycles by a percentage. I used 500 for each so that it would slow or speed the cycles down at the same settings.

The scaler is nice however keep in mind that some of the smaller images like the Geoscape icons or even some small text might look a little different than what they should be thanks to the anti aliasing. Still, visually appealing.



- NKF

Edited by NKF, 31 March 2009 - 10:49 PM.

Lord High Generalissimo Ruler Supreme of Norm's Anti Pedant Society (NAPS).

Number of members: 1

#3 Jezulkim

Jezulkim

    Captain

  • Forum Members
  • PipPipPipPip
  • 194 posts

Posted 01 April 2009 - 04:38 AM

Hello, I'd like to share my settings for TftD.

[cpu]
core=auto
cycles=auto

[sdl]
fulldouble=true
output=opengl

With these settings the game runs really smoothly, no slowdows, smooth scrolling in battlescape.
That's my team in my avatar!

#4 kasumimi

kasumimi

    Sergeant

  • Forum Members
  • PipPipPip
  • 16 posts

Posted 01 April 2009 - 06:43 AM

Hello, I'd like to share my settings for TftD.

[cpu]
core=auto
cycles=auto

[sdl]
fulldouble=true
output=opengl

With these settings the game runs really smoothly, no slowdows, smooth scrolling in battlescape.


Don't you decrease CPU performance or cycles in any way? O.o

Just tried those settings and everything is lightning speed :(

#5 Jezulkim

Jezulkim

    Captain

  • Forum Members
  • PipPipPipPip
  • 194 posts

Posted 01 April 2009 - 07:38 AM

What version of dosbox are you using? I'm using 0.72.

Maybe there's something else in my config that is required for normal speed, I'm posting my full configuration file for TFTD.

# This DOSBox configuration file was automatically created by D-Fend Reloaded.
# Changes made to this file will NOT be transfered to D-Rend Reloaded profiles list.
# D-Fend Reloaded will delete this file from temp directory on program close.

# Config file for profile "X-COM: Terror from the Deep"

[sdl]
fullscreen=true
fulldouble=true
fullresolution=1280x1024
windowresolution=original
output=opengl
autolock=false
sensitivity=200
waitonerror=true
usecancodes=true
priority=higher,normal
mapperfile=D:\DOSBox-0.72\D-Fend Reloaded\mapper.txt

[dosbox]
machine=vga
captures=D:\DOSBox-0.72\D-Fend Reloaded\Capture\X-COM Terror from the Deep\
memsize=63

[render]
frameskip=0
aspect=false
scaler=normal2x

[cpu]
core=auto
cycles=auto
cycleup=500
cycledown=20

[mixer]
nosound=false
rate=44100
blocksize=2048
prebuffer=10

[midi]
mpu401=intelligent
device=default
config=

[sblaster]
sbtype=sb16
sbbase=220
irq=7
dma=1
hdma=5
mixer=true
oplmode=auto
oplrate=44100

[gus]
gus=true
gusrate=44100
gusbase=240
irq1=5
irq2=5
dma1=1
dma2=1
ultradir=C:\ULTRASND

[speaker]
pcspeaker=false
pcrate=22050
tandy=auto
tandyrate=22050
disney=false

[dos]
xms=true
ems=true
umb=true
keyboardlayout=FI

[joystick]
joysticktype=none
timed=true
autofire=false
swap34=false
buttonwrap=true

[serial]
serial1=dummy
serial2=dummy
serial3=disabled
serial4=disabled

[autoexec]
@echo off
SET PATH=Z:\
keyb FI 437 > nul
mount C "D:\DOSBox-0.65\CROOT~1\"
C:
cd\
cd \TFTD
TERROR.COM
exit

That's my team in my avatar!

#6 kasumimi

kasumimi

    Sergeant

  • Forum Members
  • PipPipPip
  • 16 posts

Posted 01 April 2009 - 11:31 AM

This is interesting.
I'm using 0.72 aswell and with your setting it's flipping to hard even Matrix's Neo couldn't play it.
Maybe you are using an older PC?

Edited by kasumimi, 01 April 2009 - 11:32 AM.


#7 Jezulkim

Jezulkim

    Captain

  • Forum Members
  • PipPipPipPip
  • 194 posts

Posted 01 April 2009 - 01:24 PM

Yes my PC is probably older than yours, but our hardware is quite similar. I have core 2 duo e6400 (2.13GHz) and 7600GT.

I don't know if it matters but I'm playing TftD version 2.1 (http://www.strategyc...ex.php?dlid=192) If you're playing version 2.0/1.4 I don't think this matters then.

Maybe your CPU is just so much more powerful..

Edited by Zombie, 01 April 2009 - 11:41 PM.
Merged posts.

That's my team in my avatar!

#8 EvilKitty

EvilKitty

    Squaddie

  • Forum Members
  • PipPip
  • 1 posts

Posted 20 November 2009 - 01:44 PM

I'm having difficulty getting it to install properly. I've mounted my CD drive and run the install.exe on the cd through DOSBox. It says I've installed everything properly, but when I run TERROR.BAT, all I get is a black screen. Any ideas?

Edit: Nevermind, figured it out. Had messed up soundblaster settings, that's why.

Edited by EvilKitty, 20 November 2009 - 02:04 PM.


#9 Drunx

Drunx

    Rookie

  • New Forum Members
  • Pip
  • 0 posts

Posted 08 February 2010 - 01:25 PM

Hy All!

I need your help!

i have the total pack version v 1.05 of this gorgious game!

Fortunately after hard work:D it works properly .

I have a 2200+ (1.5ghz CPU. ) 768 ram, ati rad 9250 vga but the game in dos box version works slowly:S


i am not a pc hardcore so could you help me?

The main problem is that the game works but e.g during the Battle Scene the Agents open the doors etc. as a Snail!!! they are so slow in the game is eing on max!

I tried cpu cycles from 1000 to max


SOMEONE PLS HELP!

thx a lot.
Janos From Hungary

#10 Zombie

Zombie

    Colonel

  • Xenocide Creative-Text Departmen
  • 2,947 posts

Posted 09 February 2010 - 09:36 PM

Not sure what the issue is, but have you checked the options button in-game? There are speed settings in there for how fast you or the aliens move and fire. Perhaps one of them is set too slow? ;)

- Zombie
The Mr. Grognard of X-COM

Zombie: Empirical data's your only man, when formulating a research plan.
A soldier's death is never in vain if it makes the formula more plain.
A few dozen make a better case for refining that third decimal place.
They call me Zombie because I don't sleep, as I slowly struggle to climb this heap,
of corpses, data points, and trials, but from the top - I'll see for miles!


#11 kasumimi

kasumimi

    Sergeant

  • Forum Members
  • PipPipPip
  • 16 posts

Posted 04 May 2010 - 06:06 PM

Hy All!

I need your help!

i have the total pack version v 1.05 of this gorgious game!

Fortunately after hard work:D it works properly .

I have a 2200+ (1.5ghz CPU. ) 768 ram, ati rad 9250 vga but the game in dos box version works slowly:S


i am not a pc hardcore so could you help me?

The main problem is that the game works but e.g during the Battle Scene the Agents open the doors etc. as a Snail!!! they are so slow in the game is eing on max!

I tried cpu cycles from 1000 to max


SOMEONE PLS HELP!

thx a lot.
Janos From Hungary



Three moth late reply!! :( I saw this too late :x

I will reply in case someone else ever gets the same problem and find his way to this thread, although I'm not 100% sure what the problem is.
The "total pack" version of Xcom doesn't have an option to change cpu core emulation (auto, dynamic etc), which needs to be set to dynamic to solve your problem (not 100% that's the issue though :x). unfortunately, I don't know how this can be done manually while still running the game from the total pack launcher menu. I recommend trying to run the game manually through Dosbox and see if that is the issue.



Reply to this topic