Jump to content


Photo

Tftd In Xp, Sorry But I'm Going Nuts!


7 replies to this topic

#1 kasumimi

kasumimi

    Sergeant

  • Forum Members
  • PipPipPip
  • 16 posts

Posted 08 April 2009 - 07:02 AM

I'm being selfish and making a thread with my own issues.
I really tried, really hard to find a solution to make TFTD become playable in XP. I swear, I've read so many threads and replies but it's impossible to find a solution.

Don't get me wrong, the game runs normally, except it's on hyper-super speed and literally unplayable.
I tried using Turbo, affiliating in it and the game to one core. The speed drops to playable levels but it's extremely sluggish, not smooth at all and definitely not fun to play. And even if it that worked playing it on default resolution is impossible after being so spoiled with Xcom1.

I tried ET's patch since it seems to be the best shot. But for some reason it won't work. Screen goes black, processor usage 50% and when I tab out of the black screen and click it again from the taskbar xcom disappears completely. I just can't imagine what is wrong... it makes me a sad panda that the creator of the patch was abducted 3 years ago, so there is really no hope in that.

Run it in Dosbox you say? I have, and finished it too. With decent smoothness and the lovely scaler options. But it just doesn't feel right after finishing Xcom1 on in windows with ET's patch + playstation music + Seb76's mod (keybinds and TFTD doors I love you). It's not as smooth and the sound is so much better in windows version.

In short : How to fix speed and maybe in a parallel universe improve resolution without ET's patch
Please, I beg you, if you have any suggestions please please share. Any hint or tip might help.

I know this is a longshot and that I'm being greedy but I have a psychosis on these things. I even lost some sleep last night on this issue.
And probably I shouldn't be making a thread on this since the above issues aren't special or urgent. I just wonder, does everyone plays TFTD in Dosbox or they just settle with barely being able to run it in windows? Or they just give up like I'm about to do, being romantic and trying to play 15 year old games to their fullest is silly anyway.

#2 nonam

nonam

    Sergeant

  • Forum Members
  • PipPipPip
  • 36 posts

Posted 08 April 2009 - 07:46 AM

You must disable DirectX. I do not know what exactly you need to click because i have russian Windows, but it should be:
Right-click Desktop=>Options(Settings?)=>Settings(Options?)=>Advanced=>Diagnostics=>drag the bar to the far left, it turns off DirectX. Be aware not to run anything that uses DirectX on this setting!

Posted Image


#3 kasumimi

kasumimi

    Sergeant

  • Forum Members
  • PipPipPip
  • 16 posts

Posted 08 April 2009 - 09:37 AM

I've tried this before. I gave it one more try though. Disabled hardware acceleration + write combining and rebooted. No change whatsoever : ()

Or maybe you mean this should be used combined with something else?
Btw I run on 3.6 dual core clocked - 3gigs and 9800gtx+ on win xp 32bit.

#4 nonam

nonam

    Sergeant

  • Forum Members
  • PipPipPip
  • 36 posts

Posted 10 April 2009 - 09:33 AM

Dual core is the core of the trouble. Maybe you could get your computer infected by a performance-slowing virus :devillaugh: :devillaugh:

Posted Image


#5 kasumimi

kasumimi

    Sergeant

  • Forum Members
  • PipPipPip
  • 16 posts

Posted 10 April 2009 - 11:55 AM

:Cry: :Cry:

#6 NKF

NKF

    Commander

  • [Global Moderators]
  • PipPipPipPipPipPip
  • 4,798 posts

Posted 10 April 2009 - 06:19 PM

If I remember correctly, for dual processor PCs, you could go to the task manager and set the core affinity so that it only uses one processor.

I don't have a dual processor so can't test this out.

- NKF
Lord High Generalissimo Ruler Supreme of Norm's Anti Pedant Society (NAPS).

Number of members: 1

#7 Sectoid Scientist

Sectoid Scientist

    Squaddie

  • Forum Members
  • PipPip
  • 7 posts

Posted 26 October 2011 - 11:25 AM

Kasumimi,
You said you set the games executable to process affinity 1. Did you use use Task Manager to do that?. For people with multicore/multicpu systems try out this program, it works great- ImageCFG.

If your using the Collector's Edition of TFTD use the CE Video Bug and Sound fix found at XCOMUFO. Read the games FAQ while your at it.

Edited by Sectoid Scientist, 26 October 2011 - 11:27 AM.


#8 kasumimi

kasumimi

    Sergeant

  • Forum Members
  • PipPipPip
  • 16 posts

Posted 26 July 2012 - 12:52 PM

I'm back in my thread 3 years later to update (in case someone bumps into this).

This wonderful guy called Tycho is updating Seb's UFOextender into working for TFTD. This means we get goodies like auto-equip, soldier stats during equip, d3d windows mode, mp3 music etc etc.
So for anyone trying to re-play TFTD download and use http://www.strategyc...ftdextender-1x/ and enjoy the game even more.



Reply to this topic