Jump to content


Photo

Equipment lost when entiring phase 2


3 replies to this topic

#1 Guse

Guse

    Rookie

  • New Forum Members
  • Pip
  • 0 posts

Posted 20 November 2009 - 04:36 PM

Sent my aquanauts on a terror mission and everything was going nice. It was my first mission with MC disruptors along and it was a mixed crew so I brought the whole package. Canons, drills, flares, tazers and grenades. My rookie psi boys weren't that succesful but my experienced shooters cleared that upper deck in no time.

But then all my MC disruptors and MC readers vanishes between first and second part. I have a save but no idea how to avoid it. Tried putting them in the backpacks and still all was lost except one reader. Tried running the psi boys back to the Triton and still no disruptors for second phase.

Could it be related to how much equipment the team as a whole carries?

Any ideas what I should try?

I think I have xcomutil. I downloaded a pack (xcom total pack 1.5) with some kind of loader and it worked right away. Some things are different like the Triton can have a cannon and the attack subs have room for a few aquanauts. Hard to know what is the patches and what is the util, last go I had at this game was when it was delivered on floppies...

Thanks for any suggestions

#2 Zombie

Zombie

    Colonel

  • Xenocide Creative-Text Departmen
  • 2,947 posts

Posted 20 November 2009 - 09:03 PM

I haven't encountered any missing equipment between missions on an unmodified TFTD copy. XcomUtil is probably messing with stuff between the two parts, that's my thought. :)

- Zombie
The Mr. Grognard of X-COM

Zombie: Empirical data's your only man, when formulating a research plan.
A soldier's death is never in vain if it makes the formula more plain.
A few dozen make a better case for refining that third decimal place.
They call me Zombie because I don't sleep, as I slowly struggle to climb this heap,
of corpses, data points, and trials, but from the top - I'll see for miles!


#3 NKF

NKF

    Commander

  • [Global Moderators]
  • PipPipPipPipPipPip
  • 4,798 posts

Posted 20 November 2009 - 09:33 PM

Very likely has XComutil running its backbone - the plain vanilla Triton never come with a cannon hard point.

XComutil does indeed do a little work on the equipment for two-parter missions. This was put in because there is an existing bug in the game that causes anything that's not carried between a 2-parter to vanish forever. That includes all of your spare equipment in the Triton. Most likely XComutil has done some brute force reorganization and sent almost all of the equipment back to base.

- NKF

Edited by NKF, 20 November 2009 - 09:34 PM.

Lord High Generalissimo Ruler Supreme of Norm's Anti Pedant Society (NAPS).

Number of members: 1

#4 Guse

Guse

    Rookie

  • New Forum Members
  • Pip
  • 0 posts

Posted 22 November 2009 - 05:46 PM

Very likely has XComutil running its backbone - the plain vanilla Triton never come with a cannon hard point.

XComutil does indeed do a little work on the equipment for two-parter missions. This was put in because there is an existing bug in the game that causes anything that's not carried between a 2-parter to vanish forever. That includes all of your spare equipment in the Triton. Most likely XComutil has done some brute force reorganization and sent almost all of the equipment back to base.

- NKF

Unfortunately it was not sent back to base. It was lost.

After several attempts I managed to get it sent back to base by running back to the Triton and drop the disruptors and readers on my spare equipment. Not an ideal solution but at least I did not have to manufacture them again. I still had enough Aquanauts with weapons to finish the mission.



Reply to this topic