Jump to content


Photo

How to determine my TFTD version and how to apply patch?


2 replies to this topic

#1 zak88lx

zak88lx

    Squaddie

  • Forum Members
  • PipPip
  • 4 posts

Posted 20 July 2010 - 03:04 PM

I'm currently playing the DOS (floppy disk) version of X-COM TFTD through DOSBox 0.74.
The game runs smooth and the sound effects/music are perfect.

I have a two part question:

1.) How do I determine what version I'm currently running (DOS - Floppies).
2.) Can I use the TFTD 2.1 patch on my DOS - Floppy disk version?

I have downloaded the TFTD 2.1 patch from Strategy Core but I don't see any instructions and some of the files look CD-Rom related!?

Thanks,
Zak

Edited by zak88lx, 20 July 2010 - 03:26 PM.


#2 NKF

NKF

    Commander

  • [Global Moderators]
  • PipPipPipPipPipPip
  • 4,798 posts

Posted 21 July 2010 - 01:29 AM

If you installed your game from the floppies, then it's very likely you've got v1.0. The easiest way to tell is with the Ion Beam Accelerators. Capture a sub that has landed and make sure you don't damage the IBA units when fighting in the sub.

If the appear for research right away, then you have v2.0. If you have to capture and research a lobsterman navigator to get them, then you have v1.0.


Don't worry too much about the cd-rom side of things. The game's designed to run off the hard drive or to run partially off the hard-drive with most of its data files stored elsewhere (in this case, the cd-rom). You'll notice the patch includes two directories TFTDHD and TFTDCD. HD refers to the hard-disk installation, which covers the floppy version.

I think all you need to do is copy everything into your game directory and run the update.com file through dosbox.

- NKF
Lord High Generalissimo Ruler Supreme of Norm's Anti Pedant Society (NAPS).

Number of members: 1

#3 zak88lx

zak88lx

    Squaddie

  • Forum Members
  • PipPip
  • 4 posts

Posted 21 July 2010 - 02:07 PM

If you installed your game from the floppies, then it's very likely you've got v1.0. The easiest way to tell is with the Ion Beam Accelerators. Capture a sub that has landed and make sure you don't damage the IBA units when fighting in the sub.

If the appear for research right away, then you have v2.0. If you have to capture and research a lobsterman navigator to get them, then you have v1.0.


Don't worry too much about the cd-rom side of things. The game's designed to run off the hard drive or to run partially off the hard-drive with most of its data files stored elsewhere (in this case, the cd-rom). You'll notice the patch includes two directories TFTDHD and TFTDCD. HD refers to the hard-disk installation, which covers the floppy version.

I think all you need to do is copy everything into your game directory and run the update.com file through dosbox.

- NKF


Thanks NKF!
Instead of running the .exe file from the patch I just manually copied the contents of the TFTDHD folder into my XCOM directory.
This seemed to work fine.
I was hoping the game version would show up somewhere for a visual confirmation.



Reply to this topic