Jump to content


Photo

Ogre Meshviewer


  • Please log in to reply
4 replies to this topic

#1 rincewind

rincewind

    Programming Department

  • Xenocide Programming Department
  • 541 posts

Posted 03 March 2005 - 08:00 AM

Hi,
Using this URL: http://www.ogre3d.or...wdownload&cid=3, you can find the Ogre MeshViewer in a precompiled version.
It makes it really easy to see how models will look ingame and also tweak material settings if you want to tackle Ogre's material scripts (it's not that hard, so if you are interested, head over to ogre3d.org and take a look at their manual).

You can either use the Ogre-Exporters available on the Ogre page or, preferably, export to dotXSI and use the XSItoOgre converter available here on the forums.

Greetings,

Rincewind

Edited by rincewind, 03 March 2005 - 08:04 AM.

Posted Image

I love boost!!! The next best thing since the invention of C++.

#2 FirestarXL

FirestarXL

    Squaddie

  • Forum Members
  • PipPip
  • 9 posts

Posted 04 March 2005 - 03:57 AM

Ah thanks, that will indeed be handy. If we can get the smoothing groups exported correctly then it will be handy to see how they do translate into Ogre.

#3 Beetle

Beetle

    Programming Department

  • Xenocide Inactive
  • 350 posts

Posted 09 March 2005 - 04:24 PM

I have tested it on my comp and unfortunately i have to said that it's very unstable on my machine :(

Beetle
Posted Image

#4 SupSuper

SupSuper

    Programming Department

  • Xenocide Programming Department
  • 2,418 posts

Posted 09 March 2005 - 04:37 PM

I have tested it on my comp and unfortunately i have to said that it's very unstable on my machine :(

Beetle

<{POST_SNAPBACK}>

tried it on the MediumScout mesh and it works fine. also works as a material editor.

too bad, now you will never know the ancient secrets of supsupers long gone avatar ;)

Posted Image


#5 Beetle

Beetle

    Programming Department

  • Xenocide Inactive
  • 350 posts

Posted 10 March 2005 - 08:30 AM

Sometimes program crushes without reason while loading object, but when i open it once agian and load model again everything works. Sometimes also crush without specifc action, strange, but even with that bug it is good idea to check your models in that program.

Beetle

P.S. Today i maneged to export model form maya 6.0 to ogre :) Any body know if there is some function i maya to recalculate face normals ???
Posted Image