Jump to content


Ufo Defense Graphics All Scrambled


15 replies to this topic

#1 Guest_Rich_*

Guest_Rich_*
  • Guests

Posted 14 June 2003 - 07:59 PM

Hey everybody. I am having a problem with X-com if you havent guessed by now. I am running windows 2000 on radeon 8500. For some reason whenever I start x-com, all the images are distorted and near the top of the screen. I know what they look like because I've played it on other OS's but the game is unplayable. I just press the bottom button twice and it will close. Please help me I want to play this awsome game again. I downloaded the fix on this site, and it says cannot create process. When I change the name to UFO defense, it says 'couldn't read process memory.'

note: original exe = 'ufo.exe'
also: it is a downloaded version as I lost the disk years ago.

Rich
bob_2010_<!!!!spamprotection!!!!>@hotmail.com

#2 Micah

Micah

    Colonel

  • [[Administrators]]
  • PipPipPipPipPip
  • 2,290 posts

Posted 14 June 2003 - 10:50 PM

My first suggestion would be to make sure the name of the exe is actually "UFO Defense.exe" with a capital "D". Next, look around for a link to a copy of the CE somebody posted in this Tech Help area.

#3 Guest_Rich_*

Guest_Rich_*
  • Guests

Posted 14 June 2003 - 11:04 PM

Yep that did it thanks. Now my problem is that some of the game is off the screen. I am using an LCD but hitting auto does not fix the problem. I also cannot set the horizontal and vertical size, but only their positions. Also in game my resolution according to my monitor is 300x700 (something like that) or vice versa.

Thanks,
Rich

#4 Puasonen

Puasonen

    Creative Text Department

  • Xenocide Inactive
  • 2,911 posts

Posted 07 August 2003 - 10:35 PM

DAMN! Have the same problem.. I have x-com 1 CE and had that scrambled graphics problem. After downloading the fix, it said that 'couldn't read process memory'
I read this topic and changed the name to UFO Defense.exe, probably the name is now right 'cause the error message changed. Now it says 'Couldn't ReadProcessMemory' Yes, that readprocessmemory is without spaces.. In FAQ it says if you have dos version and try to use the fix, it gives this error message but I'm positive it's CE! Can ANYONE help? It worked before I upgraded my computer. (had XP then also so that hasn't changed)
There's no need for a sig..

#5 GreatGold

GreatGold

    Creative Text Department

  • Xenocide Inactive
  • 852 posts

Posted 07 August 2003 - 11:30 PM

Have you two turned OFF DirectDraw?
---
Rule #33:
Celatid venom is a paralytic nerve toxin, not 'happy juice".

---
Posted Image

#6 Puasonen

Puasonen

    Creative Text Department

  • Xenocide Inactive
  • 2,911 posts

Posted 07 August 2003 - 11:51 PM

Nope, that's the next thing I'm gonna try. It's just so much work to change it every time I start and stop playing ufo.
There's no need for a sig..

#7 GreatGold

GreatGold

    Creative Text Department

  • Xenocide Inactive
  • 852 posts

Posted 07 August 2003 - 11:54 PM

It only takes about 20 seconds, and I'm pretty sure it will solve your problem. Give it a try...

Gold
---
Rule #33:
Celatid venom is a paralytic nerve toxin, not 'happy juice".

---
Posted Image

#8 Micah

Micah

    Colonel

  • [[Administrators]]
  • PipPipPipPipPip
  • 2,290 posts

Posted 10 August 2003 - 01:28 AM

Did it work?

#9 Guest_Gunloc0_*

Guest_Gunloc0_*
  • Guests

Posted 23 August 2003 - 12:34 AM

have you tried lowering the perfromance in the properties to the lowest setting?

#10 Guest_Jim69_*

Guest_Jim69_*
  • Guests

Posted 23 August 2003 - 02:55 AM

That only effects the hardware acceleration IIRC, and if u turn Direct Draw off then it won't attempt 2 use any hardware acceleration ne way I think.

#11 Cpl. Facehugger

Cpl. Facehugger

    Creative Text Department

  • Xenocide Inactive
  • 3,749 posts

Posted 23 August 2003 - 08:21 AM

Did you use xcomutil? I think that fixes the garbled video problem.
I'm only partially inactive. :P I can still be reached at cpl.facehugger@gmail.com, and via PM. Preferably the former.

*Coming back? Avast! Facehugger, finish your assignments!*

Posted Image

#12 Kenshiro

Kenshiro

    Captain

  • Xenocide Artwork Department
  • 200 posts

Posted 23 August 2003 - 09:34 AM

Part of the problem might be that some of the newer cards no longer support a screen resolution low enought to run X-Com. I can run X-Com just fine on my P-133 with its onboard VGA but my P-2.35Ghz with a Radeon 9700 Pro scrambles the graphics. X-Com util doesn't help, changing the name doesn't help, and turning off DirectDraw doesn't help. Could be something else, but I think the problem is that it just can't flip the resolution down that much. I've gotten similar effect working in C (in the long past) when I set the screen resolution to un unsupported mode that was too high for my card to handle.

#13 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 14 October 2003 - 09:34 AM

thanks folks.... Turning off Direct Draw did it for me

#14 Guest_Omen_*

Guest_Omen_*
  • Guests

Posted 14 October 2003 - 09:47 PM

Ok I was having the same problem with the graphics, I downloaded the fix and the game worked perfectly. Well i went to work and later after i got home i went to play it only now im getting a error (Patch code timed out) can any tell me what i need to do? I rather not have to turn off my Daccel every time i want to play.

#15 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 15 October 2003 - 12:15 AM

How do you turn off DirectDraw?

#16 j'ordos

j'ordos

    Alien Concept Task Force

  • Xenocide Artwork Department
  • 5,059 posts

Posted 15 October 2003 - 05:57 AM

please read the faq :

you are still unable to run the game after using f0dder's fix, manually disable DirectDraw acceleration by following these instructions: From the Start Menu, click Run. Type in "dxdiag.exe" and click OK. After the data has finished loading, click the Display tab at the top of DxDiag. Look for the line that reads "DirectDraw Acceleration Enabled" and click Disable. Click EXIT at the bottom and go play. Remember to re-enable it before running application or games that require directx acceleration.


"You can't trust your eyes if your imagination's out of focus" - Mark Twain
"The mind is like an umbrella, it functions best when open" - Walter Gropius
Posted Image
SNEKK BLOG U-LAR MEKHH! GAHGHH! RK!
GRRGH RGGHH SNORRTT GHACKHGG

Now presented in DoubleVision™ (where drunk)



Reply to this topic