Jump to content


Photo

Need Help!


29 replies to this topic

#1 Deathskull

Deathskull

    Captain

  • Forum Members
  • PipPipPipPip
  • 439 posts

Posted 14 January 2004 - 03:42 PM

Whenever I try to play apoc, I just get a black screen tht does nothing. I set the compatibility to 95 and 256 colors and did everything mark0 said and nothing works. Any suggestions?
USA Today has come out with a new survey: Apparently three out of four people make up 75 percent of the population.
- David Letterman

#2 Puasonen

Puasonen

    Creative Text Department

  • Xenocide Inactive
  • 2,911 posts

Posted 15 January 2004 - 05:22 AM

svga patch? Have you downloaded it?
There's no need for a sig..

#3 NKF

NKF

    Commander

  • [Global Moderators]
  • PipPipPipPipPipPip
  • 4,798 posts

Posted 15 January 2004 - 05:58 AM

Maybe it's stalling or locking up at the intro? I've had this happen before. Though, in my case it was my soundcard that was causing the computer to lock up.

Can you try running it with the "skip" command to skip the intro and see if that does anything?

- NKF
Lord High Generalissimo Ruler Supreme of Norm's Anti Pedant Society (NAPS).

Number of members: 1

#4 j'ordos

j'ordos

    Alien Concept Task Force

  • Xenocide Artwork Department
  • 5,059 posts

Posted 15 January 2004 - 10:14 AM

Is your sound enabled? If it's disabled you have to press enter and it will continue. :) . Normally, if you have the crack, it should have a batch file that skips the intro... If not, do as NKF said, the movie files aren't included in the downloadable version, and I think xcom3 will crash if you don't have them and don't skip them.

Edited by j'ordos, 15 January 2004 - 10:16 AM.

"You can't trust your eyes if your imagination's out of focus" - Mark Twain
"The mind is like an umbrella, it functions best when open" - Walter Gropius
Posted Image
SNEKK BLOG U-LAR MEKHH! GAHGHH! RK!
GRRGH RGGHH SNORRTT GHACKHGG

Now presented in DoubleVision™ (where drunk)

#5 Deathskull

Deathskull

    Captain

  • Forum Members
  • PipPipPipPip
  • 439 posts

Posted 15 January 2004 - 04:12 PM

I have the svga fix and i used the skip. I tryed it without sound and pressed enter and it didnt do anything. It just sits there with a blank screen.
USA Today has come out with a new survey: Apparently three out of four people make up 75 percent of the population.
- David Letterman

#6 Deathskull

Deathskull

    Captain

  • Forum Members
  • PipPipPipPip
  • 439 posts

Posted 15 January 2004 - 05:54 PM

Was I supposed to do anything with the win95ins.exe?
USA Today has come out with a new survey: Apparently three out of four people make up 75 percent of the population.
- David Letterman

#7 Puasonen

Puasonen

    Creative Text Department

  • Xenocide Inactive
  • 2,911 posts

Posted 16 January 2004 - 12:36 AM

Can you tell us your computers specs?
There's no need for a sig..

#8 Deathskull

Deathskull

    Captain

  • Forum Members
  • PipPipPipPip
  • 439 posts

Posted 16 January 2004 - 03:10 PM

Intel Pentium 3 processor
448 MHz
256 Mb of RAM
USA Today has come out with a new survey: Apparently three out of four people make up 75 percent of the population.
- David Letterman

#9 Deathskull

Deathskull

    Captain

  • Forum Members
  • PipPipPipPip
  • 439 posts

Posted 16 January 2004 - 04:47 PM

I finally got dosbox and ive gotten a little further. Now I have this:

Attached Thumbnails

  • New_GIMP_image.PNG

USA Today has come out with a new survey: Apparently three out of four people make up 75 percent of the population.
- David Letterman

#10 Puasonen

Puasonen

    Creative Text Department

  • Xenocide Inactive
  • 2,911 posts

Posted 16 January 2004 - 06:16 PM

Now that you can see the cursor, does it move?
There's no need for a sig..

#11 Robo Dojo 58

Robo Dojo 58

    Colonel

  • Moderators
  • PipPipPipPipPip
  • 1,001 posts

Posted 16 January 2004 - 06:52 PM

As of DosBox .60, Apocalypse "technically" runs, but it isn't playable.
Here's the link showing game compatibility. Apoc is just barely runable under Dosbox. I'm amazed that you could get that far. :huh: My Apoc simply crashes in Dosbox.
Posted Image Haha! I'm now the Supreme Commander of X-COM. Time to kiss Earth goodbye.

My first order of business: Homeless people make cheap rookies, and are great at opening UFO doors. Heck, they're so cheap, I'm going to replace all personel with them!
Secondly: This organisation takes too much money to run. Weapon shipments will come from Siberia from now on. Costly maintenance is to be cut on all facilities. That includes venting.
Thirdly: We have a new colonel. His name is Facehugger, he loves aliens, and I want you all to treat him with respect.
Lastly: I'll be in my condo on an undisclosed island, if you need me. Good day.

FMIX-The General Stores

#12 Puasonen

Puasonen

    Creative Text Department

  • Xenocide Inactive
  • 2,911 posts

Posted 16 January 2004 - 07:40 PM

Yes, apoc is done to windows platform.
There's no need for a sig..

#13 j'ordos

j'ordos

    Alien Concept Task Force

  • Xenocide Artwork Department
  • 5,059 posts

Posted 17 January 2004 - 06:38 AM

Xcom Apoc is still mainly a DOS program, although it has support for win95.
I suppose you should get win95/98/DOS or something like that on your pc, and hope it works then :)

Edited by j'ordos, 17 January 2004 - 06:39 AM.

"You can't trust your eyes if your imagination's out of focus" - Mark Twain
"The mind is like an umbrella, it functions best when open" - Walter Gropius
Posted Image
SNEKK BLOG U-LAR MEKHH! GAHGHH! RK!
GRRGH RGGHH SNORRTT GHACKHGG

Now presented in DoubleVision™ (where drunk)

#14 Deathskull

Deathskull

    Captain

  • Forum Members
  • PipPipPipPip
  • 439 posts

Posted 17 January 2004 - 11:35 AM

I guess ill have to hope the next version of dosbox supports apocolypse
USA Today has come out with a new survey: Apparently three out of four people make up 75 percent of the population.
- David Letterman

#15 Guest_Karadoc_*

Guest_Karadoc_*
  • Guests

Posted 20 January 2004 - 12:20 AM

I have exactly the same problem on my XP box.
Black screen with a little flashing cursor in the top left corner.
Dosbox will run the game, but it looks just like that screen shot you posted (but with a different menu screen, I have the other version of Apoc).
I tried a Win98 bootdisk, but that's even worse. It hard locks the computer with a few technical error messages.

Fortunatly for me, I can still play it on my Win98 box. Although, I won't have it for ever...

It's strange that so many people can get it to run on XP (or that so many can't, if you like). I would have thought that it would either work on XP or it wouldn't.

#16 Guest_mr_*

Guest_mr_*
  • Guests

Posted 27 January 2004 - 01:30 PM

if you're playing without sound then you'll get a black screen instead of the intro. if you hit any key then it will skip the intro.

#17 Puasonen

Puasonen

    Creative Text Department

  • Xenocide Inactive
  • 2,911 posts

Posted 28 January 2004 - 07:44 AM

It's strange that so many people can get it to run on XP (or that so many can't, if you like). I would have thought that it would either work on XP or it wouldn't.

Getting old games to work on win2000/xp/nt is about the same like those first "plug and pray" devices long time ago. You just have to install them, put your thumbs up and start the game. Little praying might help too. :rolleyes: I have been blessed with a computer which perfectly runs apocalypse and TFTD. Even X-com 1 runs fairly. :rock:

edit
Oh, and I have winXP on my computer.

Edited by Nyyperoid, 28 January 2004 - 07:45 AM.

There's no need for a sig..

#18 Deathskull

Deathskull

    Captain

  • Forum Members
  • PipPipPipPip
  • 439 posts

Posted 28 January 2004 - 11:16 AM

I have been blessed and cursed. My computer runs xcom1&2 perfectly and doesnt run xcom3 at all
USA Today has come out with a new survey: Apparently three out of four people make up 75 percent of the population.
- David Letterman

#19 Puasonen

Puasonen

    Creative Text Department

  • Xenocide Inactive
  • 2,911 posts

Posted 28 January 2004 - 01:33 PM

Seems that you have the US version of it, have you tried the European version? With the red beginning screen?
Hmm. crazy idea, change your regional settings to US if it isn't already and try to run the game without dosbox.

Edited by Nyyperoid, 28 January 2004 - 01:34 PM.

There's no need for a sig..

#20 Deathskull

Deathskull

    Captain

  • Forum Members
  • PipPipPipPip
  • 439 posts

Posted 28 January 2004 - 01:35 PM

Europian version is different than the US version? Bogus!
USA Today has come out with a new survey: Apparently three out of four people make up 75 percent of the population.
- David Letterman

#21 Puasonen

Puasonen

    Creative Text Department

  • Xenocide Inactive
  • 2,911 posts

Posted 28 January 2004 - 02:36 PM

Europian version is different than the US version? Bogus!

I don't know if it's different in any other way than the fixed spelling error of "microprose" in the beginning screen and the fact that there's a big red X on the backround of the beginning screen. You might consider to try it though because you never know.
There's no need for a sig..

#22 Guest_karadoc_*

Guest_karadoc_*
  • Guests

Posted 28 January 2004 - 09:52 PM

Seems that you have the US version of it, have you tried the European version? With the red beginning screen.

I wouldn't bother trying the other version. The game is the same.
As I said in my other post, I have exactly the same problem and I'm using the European version.

#23 Deathskull

Deathskull

    Captain

  • Forum Members
  • PipPipPipPip
  • 439 posts

Posted 28 January 2004 - 09:58 PM

Ill use the asian version!
USA Today has come out with a new survey: Apparently three out of four people make up 75 percent of the population.
- David Letterman

#24 Puasonen

Puasonen

    Creative Text Department

  • Xenocide Inactive
  • 2,911 posts

Posted 29 January 2004 - 01:39 AM

? :LOL:

Btw: The reason I suggested this is that I had a problem running NFS Underground with my computer. I contacted tech support and they asked some info and then told me that I have an US version of it (I live in europe). They told me to change my regional settings to US and it worked! I played the game through and it worked just like it was supposed to! NOTICE! This games US and EUROPEAN version is also exactly the same but something is different because this worked.
There's no need for a sig..

#25 Puasonen

Puasonen

    Creative Text Department

  • Xenocide Inactive
  • 2,911 posts

Posted 30 January 2004 - 05:53 AM

Okay, a guy named "Thronecth" probably solved this problem. Start windows in "safe mode". Then start the game and it works! :happybanana:

Edited by Nyyperoid, 30 January 2004 - 05:53 AM.

There's no need for a sig..

#26 Deathskull

Deathskull

    Captain

  • Forum Members
  • PipPipPipPip
  • 439 posts

Posted 30 January 2004 - 01:52 PM

How do I start in safe mode?
USA Today has come out with a new survey: Apparently three out of four people make up 75 percent of the population.
- David Letterman

#27 j'ordos

j'ordos

    Alien Concept Task Force

  • Xenocide Artwork Department
  • 5,059 posts

Posted 30 January 2004 - 01:58 PM

...and then rebooted, but while its rebooting I hit F8 to bring up the unique reboot sequence. I then chose to load windows in safe mode in VGA...


"You can't trust your eyes if your imagination's out of focus" - Mark Twain
"The mind is like an umbrella, it functions best when open" - Walter Gropius
Posted Image
SNEKK BLOG U-LAR MEKHH! GAHGHH! RK!
GRRGH RGGHH SNORRTT GHACKHGG

Now presented in DoubleVision™ (where drunk)

#28 Puasonen

Puasonen

    Creative Text Department

  • Xenocide Inactive
  • 2,911 posts

Posted 31 January 2004 - 08:55 AM

Yes, see his topic for the full info about how to do this.
There's no need for a sig..

#29 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 31 January 2004 - 11:57 AM

Didnt work. Of course thats probably becuase im to lazy to combine safe mode and mark0s fix together. I just tryed it in safe mode with the svga patch.

#30 Deathskull

Deathskull

    Captain

  • Forum Members
  • PipPipPipPip
  • 439 posts

Posted 31 January 2004 - 11:58 AM

Whoops! forgot to login :wacko:
USA Today has come out with a new survey: Apparently three out of four people make up 75 percent of the population.
- David Letterman



Reply to this topic