Jump to content


Photo

Version 627 players?


  • Please log in to reply
4 replies to this topic

#1 Hobbes

Hobbes

    UFO2000 Staff

  • Moderators
  • PipPipPipPip
  • 719 posts

Posted 24 September 2009 - 04:50 PM

If there's anyone interested in playing a game of stable version 627 I'll be on the server. See ya there :)

Edit: If I'm afk challenge me and I'll hear it.

Edited by Hobbes, 24 September 2009 - 05:52 PM.


#2 Serge

Serge

    Project Leader: UFO 2000

  • Xenocide Programming Department
  • 785 posts

Posted 27 September 2009 - 10:13 AM

Hi there! It's nice to see you around.

I guess there won't be many challengers, just because this old version is not easily available. It is hidden from the download area because it is affected by some old security problems (fixed on more recent versions): http://secunia.com/advisories/21091

What makes you prefer it over the latest build? Performance, bugs, balance issues, anything else? Maybe we could try to fix something (that is if we can overcome inertia and start moving again) ...
ufo2000 development team
http://ufo2000.sourceforge.net

#3 clawunf

clawunf

    Sergeant

  • Forum Members
  • PipPipPip
  • 17 posts

Posted 08 October 2009 - 02:57 PM

Hobbes, i dont understand why you want to play the older version... the newer one is alot better... although for whatever reason... I could be wrong, there is no more game music.. so now i have to load some mp3's while I play.

#4 JoeJoe

JoeJoe

    Captain

  • Forum Members
  • PipPipPipPip
  • 165 posts

Posted 15 October 2009 - 03:03 PM

I sort of see where Hobbes is coming from. There is a lot to get used to in the latest version.

#5 Kratos

Kratos

    UFO2000 Staff

  • Moderators
  • PipPipPipPipPip
  • 4,113 posts

Posted 27 October 2009 - 07:56 PM

There's just too much unbalancing in the game in itself. Too many default weapons, having 16 floors is just crazy (especially for the maps that didn't design them to begin with), too much variability (grenades blowing up on each other and stacking to go for a instant kill). There's just too much things that need improving. But nobody is actively developing to fix this. I would help a long time ago but it's just too much for me to jump in such a programming project like this, nor would I have any access to modify newer versions. To us this version just "feels" more stable and not so alien (not the alien bases >>).

Also the older version only supports x-com, and that is what X-com fans really like to remember. X-com, not modern warfare spin-off. No offense, it's nice to be flexible in creating your own weaponset but the default has too many issues IMHO. I stated the reasons before...somewhere. But again, X-com fans want X-com.

Hobbes,

I wouldn't mind a couple games now and then. I am usually busy though, life, my own project, work, etc. I'm sure I can play on a day off though, which is usually Wednesdays and Fridays. Hope my reply isn't too late for you to actually get it :P

Edited by Kratos, 27 October 2009 - 07:59 PM.