Jump to content


Photo

Xcom Tftd (et-version 20/01/2005)


155 replies to this topic

#101 FrickenMoron

FrickenMoron

    Squaddie

  • Forum Members
  • PipPip
  • 6 posts

Posted 04 February 2005 - 03:14 PM

Thanks, im gonna look forward to a fix. The stairs problem has always been there in the CE of TFTD no matter what exe i use, its really weird.

#102 Gurluas2000

Gurluas2000

    Captain

  • Forum Members
  • PipPipPipPip
  • 151 posts

Posted 16 March 2005 - 12:06 PM

no research bug fix??

#103 Guest_Lord Lio_*

Guest_Lord Lio_*
  • Guests

Posted 02 April 2005 - 02:40 PM

Hi,
just tried to play the updated patch
but - every time i start the game, with or without loader (i use vdms),
the right side of my screen flicker, and i can't hear the midi music.

it might be just a stupid property problem,
but i really don't know what to try...

help? :blink2:

#104 Lord Lio

Lord Lio

    Rookie

  • Forum Members
  • Pip
  • 0 posts

Posted 03 April 2005 - 05:57 AM

Mmmm....

Mannaged to save just before the "Fire Frenzy" bug some others complained about.
hope it'll do any good...


just take krug and shoot the lobster in front of him,
the lobster will react - first by a lunched weapon or something like that, and then an endless shooting of sonic pistol, untill he kills krug.
it allways happens like this (lunch first, then sonic)
it also happened to one of my x-com shooting another alien, and all the agent had was a jet harpoon !!!!!!~!

some other bugs i encountered, are aliens or x-com refusing to die -
the x-com, sometimes from a direct sonic cannon shot (3 times strait !!!) having no armor! and not even a scratch,

and in this specific save i've posted, try throwing sonic pulsers on the lobster.
it survived 3 direct explosions, and not a scratch.... :sly:

Attached Files



#105 Guest_Filipe_*

Guest_Filipe_*
  • Guests

Posted 06 April 2005 - 11:45 AM

Hey People,
I got a Acer Travelmate 800 LCiB, with a Radeon 9200 mobile, (afaik)
When I run the game (ce under xp), it always minimises, immediately.
I Tried the original ce, the fodder loader, and the patch posted here, as well as disabling direct draw.

Any hints??? :Help:
Cheers,
Fil

#106 Emilio Estevez HV panics

Emilio Estevez HV panics

    Squaddie

  • Forum Members
  • PipPip
  • 1 posts

Posted 27 April 2005 - 09:37 AM

Mmmm....

Mannaged to save just before the "Fire Frenzy" bug some others complained about.
hope it'll do any good...


just take krug and shoot the lobster in front of him,
the lobster will react - first by a lunched weapon or something like that, and then an endless shooting of sonic pistol, untill he kills krug.
it allways happens like this (lunch first, then sonic)
it also happened to one of my x-com shooting another alien, and all the agent had was a jet harpoon !!!!!!~!

some other bugs i encountered, are aliens or x-com refusing to die -
the x-com, sometimes from a direct sonic cannon shot (3 times strait !!!) having no armor! and not even a scratch,

and in this specific save i've posted, try throwing sonic pulsers on the lobster.
it survived 3 direct explosions, and not a scratch....  :sly:

<{POST_SNAPBACK}>


Had the same problem with frenzy fire from aliens.. I've also had an unusal medic kit bug. My Captain was hit by a sonic rifle twice and dropped to the ground unconscious (was after a gillman frenzy-fired right into the doorway of my transport... it got a little messy inside :) ). I ran a medic up to him and hit heal 4 times that round, still down. The next round I hit heal 6 times, still down. The round after that my medic picked up the kit the Captain had on him from beside his mortally wounded body and hit heal 5 times, still down. The next turn the Captain died. I've successfully used the medic kit on unconsious troopers before so I have no idea why this time it was different (and didn't save the game unfortunately).

#107 Rowenstin

Rowenstin

    Rookie

  • Forum Members
  • Pip
  • 0 posts

Posted 28 April 2005 - 02:46 PM

The patch is great, but:

- I donīt have music when running the patch.

- It seems to be some incompatibility issues with xcomutil. The setup from xcomutil works fine, but the game crashes when trying to start the game with the runxcom bat file; it doesnīt happen with X-com 1, the both of them work fine together. However, it keeps some things (like the improved gauss weapons, though Iīd like to get id of MC)

#108 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 17 June 2005 - 10:57 AM

I have Windows XP with an AMD athlon XP Processor and VIA/S3G UniChrome IGP card- and Terror From The Deep normally runs perfect (Save, of course, for the standard processor problems like the high-speed clock). For some reason, when I patch my version (It's the standard CE; and your X-COM 1 ET Version works like a dream) it loads to a black screen and then hangs. It closes if I Alt+Tab out then reopen it.

I love your X-COM 1 ET version, so I'm really looking forward to getting this working on my comp. Could I be doing something wrong?

#109 cmorgan

cmorgan

    Rookie

  • Forum Members
  • Pip
  • 0 posts

Posted 21 June 2005 - 06:12 PM

I agree with Guest June 17 -- I have the same problem. System differences are Win98SE, P4, GeForce3 64. INCREDIBLY enjoyed a bug-free romp through X-Com 1 ET. Actually better than the original experience lo so many years ago; thank you so much for your hard work.

#110 max

max

    Sergeant

  • Forum Members
  • PipPipPip
  • 21 posts

Posted 01 July 2005 - 12:54 AM

Hi,

I'll update TFTD release version with the graphics from XCOM1 release. need to remove the custom graphics, like the mouse and alternative geoscape icons. - these where added hoping someone would submit there own, but it did not catch on.

happy to hear that it is enjoyed!

#111 Surmulle

Surmulle

    Rookie

  • Forum Members
  • Pip
  • 0 posts

Posted 07 July 2005 - 04:31 PM

daaamn :P haha i installed it just about right now, an when i gor my first ailen crash site "fire frenzy started, Doesn't matter what i do, They keep on firing as long as it needs till my aquanout is dead :D haha cant those bugs be fixed somehow? :) thx :)

#112 middlefinger

middlefinger

    Rookie

  • Forum Members
  • Pip
  • 0 posts

Posted 07 July 2005 - 08:18 PM

daaamn :P haha i installed it just about right now, an when i gor my first ailen crash site "fire frenzy started, Doesn't matter what i do, They keep on firing as long as it needs till my aquanout is dead :D haha cant those bugs be fixed somehow? :) thx :)

<{POST_SNAPBACK}>


Lo im new here and i'v ben playin x-com fer a long time first compu game i ever bought...and could not play for awhile with 98 & xp probs :Cry: i just fergot about it...but the other day my son found ya'll chatin it up an asked me about that dusty x-com
game in the unplayable pc game box :( me an him have ben playin fer 3days now :D only thing we have found wrong is this auto fire bug i hope it can b solved....and to the fixer of my #1 all time game.....ill squish the lobster dude for you....
"RULES OF COMBAT"
#1.I am the warlord of combat and will lead you from the front not
the rear.
#2.I dont have to like it,I just have to do it.
#3.KISS. (self explanatory)
#4.Kill your enemy by any means available b'fore he kills you.
#5.Proper preparedness prevents piss poor performance.
#6.Kill them all let the GOD of combat sort them.
#7.The more you bleed in training the less you bleed in combat.
#8.Attack...Attack...ATTACK
PS.Cover me im goin in.
Mr.Middlefinger.

#113 middlefinger

middlefinger

    Rookie

  • Forum Members
  • Pip
  • 0 posts

Posted 14 July 2005 - 08:08 AM

daaamn :P haha i installed it just about right now, an when i gor my first ailen crash site "fire frenzy started, Doesn't matter what i do, They keep on firing as long as it needs till my aquanout is dead :D haha cant those bugs be fixed somehow? :) thx :)

<{POST_SNAPBACK}>


Lo im new here and i'v ben playin x-com fer a long time first compu game i ever bought...and could not play for awhile with 98 & xp probs :Cry: i just fergot about it...but the other day my son found ya'll chatin it up an asked me about that dusty x-com
game in the unplayable pc game box :( me an him have ben playin fer 3days now :D only thing we have found wrong is this auto fire bug i hope it can b solved....and to the fixer of my #1 all time game.....ill squish the lobster dude for you....

<{POST_SNAPBACK}>

now ive got a problem besides the reaction fire bug.game frezzes up and stops responding nothing has changed in my system that i know of me and my son are running same op systems and setups on our cpus and he does not have this problem.im posting the last save i had bfore this only does it in battlescape.... :Brickwall:

Attached Files


"RULES OF COMBAT"
#1.I am the warlord of combat and will lead you from the front not
the rear.
#2.I dont have to like it,I just have to do it.
#3.KISS. (self explanatory)
#4.Kill your enemy by any means available b'fore he kills you.
#5.Proper preparedness prevents piss poor performance.
#6.Kill them all let the GOD of combat sort them.
#7.The more you bleed in training the less you bleed in combat.
#8.Attack...Attack...ATTACK
PS.Cover me im goin in.
Mr.Middlefinger.

#114 grunty

grunty

    Squaddie

  • Forum Members
  • PipPip
  • 2 posts

Posted 08 August 2005 - 09:00 PM

XCOM TFTD (ET-version 20 January 2005)

Summary
--------------------------------------------------------------------------------

* bugfixes (mostly 'battlescape')
* alternative video modes support
* auto sell manufacture enabled by decrease zero quantity (1111)
* allocate all scientist by decrease zero quantity
* allocate all technician by decrease zero quantity
* manufacture 'ingredients' removed at time of production
* idle technicians contribute to assembling base facilities (25/day)
* geoscape time (updated)

bugfix update: fixed incorrect damage being taken caused by previous et patch.

details are included in the zip.

Have fun!

<{POST_SNAPBACK}>


I get no music, how do i fix this?

#115 Gecko322

Gecko322

    Sergeant

  • Forum Members
  • PipPipPip
  • 13 posts

Posted 16 August 2005 - 11:45 AM

I've also been getting the crazy unlimited reaction fire bug, which is kind of a pain. I can work around it by saving a lot and just grenading the aliens as soon as they come into visual range, but it feels kind of sleazy. Any help on that would be hugely appreciated. Other than that though, everything works great, excellent work overall =b

#116 Blehm 98

Blehm 98

    Colonel

  • [Global Moderators]
  • PipPipPipPipPip
  • 2,626 posts

Posted 16 August 2005 - 11:55 AM

Its fun with a Heavy Guass though, believe me, firing 15 Heavy gauss shots on artifacts and cutting those pyramids is fun

BTW, the frenzy bug isn't ET, it is also Xcomutil, unless it is just an xcom standard bug
Top Secret Xenocide Status report

BF2 Hackers =5SF= have busted
]sD[ Engageo <-- couldn't get him banned though, no screenshot of him ingame
]sD[Nomisser
an AK guy
The anti-logarithm of the logarithm of X plus the logarithm of Y equals X times Y, or 10^(logX + logY) = XY
Posted Image
I hate spider solitaire...

#117 Guest_Carl_*

Guest_Carl_*
  • Guests

Posted 17 August 2005 - 12:56 PM

Its fun with a Heavy Guass though, believe me, firing 15 Heavy gauss shots on artifacts and cutting those pyramids is fun

BTW, the frenzy bug isn't ET, it is also Xcomutil, unless it is just an xcom standard bug

<{POST_SNAPBACK}>


Great patch, but unfortunatly the music is gone. It seems like I'm not the only one bothered by this issue.

So, how will I get the game music play? Please...

#118 Blehm 98

Blehm 98

    Colonel

  • [Global Moderators]
  • PipPipPipPipPip
  • 2,626 posts

Posted 17 August 2005 - 01:11 PM

try running setup again or making sure you have a fully XP compatible version of the game
Top Secret Xenocide Status report

BF2 Hackers =5SF= have busted
]sD[ Engageo <-- couldn't get him banned though, no screenshot of him ingame
]sD[Nomisser
an AK guy
The anti-logarithm of the logarithm of X plus the logarithm of Y equals X times Y, or 10^(logX + logY) = XY
Posted Image
I hate spider solitaire...

#119 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 18 August 2005 - 08:34 PM

to get the music to work, go to control panel > sounds and audio devices. then go to the audio tab. then change your midi playback to microsoft gs wavetable synth. voila.

#120 Guest_X-Com Fan_*

Guest_X-Com Fan_*
  • Guests

Posted 28 August 2005 - 10:24 AM

Hello,

I was playing CE without the patch, but experienced severe corruption problems (random crashes that became more and more frequent). From a certain point on, I couldn't load the saves anymore (got crashes to desktop each time).

So I installed the tftdet patch. Only that now the game seems to eat up all the processor and, during battle, it runs real slowly. I have to keep aquanauts at maximum speed and still they move like they're in their 90's. It takes about five seconds to auto-fire a harpoon jet. :((

I run the game on a PIII 800 IBM laptop with 128SDRAM and Win XP.

By the way, I also have a 14 inch display. Before the patch, the game used the whole screen and didn't look so bad on a small display like mine. Now, with the 640 resolution, I get this tiny window and everything seems so small.

So my questions are, can I:

run the game at pre-patch speed in battlescape (geo-scape patch speed is fine)
not overload the processor so much (probably related to first q)
use the old resolution but keep the advantages of the patch

Thanks,

PS. Man, I wish I were a programmer, if only for helping to fix this great game.

#121 max

max

    Sergeant

  • Forum Members
  • PipPipPip
  • 21 posts

Posted 29 August 2005 - 07:24 AM

Hi, the screen resolution can be changed to 1024 768, also filtering may cause the game to run slower. Is this enabled in the registry?

Please try starting a new game, does the battlescape still run slow? (it was tested on a 300 mhz celeron laptop without this problem). It may be an old savegame with bugs being used, with the 'bugfixes' compensating and taking extra cycles.

Hope this helps.

Submit you savegame if you like, though admitantly, I don't work on the patch very often. :(

#122 Guest_X-Com Fan_*

Guest_X-Com Fan_*
  • Guests

Posted 29 August 2005 - 10:11 AM

Unfortunately I can't figure out where I can change the resolution to 1024. Is there a config file that I should look for.

Also, I don't know what "filtering" is, nor where I can find it/modify it. It might help if you could give me some specific instructions.

It's not a problem with the save game. I started a new game since the old save pissed me off to the extent that I deleted the entire game. Than I ran into this site and found out about the patch, and here we go again...

#123 Guest_X-Com Fan_*

Guest_X-Com Fan_*
  • Guests

Posted 29 August 2005 - 01:01 PM

Later I noticed a similar patch that you did for UFO1. I found the reg file there that deals with the registry. I ran that game as well and got the same problems. I disabled all filters with regedit and still got the slow motion bug. In 1024 even the geoscape is too laggy. It takes a few seconds for a popup message to open.

Maybe I should mention that I use a copy of the game that I got from some abonware site. It came on rar archives. Do you think that may have something to do with it? Am I missing some files maybe?

Anyway, this seems like a dead end for me. Thanks for showing interest.

#124 Guest_Hunter83_*

Guest_Hunter83_*
  • Guests

Posted 15 November 2005 - 11:58 AM

Hi,

I've found these forums, and particularly the ET patch for UFO Defense very helpful. I was afraid my CE CD's would be collecting dust forever cause of that dreadful garbled graphics stuff.

I'm pretty close to beating UFO defense and will then start playing Terror from the Deep, for probably my 3rd or 4th time through; though first time on this system(Windows 2k).


I was wondering and hoping if there's any way to run TFTD in a higher resolution mode as it was in UFO Defense. I personally can't stand to run anything below 1024x768. If for no other reason then to keep the refresh rate at least 85, anything under and my eyes start going crazy.

Also if it'd be easy to give the Sonic Pulsars a proximity fuse like the Alien Grenades in UFO.


I dunno if max is still supporting this patch but I thought I'd post here in the hopes that he is.

#125 Guest_Dreadnotus_*

Guest_Dreadnotus_*
  • Guests

Posted 22 November 2005 - 03:48 PM

Yes, I tried downloading the zop file and it works fine, but when i try to unzip it with ZinZip 10.0 it sais The file is currupt. Any suggestions?

#126 calendil

calendil

    Rookie

  • Forum Members
  • Pip
  • 0 posts

Posted 04 January 2006 - 11:00 AM

XCOM TFTD (ET-version 20 January 2005)

Summary
--------------------------------------------------------------------------------

* bugfixes (mostly 'battlescape')
* alternative video modes support
* auto sell manufacture enabled by decrease zero quantity (1111)
* allocate all scientist by decrease zero quantity
* allocate all technician by decrease zero quantity
* manufacture 'ingredients' removed at time of production
* idle technicians contribute to assembling base facilities (25/day)
* geoscape time (updated)

bugfix update: fixed incorrect damage being taken caused by previous et patch.

details are included in the zip.

Have fun!

<{POST_SNAPBACK}>


I can't open the zip properly, can there be any distorsion on the file?
Posted Image
Posted Image
Posted Image

#127 Guest_xrefusex_*

Guest_xrefusex_*
  • Guests

Posted 25 January 2006 - 11:36 AM

XCOM TFTD (ET-version 20 January 2005)

Summary
--------------------------------------------------------------------------------

* bugfixes (mostly 'battlescape')
* alternative video modes support
* auto sell manufacture enabled by decrease zero quantity (1111)
* allocate all scientist by decrease zero quantity
* allocate all technician by decrease zero quantity
* manufacture 'ingredients' removed at time of production
* idle technicians contribute to assembling base facilities (25/day)
* geoscape time (updated)

bugfix update: fixed incorrect damage being taken caused by previous et patch.

details are included in the zip.

Have fun!

<{POST_SNAPBACK}>


The file seems to be corrupt. Anybody else have it?

#128 SleepyWu

SleepyWu

    Sergeant

  • Forum Members
  • PipPipPip
  • 13 posts

Posted 11 February 2006 - 06:06 AM

How can I change screen resolution? help-file says that this version supports
four types
640*400 24bit (1M video)
640*400 32bit (1M video)
640*480 24bit (1M video)
640*480 32bit (1M video)
but by default 640x400 is used. How can I swith it to 640x480?
I tried to use reg-file from UFO with changed path inside the file, but nothing happened...

#129 Mr.Marshmallow

Mr.Marshmallow

    Rookie

  • Forum Members
  • Pip
  • 0 posts

Posted 23 February 2006 - 02:29 PM

Hello @ll,

this is my first post here. As you all, I am truly a fan of the original XCOM Series,
Ufo and TFTD. I remember playing those games a lot on 486 DOS, but even getting me a XCOM Collector Edition has made no change:
I wasnt able to play XCOM on XP due to garbled gfx. Now I found the xcomufo page,
and thx for it. Finally I made it, both parts, UFO with SAI and TFTD normal, run in
640x480 mode on my 19" TFT perfectly.
There are some glitches, thats why I write down how I did it.
1. (I) installed the CE Edition of UFO and TFTD.
2. Apply Moks Patch on UFO, then apply the 2xSAI patch, renaming it to "Ufo Defense.exe"
3. Applying ETs "tftdet_2005_01_20" patch on TFTD
4. I did not use xcomfix.exe or any of these loaders.

all this resulted in a steady problem:
the resolution was 640x350, no matter what I tried, the upper and lower part werent visible. I read all the posts, I tried to disable DDraw, tried every hint I read, but nothing changed that problem. Then, after a short time of praying to the lord for helping me getting this *$$&%$ fixed, halleluja,

5. I checked the video settings of my card, ATI 9800, went to the display sheet, and changed Desktop frequency to "same as desktop". Thats all! Hope this will help somebody too.

Now I have 640x480, Ufo with 2xSai (maybe there will be another prayer for a TFTD 2xSAI), but it works 100% perfectly!! Gosh!!!
Thx to all those envolved, and maybe you could tell us someday how you made this incredible patch? Reverse engineering? I really dont know, but you have solved many peoples problems. Thank YOU!

Edited by Mr.Marshmallow, 23 February 2006 - 02:30 PM.


#130 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 24 February 2006 - 03:11 PM

Seems that I managed to get a strange bug, all my soldiers was invulvernable during a tactical mission. Nice for me I guess but it makes for a pretty dull game ;)

#131 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 28 February 2006 - 10:09 AM

I take it that Max doesn't support this patch anymore?

#132 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 21 March 2006 - 01:58 PM

How do I make it work?

I have CE edition and 2 executable files: terror from the deep and idr_xcom2. I can not run first one - graphic problems. As I understood second is a kind of fix for that. But when I install tftdET, i can not rus second also - same graphic problems appear...

I have win2000.. same problem was with XP.. any ideas?

Built-in video card might be a problem?

#133 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 21 March 2006 - 03:23 PM

How do I make it work?

I have CE edition and 2 executable files: terror from the deep and idr_xcom2. I can not run first one - graphic problems. As I understood second is a kind of fix for that.  But when I install tftdET, i can not rus second also  - same graphic problems appear...

I have win2000.. same problem was with XP.. any ideas?

Built-in video card might be a problem?

<{POST_SNAPBACK}>


the problrm was build-in video card. Runs smoothly on another computer.. Thought, I had a very strange unlimited fire bug. Anyone found a fix to it?

It may be either reaction shot or just a usual fire..

#134 Outlawstar15a2

Outlawstar15a2

    Sergeant

  • Forum Members
  • PipPipPip
  • 33 posts

Posted 23 April 2006 - 06:02 PM

I have a few TFTD CE save games with crashes to desktop in battlesape, that old corrupted savegame thing. I managed to get around it by working with multiple savefiles and returning to earlier dates on non corrupted saves and starting over, it's a pain but the only solution to work. Now I've heard good things about this patch if you want me to I can post the corrupted saves here. Also I I might have found a way around the research bug I found this website that allows you to download a file that will fix the bug by starting the research project with zero scientists I don't know how the modified files will play with this patch but it might be fixable. Also I know of one research bug that I can help you reproduce. It involves the Leviathan and the Magnetic Ion Armor. TFTD requires you to research things in a given order and at a given time, this is the bug in short. Failure to do so means lost research opportunities I have the tech tree list for the entire TFTD game that will show such requirements I will post it here if desired so we can reproduce the bugs on purpose sound good?

#135 Outlawstar15a2

Outlawstar15a2

    Sergeant

  • Forum Members
  • PipPipPip
  • 33 posts

Posted 23 April 2006 - 06:26 PM

Ok I got a problem I recently tried to run the patch itself after adding a .exe extension to it and got this message.

C:\X-Com~1\tftdet.exe
The NTVDM CPU has encountered an illiegal instruction.
CS:055d IP0001 OP:ff ff 9f 00 9a Choose 'Close' to terminate the application

When I attempt to run Terror from the Deep.exe directly it says this.

Patch not installed (0xFFFFFFFF, 0x00000002)

Ok what gives?

#136 Guest_M3X6_*

Guest_M3X6_*
  • Guests

Posted 11 May 2006 - 07:48 AM

Hey, I'm just wondering after going through this thread, is the developer of the patch even alive still??? Perhaps he's been abducted? :alien2:

#137 ozsem

ozsem

    Rookie

  • Forum Members
  • Pip
  • 0 posts

Posted 15 May 2006 - 08:16 AM

Hey, I'm just wondering after going through this thread, is the developer of the patch even alive still??? Perhaps he's been abducted? :alien2:

<{POST_SNAPBACK}>


I also have a problem with the frenzy fire.

#138 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 01 June 2006 - 02:15 PM

Hey, I'm just wondering after going through this thread, is the developer of the patch even alive still??? Perhaps he's been abducted? :alien2:

<{POST_SNAPBACK}>


I also have a problem with the frenzy fire.

<{POST_SNAPBACK}>


Yup me too, the frenzy fire just never stops... anyone found a fix.. or know what causes it.. WTF

#139 Deviator

Deviator

    Rookie

  • Forum Members
  • Pip
  • 0 posts

Posted 03 June 2006 - 04:45 AM

Hello Max! I have found one stinky research bug: When you researched Aquatoid Medic, the game crushes after you press OK or View Reports. Can you fix it?

P.S. I read that this bug also is in first ufo, when you researched Floater Medic.

#140 monster85

monster85

    Rookie

  • Forum Members
  • Pip
  • 0 posts

Posted 29 October 2006 - 12:44 AM

hereby i attacted one savegame file that i used to play this games..


but eveytime i play this save file. my TFTD game will hang .. why ?


thk ..


for that attactment file... please rename it from " game3.ex_ " to " game3.exe " .. then only play it..

thks

Attached Files


Edited by monster85, 29 October 2006 - 12:45 AM.


#141 Caboose

Caboose

    Sergeant

  • Forum Members
  • PipPipPip
  • 10 posts

Posted 18 November 2006 - 08:41 PM

Hey guys.

I installed this patch (for XCOM 2) as I did with XCOM 1, and it worked great there.

I see the patch for XCOM 2 is very similar, but when I run the patched .exe-file i don't get any music (as several others have reported). It seems that i need the midi-files need to be in the SOUND-folder (which they were not). Now, I managed to find the music to the game in midi-format on the net, but they need to be renamed in order for the game to recognize them.

Some of the midi-files were named exactly the same as in XCOM 1, for example: GMGEO1.mid, GMGEO2.mid, GMINTER1.mid, GMINTER2.mid and so on. But the rest I couldn't figure out..

Could anybody write me what the midi-files in their SOUND-folder are called? I would appreciate it greatly, as this would give me the music back in the game. :)

The ones i know are:

GMGEO1.mid
GMGEO2.mid
GMGEO3.mid
GMGEO4.mid
GMGEO5.mid
GMGEO6.mid
GMINTER1.mid
GMINTER2.mid
GMINTER3.mid

Help me please? :(

Edited by Caboose, 18 November 2006 - 08:46 PM.


#142 Zombie

Zombie

    Colonel

  • Xenocide Creative-Text Departmen
  • 2,947 posts

Posted 18 November 2006 - 09:02 PM

This is what I have in my sound folder. I believe it is un-modified:

gmattbas
gmbigmar
gmdebgoo
gmdebpor
gmdefbas
GMGeo1
GMGeo2
GMGeo3
GMGeo4
GMGeo5
GMGeo6
GMInter1
GMInter2
GMInter3
gmisposh
gmnewint
gmsig
gmtacdry
gmtacwet
gmwaitlo

Hope that helps. :)

- Zombie
The Mr. Grognard of X-COM

Zombie: Empirical data's your only man, when formulating a research plan.
A soldier's death is never in vain if it makes the formula more plain.
A few dozen make a better case for refining that third decimal place.
They call me Zombie because I don't sleep, as I slowly struggle to climb this heap,
of corpses, data points, and trials, but from the top - I'll see for miles!


#143 Caboose

Caboose

    Sergeant

  • Forum Members
  • PipPipPip
  • 10 posts

Posted 22 November 2006 - 12:10 PM

Thanks alot, mate. I get most of my music now, however the intro music and poor results briefing music won't play. Oh well, doesn't really matter that much. Thanks again, at least I have most the music now. :)

#144 iucpxleps

iucpxleps

    Squaddie

  • Forum Members
  • PipPip
  • 2 posts

Posted 18 December 2006 - 10:01 AM

this patch garbles my screen..:( I have the full CE game..

#145 paulc

paulc

    Squaddie

  • Forum Members
  • PipPip
  • 2 posts

Posted 18 January 2007 - 07:35 AM

I have the same problem, any fix? Thanks.

I have Windows XP with an AMD athlon XP Processor and VIA/S3G UniChrome IGP card- and Terror From The Deep normally runs perfect (Save, of course, for the standard processor problems like the high-speed clock). For some reason, when I patch my version (It's the standard CE; and your X-COM 1 ET Version works like a dream) it loads to a black screen and then hangs. It closes if I Alt+Tab out then reopen it.

I love your X-COM 1 ET version, so I'm really looking forward to getting this working on my comp. Could I be doing something wrong?



#146 Lomax

Lomax

    Rookie

  • Forum Members
  • Pip
  • 0 posts

Posted 22 February 2007 - 11:57 AM

Hey everyone!

Recently rediscovered the joys of X-Com TFTD which I played a lot back in the nineties. Incredible how well it's stood the test of time, still tremendously good & challenging fun and the atmosphere is great too! Only thing I don't like is the abundance of bugs (in particular the battlescape ones) and the measly 320x200 resolution. I was therefore immensly pleased to see that someone called "Max" had come up with a patch that not only gets rid of most bugs but also allows higher resolutions to be used! Yay!

However, I'm having great difficulty getting the higher resolutions to work. After digging around here I found Max's patch for X-Com1 and examined the .reg file in there, thinking it ought to be some similar keys for X-Com2. Just to make sure I made this .reg file and merged it:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microprose\X-COM Enemy Unkown\E.T.]
"edge_filter"=dword:00000001
"avg_filter"=dword:00000000
"vres"=dword:000001e0
"hres"=dword:00000280
"Bpp"=dword:00000004
"base_layout"=dword:00000000

[HKEY_LOCAL_MACHINE\SOFTWARE\Microprose\X-COM Terror From The Deep\E.T.]
"edge_filter"=dword:00000001
"avg_filter"=dword:00000000
"vres"=dword:000001e0
"hres"=dword:00000280
"Bpp"=dword:00000004
"base_layout"=dword:00000000

Alas, it doesn't work! No change in graphics resolution apart from a black bar at the bottom of the screen. This looks the same regardless of what values I enter for vres, hres and Bpp and regardless of which of the two keys I do it in. My only conclusion is that the game cannot see the registry key because it is incorrectly named. Could anyone here shed some light on this?

And if you're still around, thanks a million for all your work on this patch Max!

Cheers,

Lomax

#147 Dreamer

Dreamer

    Squaddie

  • Forum Members
  • PipPip
  • 8 posts

Posted 18 August 2008 - 01:05 AM

thanks man, love it

#148 Mr.Marshmallow

Mr.Marshmallow

    Rookie

  • Forum Members
  • Pip
  • 0 posts

Posted 20 September 2008 - 05:00 AM

Patch doesnt work here, put all the Files into the TFTD Folder, CE Edition, but it crashes immediately after starting, the screen is only black.
If I start th original TFTD exe it works fine in a lower resolution.

#149 Dustin

Dustin

    Rookie

  • New Forum Members
  • Pip
  • 0 posts

Posted 06 October 2008 - 02:45 PM

Patch doesnt work here, put all the Files into the TFTD Folder, CE Edition, but it crashes immediately after starting, the screen is only black.
If I start th original TFTD exe it works fine in a lower resolution.



I get this same problem... Anybody know how to fix this??

Update:

It uses 50% of the CPU and 10MB of ram while only showing a black screen. I let it sit for a few minutes and nothing happened. If I minimize it and bring it back up then it crashes.

Edited by Dustin, 06 October 2008 - 03:19 PM.


#150 acirko

acirko

    Rookie

  • New Forum Members
  • Pip
  • 0 posts

Posted 27 November 2008 - 08:06 PM

XCOM TFTD (ET-version 20 January 2005)

Summary
--------------------------------------------------------------------------------

* bugfixes (mostly 'battlescape')
* alternative video modes support
* auto sell manufacture enabled by decrease zero quantity (1111)
* allocate all scientist by decrease zero quantity
* allocate all technician by decrease zero quantity
* manufacture 'ingredients' removed at time of production
* idle technicians contribute to assembling base facilities (25/day)
* geoscape time (updated)

bugfix update: fixed incorrect damage being taken caused by previous et patch.

details are included in the zip.

Have fun!


Number of problems i'm having with this patch

Is there anyway to get this bugfix to work with DOSBox?
I can't figure out how to change the resolution to something other than default.
The music stops playing. I went into Sounds&Audio devices and changed it to the windows midi player thing, but that isn't work either.

Edited by acirko, 01 December 2008 - 05:16 PM.




Reply to this topic