Jump to content


Photo

Build 0.4


17 replies to this topic

#1 GARAK

GARAK

    Sergeant

  • Forum Members
  • PipPipPip
  • 13 posts

Posted 06 April 2008 - 10:38 PM

Just played .4 build. Pretty awesome people. Amazing progress. The world will thank all of you when this is done.

#2 dteviot

dteviot

    Programming Department

  • [Xenocide Senior Members]
  • 1,479 posts

Posted 06 April 2008 - 11:16 PM

Blush. I'm just happy to learn that other people are actually following the progress.
Saving the world from the scum of the universe is hard work. Especially when you have to create the scum to begin with.

#3 ccarter1024

ccarter1024

    Squaddie

  • Forum Members
  • PipPip
  • 1 posts

Posted 07 April 2008 - 01:48 PM

I was just looking at the site and saw that there is a new build. Will be downloading and installing tonight. Can't wait to see the progress you guys have made.
I never fragged an alien I didn't hate.

#4 Darkhomb

Darkhomb

    Captain

  • Xenocide Artwork Department
  • 628 posts

Posted 07 April 2008 - 02:18 PM

Thank you! Don't forget the sound pack if you don't have it from the previous build

#5 Guest_Azrael Strife_*

Guest_Azrael Strife_*
  • Guests

Posted 07 April 2008 - 07:03 PM

Three cheers for david and darkhomb! :)
(and other contributors, of course, but we'd be dead by now without you, guys)

#6 Darkhomb

Darkhomb

    Captain

  • Xenocide Artwork Department
  • 628 posts

Posted 07 April 2008 - 09:50 PM

Don't thank me, many other have done more then I have.

#7 Guest_Azrael Strife_*

Guest_Azrael Strife_*
  • Guests

Posted 07 April 2008 - 11:21 PM

You took over Art and did a lot of artwork stuff while everyone was gone for many months :) I'd say there's a lot to thank you for too :D

#8 Puasonen

Puasonen

    Creative Text Department

  • Xenocide Inactive
  • 2,911 posts

Posted 11 April 2008 - 11:59 AM

Very nice to see the amount of progress.. Well, can't see it actually but read. Too bad I can't test the latest build because I don't have the necessary .XNA installed. Tried to install it but it gave me an error message about not having a C# visual studio or something installed. I can only hope someone will make a video about this build to give an old fart like me a chance to see the battlescape and all. Keep up the good work anyway!
There's no need for a sig..

#9 kafros

kafros

    Creative Text Department

  • Xenocide Creative-Text Departmen
  • 1,800 posts

Posted 11 April 2008 - 03:53 PM

So I think we should try to make an installer for the game... I've seen some packages for XNA games that can check whether you have the necessary components installed. The creator can choose whether to include them in the installer (so it increases the size of the file by 50MB or so) or just tell you what to install manually. Now that dteviot takes a brake, I guess it's a good time to experiment with that. I'll keep you informed Puasonen!

#10 mosquitoii

mosquitoii

    Squaddie

  • Forum Members
  • PipPip
  • 1 posts

Posted 11 April 2008 - 10:15 PM

Thank you! Don't forget the sound pack if you don't have it from the previous build


I can't start the latest release - Vista w/o SP1
Nvidia 6150 - Dec 2007 driver - no updates

What dows this mean:
Exception: The specified module could not be found. (Exception from HRESULT: 0x8007007E)
StackTrace:
at ProjectXenocide.Program.CheckGraphicsHardware()
at ProjectXenocide.Program.Main() in C:\Users\Jasin\Documents\Xenocide SVN\XenoXNA\Xenocide\Source\Program.cs:line 47

Any asistance would be appreciated.

Mosquitoii

#11 Darkhomb

Darkhomb

    Captain

  • Xenocide Artwork Department
  • 628 posts

Posted 12 April 2008 - 12:56 AM

Do you have all required programs? .net 2.0, XNA framework and latest DirectX? even if it says 9 you need the latest version of 9.

#12 Darkhomb

Darkhomb

    Captain

  • Xenocide Artwork Department
  • 628 posts

Posted 12 April 2008 - 12:57 AM

Very nice to see the amount of progress.. Well, can't see it actually but read. Too bad I can't test the latest build because I don't have the necessary .XNA installed. Tried to install it but it gave me an error message about not having a C# visual studio or something installed. I can only hope someone will make a video about this build to give an old fart like me a chance to see the battlescape and all. Keep up the good work anyway!



Sounds like you were trying to install the wrong thing, There is XNA studio with is for c# visual studios, and there is XNA framework. Please install the latter and try again.

#13 Drako^lM

Drako^lM

    Squaddie

  • Forum Members
  • PipPip
  • 2 posts

Posted 12 April 2008 - 06:36 AM

Nice work Team :)
Last progress release rulez
THX :)

#14 kafros

kafros

    Creative Text Department

  • Xenocide Creative-Text Departmen
  • 1,800 posts

Posted 12 April 2008 - 02:21 PM

http://momupload.com...p_test.exe.html

Enjoy :)

This is just a test installer I just temporarily uploaded. You can select where to install the latest release, and when it finishes it'll automatically run the XNA Requirements Checker (http://xnamatrix.com/xnareq.php), which is supposed to automatically update the needed components (I don't know how it works cause I already had everything installed when I found it). It also checks if your graphics card is capable of running XNA games

Tell me if it works for you. If not, then I'll release a second installer with which you'll be able to choose which components to download to your desktop (any or all of the 3 needed to run the game). There are some things bothering me with the script so I'll work on it a bit more once I have time ;)

#15 Mad

Mad

    Creative Text Department

  • [Xenocide Senior Members]
  • 1,958 posts

Posted 13 April 2008 - 08:59 AM

http://momupload.com...p_test.exe.html

Enjoy :)

This is just a test installer I just temporarily uploaded. You can select where to install the latest release, and when it finishes it'll automatically run the XNA Requirements Checker (http://xnamatrix.com/xnareq.php), which is supposed to automatically update the needed components (I don't know how it works cause I already had everything installed when I found it). It also checks if your graphics card is capable of running XNA games

Tell me if it works for you. If not, then I'll release a second installer with which you'll be able to choose which components to download to your desktop (any or all of the 3 needed to run the game). There are some things bothering me with the script so I'll work on it a bit more once I have time ;)

It works good for me. But since you are on an installer, you could also add the options to directly download the audio pack and the option to download the high resolution textures... ^_^ :innocent:

Edit: Nope, it does not work. Xenocide starts if you finish the installation with "launch Xenocide", but if you try to start Xenocide from the start menu later, you get an error
Exception: No Imageset named 'TaharezLook' is present in the system.
StackTrace:
   bei CeGui.ImagesetManager.GetImageset(String name) in D:\Xenocide Repository\XNA\trunk\Dependancies\CeGui\CeGui\Source\ImageSetManager.cs:Zeile 197.
   bei ProjectXenocide.Xenocide.InitializeCegui() in D:\Xenocide Repository\XNA\trunk\Xenocide\Source\Xenocide.cs:Zeile 155.
   bei ProjectXenocide.Xenocide.Initialize() in D:\Xenocide Repository\XNA\trunk\Xenocide\Source\Xenocide.cs:Zeile 122.
   bei Microsoft.Xna.Framework.Game.Run()
   bei ProjectXenocide.Program.Main() in D:\Xenocide Repository\XNA\trunk\Xenocide\Source\Program.cs:Zeile 51.
This is, because you have not set the "run in" variable in Xenocide.lnk (the shortcut the installer writes into the startmenu)

Edited by Mad, 13 April 2008 - 09:15 AM.

Keep smiling while dying

Of course I have gone mad with power! It would be completely ridiculous to go mad without power!
And no, this is not a quote from the Simpson's movie, I want it on paper, that I actually wrote that quite some time before the movie came out.

Posted Image

#16 kafros

kafros

    Creative Text Department

  • Xenocide Creative-Text Departmen
  • 1,800 posts

Posted 13 April 2008 - 12:11 PM

It works good for me. But since you are on an installer, you could also add the options to directly download the audio pack and the option to download the high resolution textures... ^_^ :innocent:

Well, the purpose of the installer was to make checking and/or installation of the prequisites easier. Did Xnari 0.5 work for you? It doesn't install anything, it just extracts an exe file which is automatically deleted when the process is finished.

The other solution is to let the users select what they want to download and install it manually themselves after installation. This process could be improved by running the downloaded setup file(s) after installation. The problem is that I haven't found yet a way to run only a specific file (that is, don't try to run the dx setup if the user hasn't selected it).

The third and optimal solution would be to check manually if each component exists. dotNet2 can be easily checked from a registry key (unfortunately it didn't work with the installer for a mysterious reason, I'll try again from scratch next time). BUT, Xna and DirectX aren't as easy... They could be checked with WiX, but I couldn't find out how (I couldn't even understand how WiX works, if you can be my guest xD).

The higher resolution pack and the audio pack are easier to add. The only problem I can think of is how to manipulate the zip files (there isn't such a feature in inno xD) or even folders. It's a piece of cake with single files though.

This is, because you have not set the "run in" variable in Xenocide.lnk (the shortcut the installer writes into the startmenu)

"Start in:" oooooooh just noticed that, thanks! Well I didn't manually create the shortcuts, they are automatically created :S. That's why there are 2 uninstall shortcuts, they differ in 1 space xD. I'll look into it, probably make them manually (I just have to find out how LOL )

The inno setup scripts need work and time, which I don't have now... Tomorrow I have a test on "Algorithms and Complexity" so time is tight. I'll upload my existing script for anyone who wants to try.

(As you've probably understood by now, this is no "drag n' drop" procedure :/ )

edit: I removed the script and started a thread at the workshops

Edited by kafros, 14 April 2008 - 08:23 PM.


#17 Mad

Mad

    Creative Text Department

  • [Xenocide Senior Members]
  • 1,958 posts

Posted 13 April 2008 - 01:25 PM

Did Xnari 0.5 work for you?

As I said before: it works good for me. actually a bit too good. I do have the XNA Framework installed, so I did not need to install the Runtime environment, but that didn't stop it from installing the RE....
Keep smiling while dying

Of course I have gone mad with power! It would be completely ridiculous to go mad without power!
And no, this is not a quote from the Simpson's movie, I want it on paper, that I actually wrote that quite some time before the movie came out.

Posted Image

#18 gu35s

gu35s

    Sergeant

  • Forum Members
  • PipPipPip
  • 17 posts

Posted 13 April 2008 - 06:38 PM

Hello all. long time no see =)
A new build... how sad... that I don't have a PC anymore :P damn. (<- is that allowed? >,<)
I see things are going along. Hopefully somebody gonna take a chance at my previous repertoire. (as if there's anything good enough to use :P )
Anyway, good job on the arts ^^ love the new models. Hope I get to play this sometime soon. And maybe get in touch with blender again and make some more "concept art" :P

Edited by gu35s, 13 April 2008 - 06:38 PM.

====================

Gu35sing is a big part of life...

====================



Reply to this topic