Jump to content


Photo

Crash With 0.4


10 replies to this topic

#1 Nick_Dx

Nick_Dx

    Squaddie

  • Forum Members
  • PipPip
  • 2 posts

Posted 16 April 2008 - 04:57 AM

Whenever I start the .exe included in the 0.4 build zid I get this error:

Posted Image

Translated to:

Xenocide.exe - App Error

App incorrectly innitiated (0xc0000135). Press 'OK' to finalize execution.



I'm running it on a Intel Core 2 Quad, NVIDIA GeForce 8800 GT, Windows XP SP2

#2 Mad

Mad

    Creative Text Department

  • [Xenocide Senior Members]
  • 1,958 posts

Posted 16 April 2008 - 05:30 AM

Do you have all the necessary prequesites installed?

* .Net Framework 2.0 (not 3.0)
* XNA Refresh 1.0 Runtime Distribution
* DirectX: DirectX 9.0c - be careful to not use a DirectX shipped with games, as these often lack some files

We will release a beta version of an installer in the next few days. It will check for these prequesites as well.
Keep smiling while dying

Of course I have gone mad with power! It would be completely ridiculous to go mad without power!
And no, this is not a quote from the Simpson's movie, I want it on paper, that I actually wrote that quite some time before the movie came out.

Posted Image

#3 Nick_Dx

Nick_Dx

    Squaddie

  • Forum Members
  • PipPip
  • 2 posts

Posted 16 April 2008 - 12:38 PM

where can I download the XNA refresh 1.0 runtime distro?
I surely have the DX 9.0c, and probably the .Net Framework, but i'm not sure about the XNA

#4 Darkhomb

Darkhomb

    Captain

  • Xenocide Artwork Department
  • 628 posts

Posted 16 April 2008 - 12:46 PM

http://www.microsoft...;DisplayLang=en

Please install latest vesion of Directx 9.0c, (there are updates every month, just because you have 9.0c doesn't mean you have the one we require.) just go to microsoft.com/directx and it will install what you need.

#5 Mad

Mad

    Creative Text Department

  • [Xenocide Senior Members]
  • 1,958 posts

Posted 16 April 2008 - 01:13 PM

where can I download the XNA refresh 1.0 runtime distro?
I surely have the DX 9.0c, and probably the .Net Framework, but i'm not sure about the XNA

Have a try with our new installer. It checks automaitcally for the prequesites. Please give feedback how it worked for you!
Keep smiling while dying

Of course I have gone mad with power! It would be completely ridiculous to go mad without power!
And no, this is not a quote from the Simpson's movie, I want it on paper, that I actually wrote that quite some time before the movie came out.

Posted Image

#6 Ashes

Ashes

    Squaddie

  • Forum Members
  • PipPip
  • 3 posts

Posted 02 September 2008 - 01:19 PM

where can I download the XNA refresh 1.0 runtime distro?
I surely have the DX 9.0c, and probably the .Net Framework, but i'm not sure about the XNA

Have a try with our new installer. It checks automaitcally for the prequesites. Please give feedback how it worked for you!


Hello,

I just downloaded your installer the other day and tried to install and run it. It installed all the prereqs properly and seemed to work fine but when I try to run the application I receive the same error as the original poster had. Please help.

Thanks

#7 StaffSargeant

StaffSargeant

    Sergeant

  • Xenocide Programming Department
  • 30 posts

Posted 02 September 2008 - 02:01 PM

Hello,

I just downloaded your installer the other day and tried to install and run it. It installed all the prereqs properly and seemed to work fine but when I try to run the application I receive the same error as the original poster had. Please help.

Thanks

Try downloading the latest DirectiX from Microsoft.

Please let us know how you get along. The new installer will not download prerequisites it believes are already installed, but it may be getting it wrong on occasion.

#8 Ashes

Ashes

    Squaddie

  • Forum Members
  • PipPip
  • 3 posts

Posted 02 September 2008 - 11:16 PM

Hello,

I just downloaded your installer the other day and tried to install and run it. It installed all the prereqs properly and seemed to work fine but when I try to run the application I receive the same error as the original poster had. Please help.

Thanks

Try downloading the latest DirectiX from Microsoft.

Please let us know how you get along. The new installer will not download prerequisites it believes are already installed, but it may be getting it wrong on occasion.


Tried that... manually downloaded the latest .NET Framework 2.0 and DirectX versions. Still nothing. Now I get a full blown error that wants to report back to Microsoft, but when I dig a little deeper, I get an Error Code of 0xe0434f4d.

Any help welcome!

thanks

Ashes

#9 kafros

kafros

    Creative Text Department

  • Xenocide Creative-Text Departmen
  • 1,800 posts

Posted 03 September 2008 - 05:11 AM

[GEEKS_ONLY] That's supposed to be a "CLR exception caused by the underlying COM interaction" [/GEEKS_ONLY]

Why did it happen? Don't know, it shouldn't! My best guess is that there's either a policy problem (have you installed the game at a network drive? Or a removable drive?), or you could try to REPAIR your .Net installation (Are you using .Net 2 SP1 btw?)

Are there any log files in the xenocide folder that you could attach here? Even the install log could be helpful :)

Edited by kafros, 03 September 2008 - 05:13 AM.


#10 Ashes

Ashes

    Squaddie

  • Forum Members
  • PipPip
  • 3 posts

Posted 03 September 2008 - 11:17 AM

[GEEKS_ONLY] That's supposed to be a "CLR exception caused by the underlying COM interaction" [/GEEKS_ONLY]

Why did it happen? Don't know, it shouldn't! My best guess is that there's either a policy problem (have you installed the game at a network drive? Or a removable drive?), or you could try to REPAIR your .Net installation (Are you using .Net 2 SP1 btw?)

Are there any log files in the xenocide folder that you could attach here? Even the install log could be helpful :)


Well I uninstalled and did a registry clean up and reinstalled. Seems to work now! Got to the opening menu but dont have time to start in quite yet! Really excited though!

I just want to thank you guys for working on this project and bringing it out. Nothing since then has really even touched what the original Xcom did for me... although it is fun to try and mod it out now a days.

Looking forward to this!

Thank you guys!

#11 kafros

kafros

    Creative Text Department

  • Xenocide Creative-Text Departmen
  • 1,800 posts

Posted 03 September 2008 - 12:29 PM

I'm happy to hear that :). Thanks for your kind word Ashes, take care!!



Reply to this topic