Jump to content


Photo

Game Can't Open /units.pck File


3 replies to this topic

#1 SleepyWu

SleepyWu

    Sergeant

  • Forum Members
  • PipPipPip
  • 13 posts

Posted 07 March 2006 - 08:34 AM

I encounered this strange problem. I tried different versions of UFO (CE, DOS, DosBox+UFO), but nothing changed.
So, the problem is: i try to land near ufo, or alien base (i think, it doesn't matter) and the equipment screen doesn't appear. Only the message "can't open /units.pck file". Then, after pressing 'escape', the results of a previous mission are displayed and game continues. It happens randomly, I had this bug on ufo's, base missions, terrors. CE-version sucsessfully started the battlescape, but there were too much bugs, such as sounds of human and alien deaths when I end turn, alien weapons on the ground, e.t.c.
I use UFO with 1.4 official patch + voice patch.

#2 Kratos

Kratos

    UFO2000 Staff

  • Moderators
  • PipPipPipPipPip
  • 4,113 posts

Posted 07 March 2006 - 03:24 PM

It is a widely known bug. IIRC, xcom util made by scott jones was trying to fix this before. Maybe check with this util?

#3 Hobbes

Hobbes

    UFO2000 Staff

  • Moderators
  • PipPipPipPip
  • 719 posts

Posted 08 March 2006 - 02:41 PM

Don't bother with XComUtil since it won't solve you that problem.

Usually the bug you described ("can't open /units .pck file" message) is not a bug at all, but the consequences of altering the contents of the files on the /units folder in a way that they are not compatible with the game. Have you installed any mods or altered the files? If you have then there's your problem.

There are other things from what you mentioned that don't seem right:

- You say you are using UFO with 1.4 patch. Well, the CE version already includes 1.4 patch. It might not be wise to install 1.4 with CE...
- If you are running DOS 1.0 you don't need the voices patch. Also I don't think the voice patch was designed to run with the DOS 1.4 version, but i am not sure of this one.

#4 SleepyWu

SleepyWu

    Sergeant

  • Forum Members
  • PipPipPip
  • 13 posts

Posted 09 March 2006 - 08:32 AM

Have you installed any mods or altered the files?

No I haven't. I used only voice patch to have old x-com sounds, because I've patched my 1.2 ver game(or 1.0?) to 1.4.

I tried to load this buggy save gave both in CE and DOS-versions. But the result was the same. I could see the battlescape in Ce-ver., but it was buggy...
I tried to save game in battlescape in CE-version and load it in DOS-ver, but this didn't help...
I continued to play and now I have 2 places with this bug: alien base and shot down UFO.



Reply to this topic