Jump to content


Compile Problems

  • Please log in to reply
1 reply to this topic

#1 Zyzyx



  • Forum Members
  • PipPip
  • 2 posts

Posted 10 January 2010 - 12:58 PM

Help! When I try to compile, when it gets to main.cpp, this happens:

g++ -MMD -funsigned-char -Wall -Wno-deprecated-declarations -I src/lua -I src/luasqlite3 -DDEBUGMODE -DUFO_SVNVERSION=\"1098M\" -O2 -pipe -DHAVE_FREETYPE -DGLYPH_TARGET=GLYPH_TARGET_ALLEGRO -DGK_NO_LEGACY -DHAVE_DUMBOGG -DHAVE_PNG -DWIN32 -DALLEGRO_STATICLINK -I mingw-libs/include -L mingw-libs/lib -c src/main.cpp -o obj-win32/main.o
In file included from mingw-libs/include/zconf.h:283,
				 from mingw-libs/include/zlib.h:34,
				 from src/zfstream.h:15,
				 from src/main.cpp:54:
c:/mingw/bin/../lib/gcc/mingw32/3.4.5/../../../../include/unistd.h:36: error: `int Sleep' redeclared as different kind of symbol
c:/mingw/bin/../lib/gcc/mingw32/3.4.5/../../../../include/winbase.h:1995: error: previous declaration of `void Sleep(DWORD)'
c:/mingw/bin/../lib/gcc/mingw32/3.4.5/../../../../include/unistd.h:36: error: declaration of `int Sleep'
c:/mingw/bin/../lib/gcc/mingw32/3.4.5/../../../../include/winbase.h:1995: error: conflicts with previous declaration `void Sleep(DWORD)'
c:/mingw/bin/../lib/gcc/mingw32/3.4.5/../../../../include/unistd.h:36: error: expected primary-exp<b></b>ression before "useconds"
c:/mingw/bin/../lib/gcc/mingw32/3.4.5/../../../../include/unistd.h:36: error: expected `)' before "useconds"
make: *** [obj-win32/main.o] Error 1

The wierd thing is that it looks like the problem is with some mingw libraries, and not ufo2000 code... Ive tried both MinGW 5.1.4 and 5.1.6, same problem. Im also using MSYS- and Windows Vista. I've gotten ufo2000 to compile before, but that was months ago, just today I decided to play with the sources again, and now this is happening. Help would be appreciated, thanks.

#2 Serge


    Project Leader: UFO 2000

  • Xenocide Programming Department
  • 785 posts

Posted 10 January 2010 - 04:14 PM

Based on your post in http://www.xcomufo.c...topic=242028614 I assume that you have solved the problem somehow :) Do we need something added to the compilation instructions in order to prevent other people from having the same troubles?
ufo2000 development team