Jump to content


Photo

Getting Tftd Dos Version To Work


25 replies to this topic

#1 j'ordos

j'ordos

    Alien Concept Task Force

  • Xenocide Artwork Department
  • 5059 posts

Posted 22 November 2003 - 04:54 AM

Those of you who use windows and can't get the CE to work, here's your last resort :) .

first off, if you haven't got it yet, get the old DOS version from here for example : then you need to get dosbox. Detailed information on how to install&use it can be found here

actually, I believe that great thread explains everything you need to know, makes my job easier. :beer:

Enjoy!

Edited by j'ordos, 18 January 2007 - 06:19 AM.

"You can't trust your eyes if your imagination's out of focus" - Mark Twain
"The mind is like an umbrella, it functions best when open" - Walter Gropius
Posted Image
SNEKK BLOG U-LAR MEKHH! GAHGHH! RK!
GRRGH RGGHH SNORRTT GHACKHGG

Now presented in DoubleVision™ (where drunk)

#2 Guest_Todd_*

Guest_Todd_*
  • Guests

Posted 30 August 2004 - 04:50 PM

Hi, I have both Dos and CE edition Terror from the deep and I cannot
get the dos version to run in Dosbox (Ive gotten Xcom 1 Dos to run in Dosbox). There is no batch file or exe file to run the game. Just the setp exe's and a couple .com files.
Can anyone explain to me simply what I need to do to run the game in Dosbox?
Thanks!
Todd

#3 j'ordos

j'ordos

    Alien Concept Task Force

  • Xenocide Artwork Department
  • 5059 posts

Posted 31 August 2004 - 04:41 AM

Hi, I have both Dos and CE edition Terror from the deep and I cannot
get the dos version to run in Dosbox (Ive gotten Xcom 1 Dos to run in Dosbox). There is no batch file or exe file to run the game. Just the setp exe's and a couple .com files.
Can anyone explain to me simply what I need to do to run the game in Dosbox?
Thanks!
Todd

<{POST_SNAPBACK}>

Run setup.exe, apply the correct settings, then run terror.com :)
"You can't trust your eyes if your imagination's out of focus" - Mark Twain
"The mind is like an umbrella, it functions best when open" - Walter Gropius
Posted Image
SNEKK BLOG U-LAR MEKHH! GAHGHH! RK!
GRRGH RGGHH SNORRTT GHACKHGG

Now presented in DoubleVision™ (where drunk)

#4 trooper005260

trooper005260

    Rookie

  • Forum Members
  • Pip
  • 0 posts

Posted 10 September 2004 - 04:06 PM

Hi, I have both Dos and CE edition Terror from the deep and I cannot
get the dos version to run in Dosbox (Ive gotten Xcom 1 Dos to run in Dosbox). There is no batch file or exe file to run the game. Just the setp exe's and a couple .com files.
Can anyone explain to me simply what I need to do to run the game in Dosbox?
Thanks!
Todd

<{POST_SNAPBACK}>

Run setup.exe, apply the correct settings, then run terror.com :)

<{POST_SNAPBACK}>

Hi ther I'm a FNG too. (Fing New Guy) I loved TFTD and want soo bad to get it to work with my new Window XP. I've downloaded the Dosbox form the sight you listed :D but cant get past opining dosbox. :blink: I can't get it to switch to my C drive it's; tell me that my C drive is not there :crying:

I went to http://vogons.zetafl...images/logo.png
but no help I can't understand it. what next?

BTW is there a FAQ somewhere on this sight for the FNG like me that ask this same question over and over and over?

#5 j'ordos

j'ordos

    Alien Concept Task Force

  • Xenocide Artwork Department
  • 5059 posts

Posted 11 September 2004 - 06:46 AM

Hi, I have both Dos and CE edition Terror from the deep and I cannot
get the dos version to run in Dosbox (Ive gotten Xcom 1 Dos to run in Dosbox). There is no batch file or exe file to run the game. Just the setp exe's and a couple .com files.
Can anyone explain to me simply what I need to do to run the game in Dosbox?
Thanks!
Todd

<{POST_SNAPBACK}>

Run setup.exe, apply the correct settings, then run terror.com :)

<{POST_SNAPBACK}>

Hi ther I'm a FNG too. (Fing New Guy) I loved TFTD and want soo bad to get it to work with my new Window XP. I've downloaded the Dosbox form the sight you listed :D but cant get past opining dosbox. :blink: I can't get it to switch to my C drive it's; tell me that my C drive is not there :crying:

I went to http://vogons.zetafl...images/logo.png
but no help I can't understand it. what next?

BTW is there a FAQ somewhere on this sight for the FNG like me that ask this same question over and over and over?

<{POST_SNAPBACK}>


I don't know where you got that link, but in the first post, I give a link to this page : http://vogons.zetafl...p?threadid=2502, which should get you started.
"You can't trust your eyes if your imagination's out of focus" - Mark Twain
"The mind is like an umbrella, it functions best when open" - Walter Gropius
Posted Image
SNEKK BLOG U-LAR MEKHH! GAHGHH! RK!
GRRGH RGGHH SNORRTT GHACKHGG

Now presented in DoubleVision™ (where drunk)

#6 tiddlywinks

tiddlywinks

    Squaddie

  • Forum Members
  • PipPip
  • 6 posts

Posted 29 October 2004 - 11:04 PM

Umm Where is DOSBox on that site i can't seem to find it. I see the big tutorial on installing it and such but can't find a DOWNLOAD button? :huh: ?

#7 tiddlywinks

tiddlywinks

    Squaddie

  • Forum Members
  • PipPip
  • 6 posts

Posted 29 October 2004 - 11:08 PM

Nevermind i found it sry I was kinda blind

#8 Guest_Stick_*

Guest_Stick_*
  • Guests

Posted 14 June 2005 - 05:30 PM

Hi i have the game but there is no music, i have sound effects, but no music. also i have xcom 1 too and it works much faster than xcom 2 any reasons why?

#9 Mustang

Mustang

    Captain

  • Forum Members
  • PipPipPipPip
  • 542 posts

Posted 26 November 2005 - 08:21 AM

Hey,
Thought I'd post this to help some people out there
Setting up DOSBox
it may lean more towards to the site's abandonware downloads, but if you have to much trouble TFTD might be there to download so you could follow the instructions exactly

WHEN YOU RUN IT IN DOSBOX:
Press control F12 until Frameskip is 12000 or so

Edited by Mustang, 26 November 2005 - 08:22 AM.



#10 Kharille

Kharille

    Sergeant

  • Forum Members
  • PipPipPip
  • 24 posts

Posted 18 January 2006 - 08:36 AM

Hi guys, need help. When I try to run this on Dosbox I find that there's several things like geoscape and sound going wrong. It says something about illegal operation or something like that. Does anyone have any recommendations?

#11 blue123

blue123

    Sergeant

  • Xenocide Recruit
  • 12 posts

Posted 04 March 2006 - 02:30 PM

WHEN YOU RUN IT IN DOSBOX:
Press control F12 until Frameskip is 12000 or so

<{POST_SNAPBACK}>


Ughh. It still runs jerky though.

#12 HdS

HdS

    Rookie

  • Forum Members
  • Pip
  • 0 posts

Posted 12 July 2006 - 11:58 AM

The solution doesn't work for me, DosBox crashed down after starting terror.com
But there is a simple solution: just download the patch http://freelancer.ag...index_eng.shtml (scroll down) and install.

I hope i can halp some guys.
Sorry for my bad english,i come from germany

#13 thingmaker

thingmaker

    Rookie

  • Forum Members
  • Pip
  • 0 posts

Posted 31 July 2006 - 12:54 PM

Hi. New here...
I haven't played TFTD for years.
Just fished out my old TFTD (dos) and set it up on my XP system... without dosbox. I have only encountered one problem with a couple of missions.
Everything is fine except for crashes which only seem to occur on the Battlescape and only seem to happen when Hidden Movement occurs. You know the drill: screen blacks, hidden movement text comes up... That's when the crash happens. There's some sort of illegasl operation message...
It's too frequent for me to consider saving often and putting up with it.
SO
Is this a known problem?
Should I use DOSBox? Will it likely solve this? (Was I stupid to try without DOSBox?)
What about the Collector's Edition? Should I try to get a copy of that instead?

I just want to save the world. Is that too much to ask?

#14 Guest_Slayed Slayer_*

Guest_Slayed Slayer_*
  • Guests

Posted 01 August 2006 - 10:34 PM

Hi everybody !

I' ve a problem and I need help :

I installed the DOSBox ( version 0.65 to precise ) on my PC Windows XP and I'm trying to get TFTD working. When I created the mount in the DOSBox, like this :

Z:\>mount c C:\***\********\TFTD\

P.S.: Yes, I voluntary censored my folder for here. ;)

Then, he says, right after :

Drive c is mounted as local directory C:\****\********\TFTD\

My question is : Now, I do What ? I go on this site (
http://vogons.zetafl...opic.php?t=2502 ) And I didn' t found my answer.

Thanks in advance, every one. =b

#15 grommet

grommet

    Sergeant

  • Forum Members
  • PipPipPip
  • 26 posts

Posted 02 August 2006 - 11:46 AM

Well, you've mounted the dir as c:, but you're still on the z:/> prompt...so type "c:" and hit <enter> then type "terror" or whatever command you use to start the game (could be terror, tftd, runxcom, runxcomw [the last two are if you use xcomutil]...usually terror)

You may need to run setup from within dosbox to configure your sound settings first...note that you want to use the same sound settings in the game that you do in the dosbox.conf file (default is soundblaster16, address 220, irq 7, dma 1)

Note that you can set dosbox to automatically mount the tftd folder as c: (or any drive) and change to it by putting those commands ("mount c c:\***\******\tftd" and "c:" in the dosbox.conf file after [AutoExec]


Grommet

#16 Jezulkim

Jezulkim

    Captain

  • Forum Members
  • PipPipPipPip
  • 194 posts

Posted 09 August 2006 - 10:02 AM

I can't get tftd run at all - it just stops right after start. Any ideas?
The dosbox title bar says: Program: Intro. And there's no intro.exe/com/whatever on my tftd folder.
That's my team in my avatar!

#17 Jezulkim

Jezulkim

    Captain

  • Forum Members
  • PipPipPipPip
  • 194 posts

Posted 15 August 2006 - 04:40 AM

Whoa! Sell your computers if you need money for food! and don't post here. Hey wait you're spam bots :huh:
And now to the business. So, does anyone know how to play TFTD with dosbox?
That's my team in my avatar!

#18 reist

reist

    Programming Department

  • Xenocide Programming Department
  • 130 posts

Posted 16 August 2006 - 03:15 AM

I can't get tftd run at all - it just stops right after start. Any ideas?
The dosbox title bar says: Program: Intro. And there's no intro.exe/com/whatever on my tftd folder.

Well, there's intro.exe in Xcom:EU, not in TFTD. I'm using dosbox to play both and there's no file even close to being name intro in the TFTD directory. There is an intro.exe in EU.
Maybe you've got mixed executables?

#19 Jezulkim

Jezulkim

    Captain

  • Forum Members
  • PipPipPipPip
  • 194 posts

Posted 16 August 2006 - 09:13 AM

It's not that - I could run the game directly from xp by clicking the icon. But the sounds were bad, it had no music and it was very, very fast.
That's my team in my avatar!

#20 reist

reist

    Programming Department

  • Xenocide Programming Department
  • 130 posts

Posted 16 August 2006 - 10:03 AM

And without dosbox you get the intro played?
Sounds strange, as if dosbox misses a files or something like that and terror.com fails. I remember it happening with older versions...really older version.
You are running terror.com directly right?

If dosbox still doesn't work for you, you could try installing VDMSound and one of the "cpu killing programs", like at-slow, moslo or one of the newer, directed at windows variants.

#21 Jezulkim

Jezulkim

    Captain

  • Forum Members
  • PipPipPipPip
  • 194 posts

Posted 17 August 2006 - 08:03 AM

And without dosbox you get the intro played?

Yes, the slide show.

You are running terror.com directly right?

Yes, running it directly.

Maybe I'll try to find another copy and see if it's any better.
That's my team in my avatar!

#22 grommet

grommet

    Sergeant

  • Forum Members
  • PipPipPip
  • 26 posts

Posted 17 August 2006 - 03:20 PM

Hmmm...thats strange, TFTD never launches a process called Intro on my computer. Just to make sure, I slowed DOSBox to 1 (yes, 1!) cycle so that I saw everything that the program launches upon startup. Basically, the title bar of the DOSBox window went from reading Program: DOSBox to reading Program: Sndstart, then (about 2 minutes later, you definitely wouldn't wanna play at 1 cycle :P )to Program: GeoScape.

Incidentally, BEFORE the program starts to play the slideshow/animation, you should get the screen that asks you to choose your language (English, German, French, or Spanish)...do you get that screen, or does it freeze before that? If so, seeing as Sndstart is the first process I saw it call, maybe your sound setup is incorrect? Remember that dos programs have to be TOLD what memory addresses, IRQs, and DMAs to use or they won't work right...DOSBox defaults to SoundBlaster16, address 220, IRQ 7, DMA 1 & 5, so try running SETUP.EXE from DOSBox and setting it for those (unless, of course, you have different settings specified in DOSBox.Conf...check it to see)

Finally, are you running the CD version of TFTD? If so, you will need to either mount your CD drive (MOUNT [thedriveletteryouwantDOSBoxtogiveyourCD] [yourCDdriveletter]:\ -t cdrom) or completely install the program to your hard drive (find the \HARDDISK directory on the CD and copy it to your hard drive)

Grommet

#23 Jezulkim

Jezulkim

    Captain

  • Forum Members
  • PipPipPipPip
  • 194 posts

Posted 10 September 2006 - 12:10 PM

Sorry about a late (very late) reply.

should get the screen that asks you to choose your language (English, German, French, or Spanish)...do you get that screen, or does it freeze before that?

It freezes before the language selection, yes.

Remember that dos programs have to be TOLD what memory
addresses, IRQs, and DMAs to use or they won't work right...

I tried the default settings, and even no music and no sound effects. It didn't help.

Finally, are you running the CD version of TFTD?

Nope, I have the floppy disc version.
That's my team in my avatar!

#24 Jezulkim

Jezulkim

    Captain

  • Forum Members
  • PipPipPipPip
  • 194 posts

Posted 07 October 2006 - 05:51 PM

Just wanted to tell you, I got it working by updating the game to the version 2.0. I never knew there were patches.
That's my team in my avatar!

#25 kyle125

kyle125

    Rookie

  • Forum Members
  • Pip
  • 0 posts

Posted 23 October 2006 - 09:48 AM

I've tried using the 2.0 version, but this has made it worse. The game now won't run and says "The system cannot find the path specified"

Any advice?

#26 Puasonen

Puasonen

    Creative Text Department

  • Xenocide Inactive
  • 2911 posts

Posted 19 January 2007 - 02:26 AM

In my game, the music works fine but fx sounds comes a bit late. When you push a button, the sound comes after one second. That applies to all sounds except music. Pretty annoying, if someone knows a solution, please tell me.
There's no need for a sig..



Reply to this topic