Jump to content


Photo

Mapping Problem


  • Please log in to reply
7 replies to this topic

#1 Junkhead

Junkhead

    Sergeant

  • Forum Members
  • PipPipPip
  • 20 posts

Posted 07 January 2006 - 09:24 PM

I tried making a map, and I followed every instruction in the mapping manual to the letter, and the map will not show up in the mission planner. I've checked all my stuff 3 times, and I can't figure out what's going on! Can you guys help me?

Attached is the .lua file and the map files. Please, tell me what's wrong, I really want to make a map and contribute to this great game :)

EDIT: Apparently the zip file attached was corrupt, so I compressed the file as a 7zip under an SFX archive (self-extracting, so you don't need any additional software to extract the file)

EDIT2: Ok, the problem is resolved now. As Hobbes said:

Got it. First need to rename all of the map files with the format 'whateverXX.map', with XX being 00, 01, 02, etc.
And the 'blanks.*" line on the .lua should be the first terrain listed.


So, for anyone else having this problem, make sure you rename the files accordingly and that the blanks file is listed as first in the LUA.

Also, I've uploaded my first draft of the map here, if you want to play it. A second draft is in the making.

Attached Files


Edited by Junkhead, 10 January 2006 - 08:18 PM.


#2 Junkhead

Junkhead

    Sergeant

  • Forum Members
  • PipPipPip
  • 20 posts

Posted 09 January 2006 - 08:18 PM

Wow, 20 views and no replies? C'mon, someone please help me :(

#3 Hobbes

Hobbes

    UFO2000 Staff

  • Moderators
  • PipPipPipPip
  • 719 posts

Posted 09 January 2006 - 10:11 PM

I would glady help but i can't open the file (the download comes corrupted).

#4 Exo2000

Exo2000

    Colonel

  • Moderators
  • PipPipPipPipPip
  • 1,009 posts

Posted 10 January 2006 - 12:25 AM

I can't load the maps in MapView - they don't display properly at all! I can't even get them to show up even when double-clicking on them.

The .lua appears to be in perfect condition, however.
Posted Image

#5 Hobbes

Hobbes

    UFO2000 Staff

  • Moderators
  • PipPipPipPip
  • 719 posts

Posted 10 January 2006 - 06:36 AM

Can you send the file to the email on my profile? thanks

#6 Junkhead

Junkhead

    Sergeant

  • Forum Members
  • PipPipPip
  • 20 posts

Posted 10 January 2006 - 02:35 PM

I uploaded a new file, it's in the 7-zip format, and its an SFX archive, so it's self extracting.

#7 Hobbes

Hobbes

    UFO2000 Staff

  • Moderators
  • PipPipPipPip
  • 719 posts

Posted 10 January 2006 - 03:38 PM

Got it. First need to rename all of the map files with the format 'whateverXX.map', with XX being 00, 01, 02, etc.
And the 'blanks.*" line on the .lua should be the first terrain listed.

#8 Junkhead

Junkhead

    Sergeant

  • Forum Members
  • PipPipPip
  • 20 posts

Posted 10 January 2006 - 08:20 PM

Got it. First need to rename all of the map files with the format 'whateverXX.map', with XX being 00, 01, 02, etc.
And the 'blanks.*" line on the .lua should be the first terrain listed.

<{POST_SNAPBACK}>


Thanks for the help, I owe you one most definitely. The map works now. I'm working on a second draft for it now, and I've uploaded the correct working version above, for anyone who wants to test it out.