Jump to content


Photo

Base Texture Task Force


  • This topic is locked This topic is locked
123 replies to this topic

#51 Blankstar

Blankstar

    Sergeant

  • Forum Members
  • PipPipPip
  • 50 posts

Posted 07 July 2004 - 08:44 PM

oops sorry forgot to add
trying #2
file #2

Attached Files



#52 Blankstar

Blankstar

    Sergeant

  • Forum Members
  • PipPipPip
  • 50 posts

Posted 07 July 2004 - 08:50 PM

#3

Attached Files



#53 Guest_drewid_*

Guest_drewid_*
  • Guests

Posted 08 July 2004 - 06:26 AM

Is that the exe RARed up? (can't be, it's too big :hammer: ).

Might get a chance to do some actual texturing tonight. I'm using Maya, but I guess the exporter will spit out something sensible that should work.

#54 red knight

red knight

    Xenocide Project Leader

  • Xenocide Inactive
  • 3,310 posts

Posted 08 July 2004 - 07:23 AM

Axiom is a straight C# port of Ogre, in fact it was ported very fast, like in 2 months of so with lots of code less than Ogre (another extra testimony of the power of .Net /Java type of reflexive and uniform languages).

If you see the code of the demos in C++ (Ogre) and C# (Axiom) you will notice is the same concept/kind of implementation. (A little more clean in C# though).

If nobody has lucky on Chronos I will see if I can do something on saturday, as I have to help my Computer Graphics professor to prepare an Advance Computer Graphics course, and I suggested him to use Axiom (as it is a remarkable port of Ogre) so I will have to do it anyways.

Greetings
Red Knight
Sourceforge Nick: flois - Federico Andres Lois
Visit my blog at: flois.blogspot.com

Posted Image

Pookie cover me, I am going in.

#55 Thalo

Thalo

    Sergeant

  • Forum Members
  • PipPipPip
  • 39 posts

Posted 08 July 2004 - 11:23 AM

I should be able to get to work on this tonight through the weekend.

Blankstar, what have you accomplished, and what could you delegate to me or one of the others to get going faster?

I feel fairly comfortable with Ogre and Axiom, and I'll look at them more closely going into the weekend. Blank or Drewid, if you guys have a specific task, let me know and I'll hop on it.

#56 Blankstar

Blankstar

    Sergeant

  • Forum Members
  • PipPipPip
  • 50 posts

Posted 08 July 2004 - 04:38 PM

Thanks thelo.
um lets see what ive accomplished. Not much to tell the truth. im waiting to see some Files from the texturers (.mesh and .material). i was working with fabguy before he left for tests. he sent me the .3ds and a .material the .3ds wasnt spit into submeshes so that i could export it into a .mesh and use the .material.
As for showing damages i was thinking on some ideas. What we could do(i dont know if this is the best way to go or not) but use the .materials to do stuff. for the fadingin/out we can use the neat transparency(modified) that came in the examples.material. we can fade in parts(aka submeshes in .mesh) telling the engine to texture the part using the .material so some will be transparent while some of it will be there as it will be in the end then we can have the normal.material load at the end in which it will be a complete model being displayed. i suggest the same for damage. Like smoke and explosion marks we can just tell the engine (using the .material) to load up a different texture(the .jpg or .png) on the submesh.(the .jpg or .png being the texture that is darker or has marks of explosions on it). now depending on how demolishing it goes that could get tricky and i havent put much thought into it( the only way i see it is load a bunch of .mesh on load up some being the damaged ones to completely destroyed and have the ones not being used invisible and when needed have the current go invisible and the one needed become visible.)(the reason of the disapearing act is the time tackin to load the .meshes)

#57 FabGuy

FabGuy

    Sergeant

  • Forum Members
  • PipPipPip
  • 57 posts

Posted 08 July 2004 - 10:59 PM

I've tried the exporter. Hope it turned out nicely. :D

I've also re-exported the materials as there might have been a little change. The graphics are not included.

Attached Files



#58 Blankstar

Blankstar

    Sergeant

  • Forum Members
  • PipPipPip
  • 50 posts

Posted 09 July 2004 - 11:10 PM

Nice Im I got the correct files this time. im going to work on it. I need to tweak the .material cuz theres doubles of some stuff.(LOL) i hope you didnt copy paste frome the old one. if so i dont care. THe next post from me will be a pic of the model in the engine.

#59 Blankstar

Blankstar

    Sergeant

  • Forum Members
  • PipPipPip
  • 50 posts

Posted 10 July 2004 - 01:00 AM

Fabguy dude it looks pretty good. OK heres a rule of thumb. after your done exporting the .mesh.xml open it and look at it you will have to close all the tabs then open the .material by renaming it to a .txt (also name both files the same name when exporting) match the materials in the .material to the materials in the .mesh.xml if they match your good if not you need to redo the mesh. in the case of teh attached pic you need to redo the mesh export. Selecting everything. then reexport the .material. hopefully it will work.

Attached Files



#60 Blankstar

Blankstar

    Sergeant

  • Forum Members
  • PipPipPip
  • 50 posts

Posted 10 July 2004 - 01:13 AM

and another with more light to the thing and a different angle

Attached Files



#61 FabGuy

FabGuy

    Sergeant

  • Forum Members
  • PipPipPip
  • 57 posts

Posted 10 July 2004 - 01:40 AM

Okay... I'll see what I can do though I can open them without renaming ;)

I think I had the gun textured already. I take it OGRE doesn't like the generic textures and needs an image. *sighs*

Seeing the weired angle of the walls - can you check if this error persists if you see them from other angles?

And the floor-textures... it should have been mirrored a few times so its like small plates all over the area.

#62 Vaaish

Vaaish

    Artwork Department

  • Xenocide Inactive
  • 1,625 posts

Posted 10 July 2004 - 01:41 AM

There are some serious smoothing group errors from the original models I have. I'll try to get them exported again but I can't promise anything. BTW have you finished mapping the complex yet? I ask because I see some real wird things happeing with some of those textures.

#63 Thalo

Thalo

    Sergeant

  • Forum Members
  • PipPipPip
  • 39 posts

Posted 10 July 2004 - 10:58 AM

Update - I decided to update my Axiom via CVS before getting started... BAD IDEA.

Axiom is currently in the middle of a reorganization of files, and leedgitar is supposed to post batch files to create the sln and csproj files, but hasn't yet.

So, i'm going through and trying to get it all working and compiling manually, but it might take me awhile....

Meanwhile don't update your Axiom until he posts those bat files!! :blink:

#64 spu7nic

spu7nic

    Squaddie

  • Forum Members
  • PipPip
  • 7 posts

Posted 10 July 2004 - 11:55 AM

I allready noticed :(,
so I'll have to wait, till these files are put to the repository ...

#65 Guest_drewid_*

Guest_drewid_*
  • Guests

Posted 10 July 2004 - 04:01 PM

looking pretty dark on my monitor. How many lights going on?

#66 Blankstar

Blankstar

    Sergeant

  • Forum Members
  • PipPipPip
  • 50 posts

Posted 10 July 2004 - 07:13 PM

what do you mean by lights textured lights or Graphically attached lights
i can do the attached lights (Hopefully) SharpDevelopment seems to be a bit lacking so im in the process of aquiring Visual Studio .Net

#67 Blankstar

Blankstar

    Sergeant

  • Forum Members
  • PipPipPip
  • 50 posts

Posted 10 July 2004 - 07:14 PM

Thats so i can work with axiom till then i will work with ogre (also hopefully i will get dotscene working)

#68 spu7nic

spu7nic

    Squaddie

  • Forum Members
  • PipPip
  • 7 posts

Posted 11 July 2004 - 07:19 AM

I finally managed to get the Worldeditor run on my machine...

Most of the buttons don't do anything right now...

Posted Image

But I don't think it's very usefull, yet ... I got a lot of lockups, there's no way to save or load things and the only way to close that prog is using taskman. (But I'm not sure, if I did something wrong...)

That shot is after placing the meshes you can see on the first screen ...
Posted Image

Edited by spu7nic, 11 July 2004 - 07:21 AM.


#69 red knight

red knight

    Xenocide Project Leader

  • Xenocide Inactive
  • 3,310 posts

Posted 11 July 2004 - 09:01 AM

Great news, was too difficult to make it work?? Maybe we are missing something. The idea of using the editor is to preview how the meshes will look in the engine and to have freedom editing material scripts.

That loading plugin (name) sounds kinda strange.

I would suggest you to take a look at this thread: http://axiomengine.s...der=asc&start=0

And post the distribution (or send it to my by mail) to put it in the server so our artists can tell us what they need so we can start enhancing it. (on the other side as Axiom is pretty similar to Ogre, you will gain vast knowledge in it).

Greetings
Red Knight
Sourceforge Nick: flois - Federico Andres Lois
Visit my blog at: flois.blogspot.com

Posted Image

Pookie cover me, I am going in.

#70 spu7nic

spu7nic

    Squaddie

  • Forum Members
  • PipPip
  • 7 posts

Posted 11 July 2004 - 09:30 AM

Maybe it would be better to create just a simple app, wich lets you open a mesh-file, assign any material and refresh the screen as soon as there are changes made to the files?

As I said, the editor isn't really useful yet ... but maybe you should try it yourself ;) ... just to see what I mean.

Just an example ;) ... I tried several things, but I found no way to move the meshes in the scene (just managed to scale them and change the position of the camera).

Edited by spu7nic, 11 July 2004 - 09:32 AM.


#71 red knight

red knight

    Xenocide Project Leader

  • Xenocide Inactive
  • 3,310 posts

Posted 11 July 2004 - 11:03 AM

How is the state of the source, it is well designed or not? Cause if it is well designed between creating our own app and modify something that exists the second is the better way to go, on the other hand if that is not the case then we should consider create our own app.

What do you people think? Drew in your experience any idea of what would be the requirements for such an application and the way to go?

Greetings
Red Knight
Sourceforge Nick: flois - Federico Andres Lois
Visit my blog at: flois.blogspot.com

Posted Image

Pookie cover me, I am going in.

#72 spu7nic

spu7nic

    Squaddie

  • Forum Members
  • PipPip
  • 7 posts

Posted 11 July 2004 - 12:37 PM

How is the state of the source, it is well designed or not? Cause if it is well designed between creating our own app and modify something that exists the second is the better way to go, on the other hand if that is not the case then we should consider create our own app.

What do you people think? Drew in your experience any idea of what would be the requirements for such an application and the way to go?

Greetings
Red Knight


Difficult to say, we need to question ourselfes, what kind of tool we actually need ...

It seems to be more or less simple to display a mesh with textures in a window and make it refresh when there are changes applied to the files. If we don't need a fully grown scene composer, where we can put lots of models, lights, etc. into one scene and arrange them, scale them and so on ... it might be easier to create a small tool yourself, than expand a foreign one (till now I took no closer look at the sources - my first goal was to make that thing run).
But if we would like to have that big solution instead of the small viewer, the whole situation changes ...

There's also a second think we'll have to keep in mind: It might be a little bit senseless to expand the first Worldeditor when there's will be a more modular 2nd version with much better structured code.

Edited by spu7nic, 11 July 2004 - 12:38 PM.


#73 Blankstar

Blankstar

    Sergeant

  • Forum Members
  • PipPipPip
  • 50 posts

Posted 12 July 2004 - 04:06 PM

How did you get it working?

and anyone familiar with axiom tell me why i cant load a .mesh file that loads perfectly fine in ogre but not axiom. I know my syntax is correct because i change the .mesh name to ogrehead and it loads. but when i change it to mine it kinda freezes

#74 spu7nic

spu7nic

    Squaddie

  • Forum Members
  • PipPip
  • 7 posts

Posted 12 July 2004 - 04:34 PM

Actually I used the included axiom binaries (as long as the restructuring of the axiom repository isn't finished) - maybe that was the fault, which caused it to be that instable...

As soon as I got it running with the right version of axiom, I'll write a little tutorial. Just gimme a few more time *smile*.

One thing I'll have to announce... because I am moving to another town, it may be, that you see me only a few times in the next two or three weeks! I'll do my best to keep you informed ;) - but maybe I'll have to wait some days till I get inet in my new apartment.

Edited by spu7nic, 12 July 2004 - 04:44 PM.


#75 Guest_drewid_*

Guest_drewid_*
  • Guests

Posted 14 July 2004 - 01:37 PM

Have a good move and don't get too stressed...
:cussing:
:D

#76 Blankstar

Blankstar

    Sergeant

  • Forum Members
  • PipPipPip
  • 50 posts

Posted 14 July 2004 - 06:21 PM

allright finnally have vs.net and wow its not as crappy as sharpdevelopment( I STRONGLY RECOMMEND THIS AS A LAST RESORT). MS C++.net opened and got the chronos editor running the moment i opened it. (go figure). ITs as spu7nic says
it doesnt do much
anything else you need me to do let me know

#77 red knight

red knight

    Xenocide Project Leader

  • Xenocide Inactive
  • 3,310 posts

Posted 16 July 2004 - 10:38 AM

Drew, what do you suggest to implement that would be needed?

Blankstar and spu7nic start implementing a sandbox that would let you open a mesh, show it and move the light arround so we can see how it would look in xenocide.

Greetings
Red Knight
Sourceforge Nick: flois - Federico Andres Lois
Visit my blog at: flois.blogspot.com

Posted Image

Pookie cover me, I am going in.

#78 Blankstar

Blankstar

    Sergeant

  • Forum Members
  • PipPipPip
  • 50 posts

Posted 19 July 2004 - 10:05 PM

sorry i didn't respond but i have been working on making the program to load the mesh's i have an idea on how to do it. all i need now is to make a frameListener class of my own so that i can impliment stuff correctly. so that away the i,j,k,l,u,o keys will move the light around along with haveing the arrow keys and mouse move the world around and if you hit the n key it will open an input box where you can type the name of the mesh file and it will load.

Im currently using the Ogre version It should be easy to put over to Axiom however when i was screwing around with it i was unable to load my fushionfacility.mesh that i showed off in ogre into axiom im still working on it.

so before i really get coding which graphic engine do you want me to use either one i believe i can accomplish

#79 red knight

red knight

    Xenocide Project Leader

  • Xenocide Inactive
  • 3,310 posts

Posted 21 July 2004 - 06:22 AM

Use the one that suits your needs (for learning), but think that we will probably evolve that app to what we need so it will be necesary to add a standard GUI in there so in that Axiom is far more compatible.

Greetings
Red Knight
Sourceforge Nick: flois - Federico Andres Lois
Visit my blog at: flois.blogspot.com

Posted Image

Pookie cover me, I am going in.

#80 Blankstar

Blankstar

    Sergeant

  • Forum Members
  • PipPipPip
  • 50 posts

Posted 21 July 2004 - 07:33 AM

very well i will do it in axiom. ill start on it today i have some time to work on it so hopefully i will be able to get it done soon

#81 Blankstar

Blankstar

    Sergeant

  • Forum Members
  • PipPipPip
  • 50 posts

Posted 22 July 2004 - 01:57 PM

Well all is going well ill have it done within the next half hour or so
ill be writing up instructions then everyone havefun with it

#82 Blankstar

Blankstar

    Sergeant

  • Forum Members
  • PipPipPip
  • 50 posts

Posted 22 July 2004 - 03:02 PM

I havent been able to post the files ill check later its done for anyone who wants it ill try to figure a way to get it to you

#83 Blankstar

Blankstar

    Sergeant

  • Forum Members
  • PipPipPip
  • 50 posts

Posted 23 July 2004 - 03:52 PM

Can someone tell me why i cant attach anything to my posts and why the attachments Has global space left -7789499bytes??

#84 Micah

Micah

    Colonel

  • [[Administrators]]
  • PipPipPipPipPip
  • 2,290 posts

Posted 24 July 2004 - 12:51 AM

Can someone tell me why i cant attach anything to my posts  and why the attachments Has global space left -7789499bytes??

<{POST_SNAPBACK}>

Nope, sorry, that's classified.

But seriously, you should have no problem now.

#85 Blankstar

Blankstar

    Sergeant

  • Forum Members
  • PipPipPip
  • 50 posts

Posted 26 July 2004 - 10:03 PM

well it says global at 708 so heres an outside link to where ive put it(my website which is kinda going towards deralict scince i dont think anyone was visiting it but ill work on it later


look below

Edited by Blankstar, 07 August 2004 - 03:39 PM.


#86 Micah

Micah

    Colonel

  • [[Administrators]]
  • PipPipPipPipPip
  • 2,290 posts

Posted 27 July 2004 - 02:06 AM

What do you mean by "it says global at 708"? I'm trying to make it so you can upload with no problem, and I thought I fixed it, so can you please explain what the forum is doing?

#87 Blankstar

Blankstar

    Sergeant

  • Forum Members
  • PipPipPip
  • 50 posts

Posted 27 July 2004 - 02:33 PM

Yah no prob sorry i went to start uploading it its 10.2 Mb cuz of a folder in it called Media Im not 100 percent sure on what it needs in it and i left it there in case we add anything i wouldnt have to update it. so when i uploaded the first file all was good. when i did the second file it said 708k left so i edited my post removing the file and putting a link to download the file from my server.

#88 Blankstar

Blankstar

    Sergeant

  • Forum Members
  • PipPipPip
  • 50 posts

Posted 27 July 2004 - 04:09 PM

Alright my PRogram is working and complete anything else anyone needs from my task force LEt me know

#89 Micah

Micah

    Colonel

  • [[Administrators]]
  • PipPipPipPipPip
  • 2,290 posts

Posted 27 July 2004 - 04:16 PM

Yah no prob sorry i went to start uploading it its 10.2 Mb cuz of a folder in it called Media Im not 100 percent sure on what it needs in it and i left it there in case we add anything i wouldnt have to update it. so when i uploaded the first file all was good. when i did the second file it said 708k left so i edited my post removing the file and putting a link to download the file from my server.

<{POST_SNAPBACK}>



Okay, check your PM box for some info.

#90 red knight

red knight

    Xenocide Project Leader

  • Xenocide Inactive
  • 3,310 posts

Posted 28 July 2004 - 12:04 PM

Blankstar I couldnt download the program from your server, somehow it is not complete (only 32 kb)... can you check it?

Greetings
Red Knight
Sourceforge Nick: flois - Federico Andres Lois
Visit my blog at: flois.blogspot.com

Posted Image

Pookie cover me, I am going in.

#91 spu7nic

spu7nic

    Squaddie

  • Forum Members
  • PipPip
  • 7 posts

Posted 02 August 2004 - 10:47 AM

Back I am - and may the force be with you :P

Today I got inet on my new apartment, it took almost half an hour to fetch all my mails - amazing...

#92 Blankstar

Blankstar

    Sergeant

  • Forum Members
  • PipPipPip
  • 50 posts

Posted 05 August 2004 - 09:40 PM

alright finnally things are starting to look up. i wasnt allowed to post the last time i was on but i did post a file to the ftp server just couldnt add the link. well heres the link and thanks to micah im able to give you this program and straighten things out. (thanks for your help).

look below

Edited by Blankstar, 07 August 2004 - 03:38 PM.


#93 Micah

Micah

    Colonel

  • [[Administrators]]
  • PipPipPipPipPip
  • 2,290 posts

Posted 06 August 2004 - 01:19 AM

Blankstar, I'm getting an "unexpected end of archive" while trying to unrar the file. The server says the file is 10,485k. Is that the correct size?

#94 Blankstar

Blankstar

    Sergeant

  • Forum Members
  • PipPipPip
  • 50 posts

Posted 07 August 2004 - 03:17 PM

Yah it should be let me look at it.

#95 Blankstar

Blankstar

    Sergeant

  • Forum Members
  • PipPipPip
  • 50 posts

Posted 07 August 2004 - 03:37 PM

sorry it should now work i reuploaded it. I should have done that the first time. halfway through it for somereason i got booted so i continued uploading the file instead of reuploading i know reuploaded it and it works just click the link here

Model viewer program

#96 centurion

centurion

    Programming Department

  • Xenocide Programming Department
  • 800 posts

Posted 08 August 2004 - 06:51 AM

When trying to run the program, it spits back:

A kódösszeállítás egy vagy több típusa nem tölthető be.
at System.Reflection.Module.GetTypesInternal(StackCrawlMark& stackMark)
at System.Reflection.Assembly.GetTypes()
at Axiom.Core.PluginManager.ScanForPlugins()
at Axiom.Core.PluginManager.LoadAll()
at Axiom.Core.PluginManager..ctor()
at Axiom.Core.PluginManager.Init()
at Axiom.Core.Engine.Setup()
at Axiom.Utility.TechDemo.Setup()
at Axiom.Utility.TechDemo.Start()
at FRSAxiomTut1.Tut1.Main()
press a key

Could you please upload the missing dll's?
Endure; in enduring, grow strong.
- Dak'kon

Help us getting Civ2 code: http://forums.civfan...p...age=1&pp=20 !

#97 Blankstar

Blankstar

    Sergeant

  • Forum Members
  • PipPipPip
  • 50 posts

Posted 11 August 2004 - 05:05 PM

sorry ive been busy at work my manager is on vacation so im acting in his place. so ive been working late and more than i usually am i will figure out wich dlls are missing and post them asap

#98 Blankstar

Blankstar

    Sergeant

  • Forum Members
  • PipPipPip
  • 50 posts

Posted 15 August 2004 - 09:12 AM

OK Try it again ive just uploaded what the entire file Including the Solution for Other programers to look at if they wish. Or if anything help me get it out

#99 Guest_drewid_*

Guest_drewid_*
  • Guests

Posted 20 August 2004 - 03:17 PM

I'm thinking I should be able to get more time free now which should mean I can actually do some co-ordinating.

SO

Guys doing texturing, where are we up to?

#100 Thalo

Thalo

    Sergeant

  • Forum Members
  • PipPipPip
  • 39 posts

Posted 23 August 2004 - 08:01 AM

I'm still here.

I have been watching to see if what Blankstar delivered is complete or needs more work. I also had problems getting Axiom environment set up, but I believe I'm past those.

Basically, ready for a task based on what remains following Blankstar's work.