Jump to content


Photo

Problems Conecting To The Server From Linux


  • Please log in to reply
6 replies to this topic

#1 Soros

Soros

    Squaddie

  • Forum Members
  • PipPip
  • 9 posts

Posted 13 October 2005 - 04:14 PM

Hi,

I've just succesfully install (I think) the linux versión of ufo2000 on my computer (debian sarge). Everything seems to work properly, I can play without problemes in the hostseat mode. But any time I try to conect the server the next message appears:

fail to connect the ufo2000 server

Apparently it must be a problem with the ports, but I don't know which port should I open or how can I do it. Do you have any suggestions?

Thanks a lot,

Soros

#2 Serge

Serge

    Project Leader: UFO 2000

  • Xenocide Programming Department
  • 785 posts

Posted 14 October 2005 - 09:30 AM

Do you use precompiled binary? There is a known issue reported: http://ufo2k.lxnt.in...view.php?id=185

As for ports, the game connects to the server using TCP port 2000 (or port 2001 for beta server).
ufo2000 development team
http://ufo2000.sourceforge.net

#3 Soros

Soros

    Squaddie

  • Forum Members
  • PipPip
  • 9 posts

Posted 14 October 2005 - 12:58 PM

I've just read the issue and that is not my problem. The ufo 2000 doesn't finish abruptly when I try to connect but a "failed to connect uffo2000 server" appears and it returns to the login screen. Of course, I've check that the server name is correct and the login name and password are correct too.

And yes, I'm using the precompiled version. I've tried to use the source versión, but apparently the program doesn't find the requiered libraries (although they have been installed without problems using apt, except for hawknl which I had to install using "make").

I'll keep looking for a possible answer in linux forums, but I hope you have another suggestion.

Thanks,

Soros

I've been looking for an answer without any succes, but i've collect some ideas. In this forums, there is another post about a failure of connection:Other post.

The situation is different because I've no proxy (I think). What I do have is a router. May the router be interfering? Is there any second way to conect the server in a similar way that in the post I mentioned?

On the other hand, I've tried to use the windows ufo2000 version from linux, using Wine. I've some graphical problems but I can connect the server and beging a game without any further problem!! If it's a problem with ports, why the windows versión works under linux and the linux version doesn't? :shrug:

Thanks

Soros

Well, I solved the problem B) . Actually, I just did exacly what Serge explains in this post for proxy servers, but aplied to my router. As a future reference, the page to check free proxi list is this:

Proxi list

Thanks a lot,

Soros

#4 Serge

Serge

    Project Leader: UFO 2000

  • Xenocide Programming Department
  • 785 posts

Posted 14 October 2005 - 10:40 PM

I've just read the issue and that is not my problem. The ufo 2000 doesn't finish abruptly when I try to connect but a "failed to connect uffo2000 server" appears and it returns to the login screen. Of course, I've check that the server name is correct and the login name and password are correct too.

Having obtained a bit more experience since the last precompiled static binary was build, looks like the problem is because of glibc is compiled into program (with all the networking code). And this networking code seems to be very fragile. It could just crash, but in your case seems like just DNS lookup is not working (as the proxies you used are all accessed using IP address). Try to use '217.23.156.2' instead of 'lxnt.info' to avoid DNS lookup stage.

We need to find a way to compile everything but glibc statically for the next binary build. This can be quite tricky.

And yes, I'm using the precompiled version. I've tried to use the source versión, but apparently the program doesn't find the requiered libraries (although they have been installed without problems using apt, except for hawknl which I had to install using "make").

I suppose you are using debian linux. It would be interesting to see what is wrong with the required libraries and resolve this compilation issue. We already had a bug report in the old bugtracker about installing lua in debian for use with ufo2000. Now this is resolved by having lua code included into ufo2000 sources (no external lua dependency now). Also please try to compile the game in minimal configuration 'make no_dumbogg=1 no_ttf=1' to see if it helps.
ufo2000 development team
http://ufo2000.sourceforge.net

#5 Soros

Soros

    Squaddie

  • Forum Members
  • PipPip
  • 9 posts

Posted 15 October 2005 - 06:32 PM

Try to use '217.23.156.2' instead of 'lxnt.info' to avoid DNS lookup stage.


I've just do it and it works!!! Of course I disabled first the http_proxi option in ufo2000.ini to check that the problem really is that the DNS lookup is not woking.

I would try compiling the game in minimal configuration as soon as posible.

See you

Soros

#6 Kratos

Kratos

    UFO2000 Staff

  • Moderators
  • PipPipPipPipPip
  • 4,113 posts

Posted 21 October 2005 - 06:49 PM

And I thought I was the only one with this problem ;) (3 posts meged)

#7 DakeDesu

DakeDesu

    Sergeant

  • Forum Members
  • PipPipPip
  • 20 posts

Posted 26 October 2005 - 07:37 PM

Also should I note that for FreeBSD, you can modify the MacOSX version of the Makefile in I think it is HawkNL. (I am pretty sure it is HawkNL)
--------
I came here to mod.