Jump to content


Photo

Super Fast X-com!


11 replies to this topic

#1 Hailfire22

Hailfire22

    Creative Text Department

  • Xenocide Inactive
  • 550 posts

Posted 20 September 2004 - 10:26 AM

I have the CE edition of X-COM on my computer (P4, XP, all the good stuff....) and it plays at super fast speeds! At the slowest shots zoom faster than the speed of light! How do I fix this?

#2 Admiral Harkov

Admiral Harkov

    Captain

  • Forum Members
  • PipPipPipPip
  • 113 posts

Posted 20 September 2004 - 10:54 AM

Maybe a slow down utility like Moslo?

#3 The Master Maniac

The Master Maniac

    Captain

  • Xenocide Recruit
  • 442 posts

Posted 20 September 2004 - 01:16 PM

What kind of "rig" do you have? I run X-Com 1 on my new Dell XPS, and, in theory, the game should run faster than the speed of light, but it maintains an acceptable speed (with the exception of geoscape time, and even then, I like it better just a tad faster).

You should go with Harkov's idea. Check out one of those CPU "slowers" if all else fails. Or, you can intentionally "overtask" your CPU by enabling something like Winamp or the like to run in the background. That's usually enough. My friend's computer has the same "going wayyy too fast" problem, and that fixes it (though the trade-off is having to listen to her terrible music :rolleyes: ).

Your CPU wouldn't support hyperthreading, by the way, would it?

Edited by The Master Maniac, 20 September 2004 - 01:17 PM.


#4 Hailfire22

Hailfire22

    Creative Text Department

  • Xenocide Inactive
  • 550 posts

Posted 20 September 2004 - 04:24 PM

Your CPU wouldn't support hyperthreading, by the way, would it?

<{POST_SNAPBACK}>


Not sure but I will try to "overload" my computer with stuff to do. Thanks everyone.

#5 Guest_alex the greater_*

Guest_alex the greater_*
  • Guests

Posted 20 September 2004 - 05:19 PM

and pepple say xp is to slow

#6 EtherImp

EtherImp

    Captain

  • Forum Members
  • PipPipPipPip
  • 189 posts

Posted 20 September 2004 - 09:11 PM

Download the xcom1fix.exe from the main page. (www.xcomufo.com)
Overwhelmed as one would be, placed in my position.
Such a heavy burden now to be the 'one'.
Born to bear and bring to all the details of our ending,
To write it down for all the world to see.

But I forgot my pen!

#7 Guest_alhava_*

Guest_alhava_*
  • Guests

Posted 20 March 2005 - 06:09 PM

I too have the speedy issue. What does Hyperthreading have to do with it?
I have a hyperthreading 2.6 processor. CPU slowers don't seem to work, xcom 1 fix doesn't slow things, though it does start w/o video glitches.

#8 iakin

iakin

    Rookie

  • Forum Members
  • Pip
  • 0 posts

Posted 21 April 2005 - 06:10 AM

I have a p4 2.8 with hyperthreading.

With f0dders patch and d3dwindower the game runs slighty faster than usual (especially at the geoscape) but I like it that way.

With the ET version the game seems to run at normal speed. Have you tried it? Maybe it will help. Though it doesn't want to display fullscreen on my lcd. Well, it DOES enter fullscreen mode but the game window is smaller than the actual resolution (with black borders). I seem to be pretty alone with this issue though.

If that fails I suggest you try the dos version with dosbox, though I suspect the game will run slower than normal then. (it did for me anyway) But after altering the setting a bit I got pretty close to normal gamespeed.

Personally I use d3dwindower, which works fine for me. I only wish someone could translate it to english (hmm i wonder what that $#C5 box does) :)

#9 Guest_Freon_*

Guest_Freon_*
  • Guests

Posted 24 April 2005 - 11:36 AM

I've got a similar problem, but it's pretty weird ;)

I've been playing with the windows version (with the xcom1fix patch) and everything worked fine until today. Now the game is really fast, especially the weapon effect (shots and explosion) and the scrolling. The rest, the geoscape and walking speed, is right.

Has anybody seen that before? :huh?:

#10 j'ordos

j'ordos

    Alien Concept Task Force

  • Xenocide Artwork Department
  • 5,059 posts

Posted 24 April 2005 - 11:52 AM

Perhaps it's just the game settings that have changed for some reason (question mark button in the battlescape, next to the abort mission one, IIRC)?
"You can't trust your eyes if your imagination's out of focus" - Mark Twain
"The mind is like an umbrella, it functions best when open" - Walter Gropius
Posted Image
SNEKK BLOG U-LAR MEKHH! GAHGHH! RK!
GRRGH RGGHH SNORRTT GHACKHGG

Now presented in DoubleVision™ (where drunk)

#11 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 24 April 2005 - 12:00 PM

No the settings are fine.

I've tried using that Turbo utility on the download section. It works but it's not feeling the same, things are a bit... well, slow ;)

Just before this bug happened, the game wouldn't take up all the screen and t here were black bands on the upper and bottom side of the screen, a bit like what iakin is describing. I restarted my machine and it was fixed.

#12 iakin

iakin

    Rookie

  • Forum Members
  • Pip
  • 0 posts

Posted 24 April 2005 - 05:45 PM

Actually Freon now that you mention it the same thing happened to me once. Was using f0dders patch and it worked great until one day BOOM! lightning speed hits the game.

Couldn't find a fix for it I'm afraid. I tried to reinstall ufo but that didn't work.

Now it's one reinstall of windows later (not because of ufo : ) and it works again.



Reply to this topic