Jump to content


Photo

Directx


  • Please log in to reply
1 reply to this topic

#1 Beetle

Beetle

    Programming Department

  • Xenocide Inactive
  • 350 posts

Posted 03 May 2005 - 01:17 PM

Hi

I think that we need some sort of directX version detection on app startup (maybe in xenocide luncher) which gives up some more user friendly dialog on wrong directX version. (something like "Install new version of directX" dialog)

Maybe someone have experience with it. It seams to be very easy :)

Greetings,
Beetle
Posted Image

#2 rincewind

rincewind

    Programming Department

  • Xenocide Programming Department
  • 541 posts

Posted 03 May 2005 - 02:42 PM

Hi

I think that we need some sort of directX version detection on app startup (maybe in xenocide luncher) which gives up some more user friendly dialog on wrong directX version. (something like "Install new version of directX" dialog)

Maybe someone have experience with it. It seams to be very easy :)

Greetings,
Beetle

<{POST_SNAPBACK}>

Just catch the appropriate exception in xenomodule.cpp and show a nice error dialog. All that is currently caught are Ogre Exceptions I think.

Btw: Nice recruit job I think. Anyone who wants do to something for our users?

Greetings,

Rincewind
Posted Image

I love boost!!! The next best thing since the invention of C++.