Jump to content


Photo

Widescreen Monitors And Ufo


5 replies to this topic

#1 noonesshowmonkey

noonesshowmonkey

    Squaddie

  • Forum Members
  • PipPip
  • 4 posts

Posted 12 September 2007 - 02:43 PM

I just got a new 20 inch widescreen LCD monitor and am in love with the thing... However, I also just decided to play X-Com through again for the millionth time. Before I got the monitor, the game ran fine with a fixed .exe or via dosbox. Now the display is all screwed up and I can't seem to fix it.

I do not believe I am running the Collectors Edition.

The right side of the screen gets cut off by maybe 10 or 15%. This results in the Geoscape buttons being cut off slightly, base control buttons also being cut off (some completely) and Battlescape functions being unreachable. Also, the screen blinks incessantly.

I downloaded the latest ET version and screwed around with the various visual settings - no joy. None of the supported resolutions or functions solve the problem.

So how do you get X-COM to run on a widescreen monitor? Do you?

- der menkey

"Certainly there is no hunting like the hunting of man and those who have hunted armed men long enough and liked it, never really care for anything else thereafter."
~ Ernest Hemingway

#2 Zombie

Zombie

    Colonel

  • Xenocide Creative-Text Departmen
  • 2,947 posts

Posted 12 September 2007 - 02:51 PM

Try lowering the refresh rate of your monitor to something like 60hz. That might stop the blinking. As for the width, don't know. :fingerscrossed:

- Zombie

Edited by Zombie, 12 September 2007 - 02:54 PM.

The Mr. Grognard of X-COM

Zombie: Empirical data's your only man, when formulating a research plan.
A soldier's death is never in vain if it makes the formula more plain.
A few dozen make a better case for refining that third decimal place.
They call me Zombie because I don't sleep, as I slowly struggle to climb this heap,
of corpses, data points, and trials, but from the top - I'll see for miles!


#3 noonesshowmonkey

noonesshowmonkey

    Squaddie

  • Forum Members
  • PipPip
  • 4 posts

Posted 12 September 2007 - 03:30 PM

I set the refresh rate of my monitor to 60 hz and have changed the resolution of the windows runtime envorinmnet all the way down to 300x200.

No joy... Everything keeps getting stretched to fit the screen and thus cut off on the far right.

- der menkey

"Certainly there is no hunting like the hunting of man and those who have hunted armed men long enough and liked it, never really care for anything else thereafter."
~ Ernest Hemingway

#4 Darkhomb

Darkhomb

    Captain

  • Xenocide Artwork Department
  • 628 posts

Posted 12 September 2007 - 03:32 PM

He is right about the monitor, LCD's need to be at 59 or 60, some can be diffrent but 90% need to be at 60.

Check your monitor display properties, they can stretch, change aspect ratio etc. You don't really want it stretched, it will look weird, put it at aspect if it has that (keeps ration 4:3) so you should have black bars on the left and right screen. then if it is not centered use your monitor adjust to center it as well.

#5 noonesshowmonkey

noonesshowmonkey

    Squaddie

  • Forum Members
  • PipPip
  • 4 posts

Posted 13 September 2007 - 09:46 PM

My monitor does not have any control tabs that allow me to force an aspect ratio. As far as I can tell my monitor is currently being identified as a CRT by the nVidia drivers that my system has on it (the latest available, downloaded them yesterday).

From what I understand part of the problem is that the monitor, when used with an analog cable or digital-analog converter, does not have full functionality and is ID'ed as a CRT style monitor that has display resolutions including widescreen resolution.

So I think I will be getting a digital video cable and checking to see if 1) windows recognizes the monitor differently then 2) the drivers for the monitor become more receptive to making changes and 3) if the nVidia control panel suddenly has options available on it for LCD screens.

We shall see.

- der menkey

"Certainly there is no hunting like the hunting of man and those who have hunted armed men long enough and liked it, never really care for anything else thereafter."
~ Ernest Hemingway

#6 Darkhomb

Darkhomb

    Captain

  • Xenocide Artwork Department
  • 628 posts

Posted 13 September 2007 - 09:57 PM

since you brought up nvidia control panel, look for the scaling option and turn it off. this does the stretching so the monitor doesnt have to, should not be a default option but it is.. that could fix your aspect ratio problem as well



Reply to this topic