Jump to content


Photo

Blank Screen on Windows 7


10 replies to this topic

#1 MaskedJackal

MaskedJackal

    Squaddie

  • Forum Members
  • PipPip
  • 2 posts

Posted 25 December 2009 - 06:10 PM

I'm running the CE, and tried the compatibility options, the patch in the sticky for Vista, and changing the refresh settings. I also have an LCD, which is something that the thread said might cause problems. Is there a solution I just missed here?

#2 EtherImp

EtherImp

    Captain

  • Forum Members
  • PipPipPipPip
  • 189 posts

Posted 25 December 2009 - 08:19 PM

I'm running the CE, and tried the compatibility options, the patch in the sticky for Vista, and changing the refresh settings. I also have an LCD, which is something that the thread said might cause problems. Is there a solution I just missed here?


Run in windowed mode via Sebs Loader, D3DWindower, or DxWind.
Overwhelmed as one would be, placed in my position.
Such a heavy burden now to be the 'one'.
Born to bear and bring to all the details of our ending,
To write it down for all the world to see.

But I forgot my pen!

#3 MaskedJackal

MaskedJackal

    Squaddie

  • Forum Members
  • PipPip
  • 2 posts

Posted 25 December 2009 - 09:54 PM

Hmm, now I can get in, but first attempt to move on tactical causes a crash.

#4 EtherImp

EtherImp

    Captain

  • Forum Members
  • PipPipPipPip
  • 189 posts

Posted 27 December 2009 - 02:56 PM

Hmm, now I can get in, but first attempt to move on tactical causes a crash.


Sorry. Can't help you there.
Overwhelmed as one would be, placed in my position.
Such a heavy burden now to be the 'one'.
Born to bear and bring to all the details of our ending,
To write it down for all the world to see.

But I forgot my pen!

#5 BladeFireLight

BladeFireLight

    Captain

  • Moderators
  • PipPipPipPip
  • 809 posts

Posted 09 January 2010 - 12:22 AM

The issue DirectX acceleration. You cant disable it in Vista or 7 unless you change your video card drive to "generic VGA". Your other options would be to use the Vista Patch over at Strategy Core's files section. it works for Windows 7 to and doesn't modify the game. I have Windows 7 x64 with a flat screen and CE runs like a dream. (although I did have mess with the scaling feature so keep aspect ratio in my drivers. or all my men looked like they cant walk away from the doughnut shop.) If NKF got the updated version of it posted for me it also supports the split EXE of XcomUtil but installing 9.6 on Win 7 is like pulling teeth.
-------------------------------------------------------------------
Combat is very simple, there is a first place and second place, second place is laying face down in the mud, sometimes, so is first place.

#6 Guest_Cycle3d60_*

Guest_Cycle3d60_*
  • Guests

Posted 21 January 2010 - 07:39 PM

have a 64 vista and I downloaded the vista patch that's on Strategy Core and now when I try to run the game I get the error message "Couldn't CreateProcess". What can I do to fix this?

#7 BladeFireLight

BladeFireLight

    Captain

  • Moderators
  • PipPipPipPip
  • 809 posts

Posted 23 January 2010 - 12:26 AM

have a 64 vista and I downloaded the vista patch that's on Strategy Core and now when I try to run the game I get the error message "Couldn't CreateProcess". What can I do to fix this?


That sounds like an issue with f0dders loader. Try running X-com with out it. The Vista patch by itself doesn't create use any loader's.

also I dont know if that patch is the more current. You can get an updated one from my site: www.bladefirelight.com

-Blade FireLight.
-------------------------------------------------------------------
Combat is very simple, there is a first place and second place, second place is laying face down in the mud, sometimes, so is first place.

#8 Guest_Cycle3d60_*

Guest_Cycle3d60_*
  • Guests

Posted 26 January 2010 - 06:12 PM

That sounds like an issue with f0dders loader. Try running X-com with out it. The Vista patch by itself doesn't create use any loader's.

also I dont know if that patch is the more current. You can get an updated one from my site: www.bladefirelight.com

-Blade FireLight.


Ok, I downloaded XcomUtil 9.7 and ran it, installed the vista patch when the setup told me to and everything. I then ran the RunXcom batch file and i still had the same problem of hearing the music, but no red MICROPROSE, no opening video, and no game. What am I missing? What did I do wrong?

Unless.... I've heard the term "collector's edition" being used a lot. Is that the same as gold edition? Because that's what I have. Could that be what's wrong?

#9 Vimm

Vimm

    Rookie

  • New Forum Members
  • Pip
  • 0 posts

Posted 26 January 2010 - 09:37 PM

I also had the blank screen problem and running the 6.7 release from bladefirelight.com fixed it. I still have an odd graphics problem though. The mouse cursor and geoscape menu colors are off as well as some tactical colors, and the tactical mouse is so fast it's useless. I've taken screen shots which strangely show only the screwy colors and nothing else. I've seen other people report similar problems but never seem to resolve it. Anyone have any ideas?

I'm running UFO Defense CE on Windows 7 x64.

screen.png screen2.png

#10 Zombie

Zombie

    Colonel

  • Xenocide Creative-Text Departmen
  • 2,947 posts

Posted 26 January 2010 - 11:50 PM

Turn off all running apps in your system tray and close all open programs. Some have a tendency to mess with the palette when X-COM is running. :)

- Zombie
The Mr. Grognard of X-COM

Zombie: Empirical data's your only man, when formulating a research plan.
A soldier's death is never in vain if it makes the formula more plain.
A few dozen make a better case for refining that third decimal place.
They call me Zombie because I don't sleep, as I slowly struggle to climb this heap,
of corpses, data points, and trials, but from the top - I'll see for miles!


#11 BladeFireLight

BladeFireLight

    Captain

  • Moderators
  • PipPipPipPip
  • 809 posts

Posted 27 January 2010 - 12:13 PM

Turn off all running apps in your system tray and close all open programs. Some have a tendency to mess with the palette when X-COM is running. :)

- Zombie


some times that is not enough for me. I have to reboot and start the game fresh with nothing else. Any toggle to desktop and back usually causes the messed up graphics issue to. (Assuming the game doesn't crash outright)
-------------------------------------------------------------------
Combat is very simple, there is a first place and second place, second place is laying face down in the mud, sometimes, so is first place.



Reply to this topic