Jump to content


Photo

Starting a new game from scratch, what do I need to know?


  • Please log in to reply
4 replies to this topic

#1 Artemis

Artemis

    Squaddie

  • Forum Members
  • PipPip
  • 3 posts

Posted 01 December 2009 - 07:29 AM

Hi guys!, Im new here and I want to play again this amazing game after so many years...

I started a game last week, but I didnt get a Live Deep One.. so, no Ion Armor and the colonies... like 500 reloads every time I got 1 soldier kill :P

So, I know that there is a patch (2.1 from Microprose) and I know there are some tools to make the gameplay a little "better" (no talking about cheats of course).

So, what do I need to do before starting to play this amazing game?, how do I install the patch and how that XCOMUTIL tool works?

Im running the CE version of TFTD on Windows XP.

Thx!!

Edit.: forgot to mention, Im running the game windowed using D3DWindower, works great.

Edit 2: Ok, I installed the latest patch from Microprose, 2.1 version, and after some research seems like I needed to copy the content of TFTDHD to my game folder, that added some files like: "TACTICAL.EXE" that allowed me to run xcomutil.

So, I ran xcomutil and selected some useful options, anw the options with "N" as default I kept like that.

So, let me know if Im doint fine.

Thx.

BIG PROBLEM...

Seems like xcomutil isnt working... I can run Xcusetup.bat and configure my xcomutil, but when I run runXcomW.bat this is the output:

"ufoexe\black" no se reconoce como un comando interno o externo,
programa o archivo por lotes ejecutable.
"intro.exe" no se reconoce como un comando interno o externo,
programa o archivo por lotes ejecutable.
"ufoexe\black" no se reconoce como un comando interno o externo,
programa o archivo por lotes ejecutable.
Stub exec failed:
dos4gw.exe
No such file or directory
C:\ARCHIV~1\X-COM>

So... what can I do? that folder "ufoexe\black" isnt there...

Anyone..? :( I googled it but no luck... cant run

Last edit: I managed to delete those black\ references.. so that errors now are gone, the problem is, that still showing up the dos4gw error...

Edited by Artemis, 01 December 2009 - 12:44 PM.


#2 NKF

NKF

    Commander

  • [Global Moderators]
  • PipPipPipPipPipPip
  • 4,798 posts

Posted 01 December 2009 - 12:44 PM

Two quick things, the 2.1 is only for the dos version of the game so it won't have much effect. CE is already 2.0 though. The only difference between 2.0 and 2.1 is how it handles the MC Reader research. With 2.0 you need to have a MC Reader in storage when you complete research on the M. C.-Lab. Generally this shouldn't be a problem as long as you don't sell all the readers.

The messages you're getting show that it can't find the executable files. But those are executables used by the dos version. Check that you aren't running runxcom.bat as opposed to runxcomw.bat.

- NKF
Lord High Generalissimo Ruler Supreme of Norm's Anti Pedant Society (NAPS).

Number of members: 1

#3 Artemis

Artemis

    Squaddie

  • Forum Members
  • PipPip
  • 3 posts

Posted 01 December 2009 - 12:50 PM

Two quick things, the 2.1 is only for the dos version of the game so it won't have much effect. CE is already 2.0 though. The only difference between 2.0 and 2.1 is how it handles the MC Reader research. With 2.0 you need to have a MC Reader in storage when you complete research on the M. C.-Lab. Generally this shouldn't be a problem as long as you don't sell all the readers.

The messages you're getting show that it can't find the executable files. But those are executables used by the dos version. Check that you aren't running runxcom.bat as opposed to runxcomw.bat.

- NKF


First of all, thx for the answer NKF.

I ran the windows version named: RunXcomW.bat downloaded from here http://xcomutil.scotttjones.com/ the version is 9.60, and the errors are still present.

Dont know what am I doing wrong...

Edit: Seems like the RunXcomW.bat is screwed up... did anyone use it without problems?

Edit2: Cant find the CE 2.0 patch for this game... I googled about 1 hour.. any link? :P

Edit3: About edit 2.. reading UFOPEDIA seems like CE version of TFTD already have 2.0 patch in it, so, nvm...

Edit4: Ok... im giving up, I wont use xcomutil and Ill play x-com with more careful... to avoid some bug or so.

Edited by Artemis, 01 December 2009 - 04:22 PM.


#4 NKF

NKF

    Commander

  • [Global Moderators]
  • PipPipPipPipPipPip
  • 4,798 posts

Posted 01 December 2009 - 11:17 PM

Well, I did say the CE version was already v2.0. ;)

So you have unzipped XComutil into your game folder and ran xcusetup. Technically that should have prepared the game to run fine with runxcomw.bat.

Did you follow the step in the instructions that tells you to make a desktop icon that points to runxcomw.bat? If you did, check that the 'start in' field is also pointing to the game folder. Alternately, try running runxcomw.bat directly from its folder.

- NKF
Lord High Generalissimo Ruler Supreme of Norm's Anti Pedant Society (NAPS).

Number of members: 1

#5 Artemis

Artemis

    Squaddie

  • Forum Members
  • PipPip
  • 3 posts

Posted 02 December 2009 - 08:52 AM

Well, I did say the CE version was already v2.0. ;)

So you have unzipped XComutil into your game folder and ran xcusetup. Technically that should have prepared the game to run fine with runxcomw.bat.

Did you follow the step in the instructions that tells you to make a desktop icon that points to runxcomw.bat? If you did, check that the 'start in' field is also pointing to the game folder. Alternately, try running runxcomw.bat directly from its folder.

- NKF


Yeah.. now it works, the problem was that for some reason RunXcomW.bat look for those DOS folders, and I installed a DOS patch... so.

But, like I said, Im giving up, cuz I have 2 problems:

1- I want to run D3DWindower and Xcomutil, and is a kind of messy to make it work...
2- Running the game with RunXcomW.bat make it cras really often..

So, Im ok with this "not so great" version of Xcom, I already have most of the "hard to research" weapons and armors, so, it's ok.