Jump to content


Photo

Assert Failed Line 36 Of Mingw-libs...


  • Please log in to reply
7 replies to this topic

#1 brainac

brainac

    Squaddie

  • Forum Members
  • PipPip
  • 5 posts

Posted 04 January 2007 - 03:03 PM

i boot win 98 on 350mhz 64mb ram machine

i did not find answers to this anywhere on the forum
i get black screen after launching the newest beta, unless in window mode, i would have to restart, but in window mode another pop up shows up :
___
UFO2000 error!
Assert failed line 36 of mingw-libs/include/allegro/inline/rle.inl
____
i press ok and get another window :
______

Microsoft Visual C++ Runtime Library

Run time Error!

program : D:/program files/ ufo 2000/ufo2000.exe

abnormal program termination
____
then the exe closes

#2 Serge

Serge

    Project Leader: UFO 2000

  • Xenocide Programming Department
  • 785 posts

Posted 04 January 2007 - 03:10 PM

You don't have much memory on this machine, probably the game can run out of it. Just to be sure, did you try launching it in minimal configuration without installing any data files from x-com?
ufo2000 development team
http://ufo2000.sourceforge.net

#3 brainac

brainac

    Squaddie

  • Forum Members
  • PipPip
  • 5 posts

Posted 04 January 2007 - 03:14 PM

You don't have much memory on this machine, probably the game can run out of it. Just to be sure, did you try launching it in minimal configuration without installing any data files from x-com?



i did, it does the same. I didnt found the minimal requirements stated anywhere.

in what other changes to .ini file, can i get the game more minimalistic?

#4 Jezulkim

Jezulkim

    Captain

  • Forum Members
  • PipPipPipPip
  • 194 posts

Posted 07 January 2007 - 04:43 AM

You don't have much memory on this machine...

Just a note: I could run the game on a machine with win98 + 333mhz p2 + 64 ram + sucky graphics card = the game ran great.

EDIT:

in what other changes to .ini file, can i get the game more minimalistic?

In case you haven't tried these:
resolution: use the lowest
screen_x_res = 640
screen_y_res = 480
colours: 16 bit, I think it's the lowest
color_depth = 16
musics: comment out all lines
-> #menu_music = $(ufo2000)/newmusic/xcom.mid

And one more thing, how clean is your ufo2000 install? Have you installed any mods?

EDIT2: Ok, I did a fresh install of ufo2000 on my old windows 98 computer. Xcom and Tftd NOT included. I started the game and it ran nice and smooth.

Edited by Jezulkim, 07 January 2007 - 09:27 AM.

That's my team in my avatar!

#5 Kratos

Kratos

    UFO2000 Staff

  • Moderators
  • PipPipPipPipPip
  • 4,113 posts

Posted 07 January 2007 - 04:27 PM

i had a 400mhz machine with 128mb ram, and it sucked with ufo2k!

#6 Sporb

Sporb

    UFO2000 Staff

  • Moderators
  • PipPipPipPip
  • 739 posts

Posted 07 January 2007 - 04:34 PM

depends on the chips i guess. The older Celerons were horrendous

#7 brainac

brainac

    Squaddie

  • Forum Members
  • PipPip
  • 5 posts

Posted 08 January 2007 - 08:42 PM

thanks to all , it works now !!!
i even installed tftd and ufo. FPS is 5-10 which is bad but playable

I only get these errors now when i go fullscreen, (i have lcd screen)

any ideas?

what are the MOST MINIMUM settings? is 320-240 possible? (or whatever the orgiginal was)

thanks

#8 Jezulkim

Jezulkim

    Captain

  • Forum Members
  • PipPipPipPip
  • 194 posts

Posted 09 January 2007 - 02:46 PM

Enabling the enlarged battlefield can take your fps higer, but you'll have bigger tiles. Many people don't like that. oh well I do.

You can enable it in game
: options > enlarged battlefield
Or directly editing the ini
: F_SCALE2X = 1
That's my team in my avatar!