Jump to content


Photo

Xcomutil Terrain Error


  • Please log in to reply
5 replies to this topic

#1 Jon Matthews

Jon Matthews

    Rookie

  • Forum Members
  • Pip
  • 0 posts

Posted 04 March 2007 - 07:00 PM

Running Xcomutil 9.6 with the DOS version of UFO, patched to 1.4. Deleted XCOM from the HD, then reinstalled, patched, then unzipped 9.6. Ran XCUSETUP and selected options to please. Since it might have a bearing, I answered NO to

"Do you want to use the new Farm and Desert Terrains?" (I'd like to, but my 486 doesn't have Java).
"Do you want combat terrain to be randomized?'
"Do you want to be prompted before every ship attack?"

Now my problem. When asked "Do you want the world map terrain to be randomized?", I answer Yes. I then get the error message "Read failure on MISSDAT\SAVEINFO.DAT." Util continues and when I start XCOM, the options I chose are working but the terrain doesn't seem to be randomized (at least the globe looks the same in the GEOSCAPE as it usually does).

Any ideas what the problem is? Do I need Java and/or the Windows CE version to have the randomized world terrain working? The "Do you want to be prompted before every ship attack?" option works (and very well, I might add).

#2 Hobbes

Hobbes

    UFO2000 Staff

  • Moderators
  • PipPipPipPip
  • 719 posts

Posted 05 March 2007 - 12:51 PM

A couple of things:

1) "Deleted XCOM from the HD, then reinstalled, patched, then unzipped 9.6." - what patch did you applied? Most likely it doesn't have anything to do with your problem but since you mentioned you are running 1.4 in a 486 machine it might not be necessary to patch anything (unless you are using XP)

2) "Do you want combat terrain to be randomized?'
"Do you want to be prompted before every ship attack?"

These 2 options don't require Java and you can use them.

3) Finally, the MISSDAT folder should be empty when you install X-COM, since it contains data from your previous tactical mission. Try running a tactical battle first, exit it and run XcuSetup again to see if you still get the error message.

#3 Jon Matthews

Jon Matthews

    Rookie

  • Forum Members
  • Pip
  • 0 posts

Posted 05 March 2007 - 09:11 PM

"what patch did you applied?" The patch I applied was to XCOM, the update 1.4 provided by Microprose (applied to the original US version [DOS] of X-COM:UFO Defense).

My 486 is still running DOS.

The MISSDAT folder was empty after initial install. I have since completed a couple of tactical msns and the folder now has about 40 files, including a SAVEINFO.DAT file with a file size of zero.

However...I still get the "Read failure on MISSDAT\SAVEINFO.DAT" message. The other aspects of util seem to be working exactly as advertised.

#4 Hobbes

Hobbes

    UFO2000 Staff

  • Moderators
  • PipPipPipPip
  • 719 posts

Posted 06 March 2007 - 10:35 AM

Ok, i've run Xcusetup and i'm getting the same error message on that prompt. This is a program bug.

#5 Pi Masta

Pi Masta

    Sergeant

  • Xenocide Recruit
  • 68 posts

Posted 07 March 2007 - 02:56 PM

Try saving while in combat? Maybe that will fill up the SAVEINFO.DAT, or you could try to copy one from a GAME_* folder into MISSDAT.

(Just a quick guess, no idea if it will help or not, either way it still sounds like a bug with XCUtil)

#6 BladeFireLight

BladeFireLight

    Captain

  • Moderators
  • PipPipPipPip
  • 809 posts

Posted 20 May 2007 - 03:16 PM

I still get the "Read failure on MISSDAT\SAVEINFO.DAT" message. The other aspects of util seem to be working exactly as advertised.


This is a bug. the RandomWorld() function is in the realtime component (xcomutrt) that runs a check on the missdat before it will do anything else. if you start a game and enter the first combat then exit, the random world option will work.

I will fix this in a later realease. (first i need to find out from steve if it's dependent on anything else.)

-Blade FireLight
-------------------------------------------------------------------
Combat is very simple, there is a first place and second place, second place is laying face down in the mud, sometimes, so is first place.