Jump to content


Photo

Cannot Get "xcomutil Eqp Wrt" To Work


  • Please log in to reply
3 replies to this topic

#1 keybounce

keybounce

    Sergeant

  • Forum Members
  • PipPipPip
  • 12 posts

Posted 22 August 2007 - 12:18 AM

So I'm trying to make an equipment list. I run xcomutil game_7 eql, and get an equipment list. I edit it, make sure it's what I want, and then try to update my battle.

It's turn one of the battle.

My command line is:
xcomutil game_7 eqp wrt

The output:
Identification of the battle
Correctly identifies the difficulty level
Correctly identifies the base of origin.
Tells me that 80 objects are sent back to that base

Recommended limit on available objects: 137
Using / instead of invalid equiment type /s21r1/wm
Equipment type / found

And that's it.

No file in the game directory was changed. The game has the same set of equipment it had before I ran xcomutil.

I don't know why it says that /s21r1/wm is invalid -- that was generated from the EQL flag. (All I did was assign new equipment; the source battle had enough equipment and locations used so I could understand how to write the assignments I wanted.)

#2 keybounce

keybounce

    Sergeant

  • Forum Members
  • PipPipPip
  • 12 posts

Posted 22 August 2007 - 12:13 PM

OK, I have some more information. I explicitly added an equipment for "/", and things changed.

I got 4 of these error messages, for these names:

t57r47/s21r1/wm
t59r42/s21cr1/cw
t60r52/s30c2/Sct
t65r57/s41r2/Sct

These are the longest names -- all shorter names equip just fine.

According to the docs, I should be ok with 19 characters after the slash. Yet it looks like 7 is the real limit.

Equally odd, the docs say that if you have name/x/y, then the /x/ in the middle is the equipment name part, but I seem to need to use the entire tail, with both the manual part and the automatic part.

Finally, if I do use WRT with this, then all the names are truncated at the first slash -- all the equipment types are removed from the names of the

I have xcomutil 9.60

#3 keybounce

keybounce

    Sergeant

  • Forum Members
  • PipPipPip
  • 12 posts

Posted 22 August 2007 - 03:29 PM

So it's not length. I've played with a variety of names. Some work, some don't, and I can't figure out any pattern of what does or does not.

Has anyone used this successfully? If it matters, this is running inside Qemu with FreeDos, on a Macintosh 10.4.9

#4 keybounce

keybounce

    Sergeant

  • Forum Members
  • PipPipPip
  • 12 posts

Posted 10 September 2007 - 11:24 AM

For what it's worth, it's working now. I have no idea why it failed before, and works now.