Jump to content


Photo

Xcomutil 9.6 Bugs


  • Please log in to reply
8 replies to this topic

#1 T-1000

T-1000

    Squaddie

  • Forum Members
  • PipPip
  • 2 posts

Posted 28 August 2007 - 11:35 PM

I encountered two bugs when using XCOMUTIL 9.6. I am using the DOS version of Xcom with Dosbox.

The first is that the Terrain randomization does not work at all. The file mprandom.xcf is there, but it just doesn't work. I know this function works in Xcomutil 9.2, so it's not a problem with DosBox.

The second is that the placement of troops when entering the alien base in Xcom 1 is wrong. My troop end up in another room other than the Green one with the lift. Sometimes they are stuck in walls and such. I knew this feature worked before in Xcomutil 8. X.

Does anybody else encounter, or have the solution to these problems?

#2 T-1000

T-1000

    Squaddie

  • Forum Members
  • PipPip
  • 2 posts

Posted 29 September 2007 - 07:27 PM

I am still looking for an answer to the why the Map randomization feature does not work with xcomutil 9.6. Did anybody managed to get this feature to work with xcomutil 9.6 with Dosbox?

#3 BladeFireLight

BladeFireLight

    Captain

  • Moderators
  • PipPipPipPip
  • 809 posts

Posted 16 December 2007 - 07:46 PM

Can you post or email me the randomization file you were using and I can figure out what is causing the brake age.

-Blade FireLight
-------------------------------------------------------------------
Combat is very simple, there is a first place and second place, second place is laying face down in the mud, sometimes, so is first place.

#4 T-1000

T-1000

    Squaddie

  • Forum Members
  • PipPip
  • 2 posts

Posted 29 December 2007 - 12:53 AM

Can you post or email me the randomization file you were using and I can figure out what is causing the brake age.

-Blade FireLight


I was using the regular Terrain randomization feature that is used with mprandom.xcf.

But I know it has something to do with rndplace.xcf, when I deleted this file, the Terrain randomization worked again, but it breaks Interceptor and firestorm troop placement.

#5 BladeFireLight

BladeFireLight

    Captain

  • Moderators
  • PipPipPipPip
  • 809 posts

Posted 29 December 2007 - 02:54 PM

Did you run xcusetup the first time from inside dosbox? if so it failed in a number of file copies, but did copy the files It uses to test success off of.

The only solutions would be to delete all the backup files and run xcusetup from windows. This will probably fix a number of bugs.

I'm working on a bugfix release right now. and dosbox has some limitations that are messing things up.

-Blade
-------------------------------------------------------------------
Combat is very simple, there is a first place and second place, second place is laying face down in the mud, sometimes, so is first place.

#6 T-1000

T-1000

    Squaddie

  • Forum Members
  • PipPip
  • 2 posts

Posted 29 December 2007 - 07:45 PM

Did you run xcusetup the first time from inside dosbox? if so it failed in a number of file copies, but did copy the files It uses to test success off of.

The only solutions would be to delete all the backup files and run xcusetup from windows. This will probably fix a number of bugs.

I'm working on a bugfix release right now. and dosbox has some limitations that are messing things up.

-Blade


I am aware that dosbox messes some stuff up, so I didn't run it from Dosbox. It seems that when rndplace.xcf and mprandom.xcf are both present, the feature refuses to work.

This problem is not present in xcomutil 9.5

#7 BladeFireLight

BladeFireLight

    Captain

  • Moderators
  • PipPipPipPip
  • 809 posts

Posted 30 December 2007 - 12:02 PM

Given the number of complains of 9.6 bugs i'm getting. I have asked scott for a copy of the 9.5 source and will be checking what changed and seeing what I can fix.
-------------------------------------------------------------------
Combat is very simple, there is a first place and second place, second place is laying face down in the mud, sometimes, so is first place.

#8 T-1000

T-1000

    Squaddie

  • Forum Members
  • PipPip
  • 2 posts

Posted 31 December 2007 - 02:41 PM

Given the number of complains of 9.6 bugs i'm getting. I have asked scott for a copy of the 9.5 source and will be checking what changed and seeing what I can fix.


This problem is also not present when running 9.6 with TFTD. So it probably has something to do with the new java desert/farm terrain.

#9 BladeFireLight

BladeFireLight

    Captain

  • Moderators
  • PipPipPipPip
  • 809 posts

Posted 01 January 2008 - 12:25 PM

I think that is an issue with the java detection. I remember when it was first added Dosbox returned a positive on the java detection. well obviously that is a false positive.

-Blade FireLight
-------------------------------------------------------------------
Combat is very simple, there is a first place and second place, second place is laying face down in the mud, sometimes, so is first place.