Jump to content


Photo

Game Security


  • Please log in to reply
3 replies to this topic

#1 brian-o

brian-o

    Sergeant

  • Forum Members
  • PipPipPip
  • 38 posts

Posted 27 July 2006 - 11:07 PM

I was looking for ufo2000 and I came accross this thing talking about vulnerabilities in ufo200

http://www.security....u/Gnews388.html

is this stuff being dealt with?

#2 Kratos

Kratos

    UFO2000 Staff

  • Moderators
  • PipPipPipPipPip
  • 4,113 posts

Posted 27 July 2006 - 11:18 PM

I am not sure, hopefully serge can take a peek at this sometime. With the difficulty level being 5/10, I'm not too worried. :) The only type of thing that is immune to vulnerabilities is inexistent matter.

Thanks for the heads up though.
Posted Image

#3 Serge

Serge

    Project Leader: UFO 2000

  • Xenocide Programming Department
  • 785 posts

Posted 28 July 2006 - 12:15 AM

I am not sure, hopefully serge can take a peek at this sometime. With the difficulty level being 5/10, I'm not too worried. :) The only type of thing that is immune to vulnerabilities is inexistent matter.

Thanks for the heads up though.

All of these problems have been fixed in 0.7.1062 build. As this problem got disclosed to public, also added a check on the server which prevents older vulnerable clients from logging in.
ufo2000 development team
http://ufo2000.sourceforge.net

#4 Kratos

Kratos

    UFO2000 Staff

  • Moderators
  • PipPipPipPipPip
  • 4,113 posts

Posted 28 July 2006 - 12:25 AM

Good to hear. Then I guess this topic will be abandoned until another issue appears. =b
Posted Image