Jump to content


Photo

Xcom Ce On Vista 32bit


76 replies to this topic

#1 BladeFireLight

BladeFireLight

    Captain

  • Moderators
  • PipPipPipPip
  • 809 posts

Posted 05 May 2007 - 04:25 PM

All I get is a black screen and accelerated intro music.

Has Any one goten Xcom CE working on Vista?

-Blade FireLight
-------------------------------------------------------------------
Combat is very simple, there is a first place and second place, second place is laying face down in the mud, sometimes, so is first place.

#2 Dr4go

Dr4go

    Rookie

  • New Forum Members
  • Pip
  • 0 posts

Posted 19 May 2007 - 04:53 AM

First: Hi @ all (it's my first post)!

I read somewhere (ah, found it again: http://www.pro-netwo...4ee483b045e00a7), that a member of another forum has gotten the game to work by changing the driver to the default "Standard VGA graphics adapter"... good luck ;o)

report back if it worked...

#3 Darkhomb

Darkhomb

    Captain

  • Xenocide Artwork Department
  • 628 posts

Posted 20 May 2007 - 01:34 PM

do a search I already posted how to get xcom apoc working with vista 64 any other game should work with it too

http://www.xcomufo.c...topic=242027667

Edited by Darkhomb, 20 May 2007 - 01:34 PM.


#4 Dr4go

Dr4go

    Rookie

  • New Forum Members
  • Pip
  • 0 posts

Posted 20 May 2007 - 03:23 PM

do a search I already posted how to get xcom apoc working with vista 64 any other game should work with it too

http://www.xcomufo.c...topic=242027667

No, I'm sorry to disappoint you, but it's IMPOSSIBLE to run the CE (Collector's Edition, aka Windows version) in dosbox. ;) Maybe my driver hint finding will help him, but dosbox, for sure, won't help (because it's running with DirectDraw).
Hey... maybe another idea would be to install the directx version X-COM uses... ;)

But thanks for the thread (your solution), it will come in handy for me... :)

#5 Darkhomb

Darkhomb

    Captain

  • Xenocide Artwork Department
  • 628 posts

Posted 21 May 2007 - 05:52 AM

I would go for the dos version then,

if your going to try CE then you can not have vista 64 there will be no way for this to work. For vista 32 Turn off most features in compat menu and set it to windows 98 and try that

Edited by Darkhomb, 21 May 2007 - 05:58 AM.


#6 SaintD

SaintD

    Captain

  • Xenocide Recruit
  • 195 posts

Posted 16 July 2007 - 07:23 PM

All I get is a black screen and accelerated intro music.

Has Any one goten Xcom CE working on Vista?

-Blade FireLight


I would think the dos version with dosbox is your best bet.

#7 BladeFireLight

BladeFireLight

    Captain

  • Moderators
  • PipPipPipPip
  • 809 posts

Posted 16 December 2007 - 08:16 PM

I would think the dos version with dosbox is your best bet.


That would be the obvious way to _play_ the game.

My issue is, to continue xcomutil support for CE, I need a working copy. The only non Vista computers I have access to is my work macbook and my antique P2 98 box. all my work comps are Vista 64 Ent and my home all all on Vista 32 Ultimate.

The 98 box doesn't suffer from the xcopy /y issue. I cant properly test and fix this using it.

The best I can do is Paralells on the MacBook. but I try to keep my personal things off computers I don't own. So untill I can get an external drive, I'm stuck with only dosbox.

-Blade FireLight
-------------------------------------------------------------------
Combat is very simple, there is a first place and second place, second place is laying face down in the mud, sometimes, so is first place.

#8 BladeFireLight

BladeFireLight

    Captain

  • Moderators
  • PipPipPipPip
  • 809 posts

Posted 04 May 2008 - 09:08 PM

Found a better Fix for runing under vista

I downloaded the Application Compatibility Toolkit 5.0 from M$
I set No emulation on the advanced options I set ForceDirectDrawEmulation This fixed EU but TFTD has scrambled graphics, will keep working on that on.
-------------------------------------------------------------------
Combat is very simple, there is a first place and second place, second place is laying face down in the mud, sometimes, so is first place.

#9 BladeFireLight

BladeFireLight

    Captain

  • Moderators
  • PipPipPipPip
  • 809 posts

Posted 04 May 2008 - 11:05 PM

Found the solution for that. Forced 256 Color. seems to be fine now.

Although it runs way to fast for my likening on a moder machine but at least I can test xcomtuil with the CE version now.

-BladeFireLight
-------------------------------------------------------------------
Combat is very simple, there is a first place and second place, second place is laying face down in the mud, sometimes, so is first place.

#10 Gimli

Gimli

    Sergeant

  • Forum Members
  • PipPipPip
  • 19 posts

Posted 05 May 2008 - 01:03 AM

Yesyes, that's all nice, but you haven't told us exactly HOW you did this. :P I could use a step by step guide in order to try and repeat this on my own PC.

#11 Dr4go

Dr4go

    Rookie

  • New Forum Members
  • Pip
  • 0 posts

Posted 05 May 2008 - 07:09 AM

Wow, after ages a real solution... :) Thanks, will try that, too!

#12 Gimli

Gimli

    Sergeant

  • Forum Members
  • PipPipPip
  • 19 posts

Posted 05 May 2008 - 12:49 PM

Doesn't work so far.

Questions, questions... OK, first of all, could you send me the database you created? If an attachment here on the forum doesn't work, I'll PM you with an e-mail to send it to. This would be the easiest way to find out exactly what settings you used.

Anyway, which OS did you set the compatibility to? Also, I tried adding the 256 colors and the ForceDirectDrawEmulation but it didn't help. I still get the same blank screen with no sound.

#13 BladeFireLight

BladeFireLight

    Captain

  • Moderators
  • PipPipPipPip
  • 809 posts

Posted 11 May 2008 - 03:03 PM

This is the fix with a basic installer.
It only works if the file naming matches that of the X-Com Collectors Edition that I have (Terror From The Deep.exe and UFO Defense.exe)
It also requires Admin rights to install but will not work if you right click and say run as admin. you have to let UAC do it's job (assuming you have not turned it off)

Xcomutil is not the least bit compatible with this patch nor does it play well with vista's file virtualization. So I'm working on that next. It will be included in future versions of Xcomutil, assuming that it works as well for others as it does for me :)


-Blade FireLight

Edited by BladeFireLight, 11 May 2008 - 03:05 PM.

-------------------------------------------------------------------
Combat is very simple, there is a first place and second place, second place is laying face down in the mud, sometimes, so is first place.

#14 BladeFireLight

BladeFireLight

    Captain

  • Moderators
  • PipPipPipPip
  • 809 posts

Posted 12 May 2008 - 08:52 PM

Just a note. This does not require ACT to use. Please don't install the ACT unless you intend to modify the patch.
-------------------------------------------------------------------
Combat is very simple, there is a first place and second place, second place is laying face down in the mud, sometimes, so is first place.

#15 namelessone

namelessone

    Rookie

  • New Forum Members
  • Pip
  • 0 posts

Posted 14 May 2008 - 08:12 AM

Just a note. This does not require ACT to use. Please don't install the ACT unless you intend to modify the patch.



This works! Thank you!

#16 Cubi

Cubi

    Rookie

  • New Forum Members
  • Pip
  • 0 posts

Posted 25 May 2008 - 08:59 AM

Amazing, just amazing ! It works perfectly.
You did a nice job, thank you so many times :-)

#17 nickyboyc

nickyboyc

    Rookie

  • New Forum Members
  • Pip
  • 0 posts

Posted 26 May 2008 - 04:59 AM

Hi Blade Fire,

Great work on the patch at least I now can get it displaying and working, it's just a little too fast at the moment is there a way I can slow it then?Fr example the clock even on 5 seconds is extremely fast also the characters movements etc..

#18 Morganjs1

Morganjs1

    Squaddie

  • Forum Members
  • PipPip
  • 3 posts

Posted 30 May 2008 - 01:38 PM

I've got UFO enemy unknown running in Vista at a good speed, using the collectors edition + the xcom1fix.exe file found on this site. I run this in win95 compatibility mode with all of the options below it ticked as well.


However when I try to run Terror from the Deep using xcom2fix.exe I get "patch timed out" error message, and the display ends up being garbled.

I don't know why XCOM1 works fine yet XCOM2 doesn't, anyone got any ideas how I could get this to work?

I won't even start with xcom apocalypse, as I remember that was tricky to run under XP let alone Vista.

Thanks

Edited by Morganjs1, 30 May 2008 - 02:05 PM.


#19 Gimli

Gimli

    Sergeant

  • Forum Members
  • PipPipPip
  • 19 posts

Posted 31 May 2008 - 01:31 AM

Well, if you look a few posts up, you'll see a patch by Blade. :P

#20 Morganjs1

Morganjs1

    Squaddie

  • Forum Members
  • PipPip
  • 3 posts

Posted 31 May 2008 - 03:10 AM

Well, if you look a few posts up, you'll see a patch by Blade. :P


I'd tried that and couldnt get it to work.

After double checking what I had done, Id copied the Blade patch to the TFTD folder but forgotten the .sdb file so no wonder it didnt work (oops)

Now I've stopped being an idiot and installed the fix properly, it works great!
Sorry about asking a stupid question.

Thanks for the help.

#21 Gimli

Gimli

    Sergeant

  • Forum Members
  • PipPipPip
  • 19 posts

Posted 31 May 2008 - 05:49 AM

There's no such thing as a stupid question. ;)

#22 Morganjs1

Morganjs1

    Squaddie

  • Forum Members
  • PipPip
  • 3 posts

Posted 01 June 2008 - 12:58 PM

Well this is weird.

TFTD now works perfectly but the original UFO has decided to stop working. Now whenever an intercept takes place on the geoscape, the mouse freezes and the intercept window refuses to come up, so I cant take down any UFOs.

Prior to this, I was also having trouble with garbled colours on the buttons to the right of the geoscape. I don't understand how these problems can appear so intermittently, you'd think if there was a problem it would be the same all the time..

Damn vista, preventing me playing a classic.

#23 Gimli

Gimli

    Sergeant

  • Forum Members
  • PipPipPip
  • 19 posts

Posted 02 June 2008 - 01:08 AM

Ah yes, that may be because the fix patches both games. Unfortunately I'm too busy to upload a version that only has TFTD, so you'll have to remind me in a few days. :/

#24 painmonger1

painmonger1

    Rookie

  • New Forum Members
  • Pip
  • 0 posts

Posted 04 June 2008 - 07:05 AM

Well this is weird.

TFTD now works perfectly but the original UFO has decided to stop working. Now whenever an intercept takes place on the geoscape, the mouse freezes and the intercept window refuses to come up, so I cant take down any UFOs.

Prior to this, I was also having trouble with garbled colours on the buttons to the right of the geoscape. I don't understand how these problems can appear so intermittently, you'd think if there was a problem it would be the same all the time..

Damn vista, preventing me playing a classic.



I'm having the exact same problem with the origional game. I haven't tried TFTD yet, but the only way I've found to take down a UFO is to keep my cursor where I think the attack buttons are and start spamming mouse clicks as soon as I get in range of a ship. This is a tricky proposition at best. Not sure if this makes a difference, but I seem to be running the Gold Edition, not the CE. Anyone have any ideas on how to fix this? I'd love to play a few non-terror site missions!

#25 Morganjs1

Morganjs1

    Squaddie

  • Forum Members
  • PipPip
  • 3 posts

Posted 07 June 2008 - 04:30 AM

I'm having the exact same problem with the origional game. I haven't tried TFTD yet, but the only way I've found to take down a UFO is to keep my cursor where I think the attack buttons are and start spamming mouse clicks as soon as I get in range of a ship. This is a tricky proposition at best. Not sure if this makes a difference, but I seem to be running the Gold Edition, not the CE. Anyone have any ideas on how to fix this? I'd love to play a few non-terror site missions!


painmonger,
I had this problem with my CE version installed from the CD, but when I tried a version from an internet site with an included windows "fix", it worked fine.
I could PM you the link, though perhaps I had better check the rules first.

#26 ramesz

ramesz

    Rookie

  • New Forum Members
  • Pip
  • 0 posts

Posted 09 June 2008 - 11:21 AM

I'm having some real trouble geting it o work on vista x64. Tried ACT and vistafix, no matter, screen is still black. I've tried downloading different versions, but is it just me or is CE=gold edition? because the readme says its CE and vista recognizes it still as gold edition.

when i execute vistafix, it goes dos window and asks me to press any key, so i do, but nothing really happens. :(

thanks for any help u can give!

#27 Gimli

Gimli

    Sergeant

  • Forum Members
  • PipPipPip
  • 19 posts

Posted 09 June 2008 - 04:50 PM

At that point the fix has already finished patching. Unfortunately, we don't have Vista 64 here, so it's difficult to test. And being very busy as I am, I won't be of much help very soon. By the way, do you have a processor with more than one core?

Edited by Gimli, 09 June 2008 - 04:51 PM.


#28 painmonger1

painmonger1

    Rookie

  • New Forum Members
  • Pip
  • 0 posts

Posted 11 June 2008 - 04:27 PM

I would greatly appreciate it if I could get that link Morgan. I've got the cursor thing working reasonably consistent, but I'm a little tired of either destroying a UFO or losing one of my attack craft when it isn't reliable. Even if you can't give me the exact link, a hint in right direction would be helpful.

#29 Tilkor

Tilkor

    Rookie

  • New Forum Members
  • Pip
  • 0 posts

Posted 15 June 2008 - 07:59 PM

Morgan may be referring to the gold edition off the web. I am having the very same problem. I've used the fix, and that allows me to actually go through the menu and play the game.

BUT, I cannot use the menu that popups while intercepting a UFO. I am using the gold edition, and it will zoom geoscape in but I wont be able to use the menu, it is like it freezes for that moment or something. If anyone can help, I am more than willing to try and reply if it helps or not.

Edit!!!

I used turbo and that solved the problem. Now entering a tactical mode is well... annoying. Everything happens at EXTREMELY fast paces and if you scroll anywhere, its to the far reaches of space. with the computer speed set at 20% with turbo. I'll continue to try and maybe lower the speed down even more during tactical missions.

Anyhow the program. Turbo is the solution to the intercepting UFOs problem on vista.

Edited by Tilkor, 16 June 2008 - 04:02 PM.


#30 Nicko

Nicko

    Rookie

  • New Forum Members
  • Pip
  • 0 posts

Posted 17 July 2008 - 07:53 AM

It works great, thanks :)

#31 ImTJ

ImTJ

    Rookie

  • New Forum Members
  • Pip
  • 0 posts

Posted 20 July 2008 - 10:54 PM

Hey guys i need some help getting my xcom on gametap working, the usual black screen thing and i dont really follow all the posts well. Can someone tell me the steps i need to take to get this thing working?

Please help i miss the screams of sectoids!

#32 PlanetGuy

PlanetGuy

    Rookie

  • New Forum Members
  • Pip
  • 0 posts

Posted 03 August 2008 - 12:58 AM

Using Blade's Vista fix the mouse pointer on screen moves very very slowly.. is their a fix to that?

#33 Blastarr

Blastarr

    Rookie

  • New Forum Members
  • Pip
  • 0 posts

Posted 17 August 2008 - 10:02 AM

Hi! Encountering multiple annoyances, and not sure why. I installed the patch posted by Blade and now I can actually see the graphics on Vista 32 (black screen before). The game runs ridiculously fast, with the clock speeding along at even the lowest setting, but the mouse seems to jump back and forth across the screen. Clicking on a starting location for my base, the popup asking for a name doesn't show what characters I've typed but pressing enter makes it go away and create the base. Entering the bases submenu caused the geomap to palette swap to a negative of itself (lots of orange instead of blue, etc) and hang for 10-15 seconds. Once in the bases menu and looking at my initial base (which was named what I'd typed, so keyboard is working, yay) the mouse pointer didn't seem to move at all. Clicking, however, showed that it had moved but wasn't displaying it as it asked if I wanted to dismantle a Plasma Defense. Waiting for about a minute and fiddling I got the jumpy mouse cursor again and clicked the Cancel button. Now the mouse doesn't seem to move again and clicking isn't doing anything.

Please help!

#34 Puasonen

Puasonen

    Creative Text Department

  • Xenocide Inactive
  • 2,911 posts

Posted 20 August 2008 - 11:58 AM

Hi! Encountering multiple annoyances, and not sure why. I installed the patch posted by Blade and now I can actually see the graphics on Vista 32 (black screen before). The game runs ridiculously fast, with the clock speeding along at even the lowest setting, but the mouse seems to jump back and forth across the screen. Clicking on a starting location for my base, the popup asking for a name doesn't show what characters I've typed but pressing enter makes it go away and create the base. Entering the bases submenu caused the geomap to palette swap to a negative of itself (lots of orange instead of blue, etc) and hang for 10-15 seconds. Once in the bases menu and looking at my initial base (which was named what I'd typed, so keyboard is working, yay) the mouse pointer didn't seem to move at all. Clicking, however, showed that it had moved but wasn't displaying it as it asked if I wanted to dismantle a Plasma Defense. Waiting for about a minute and fiddling I got the jumpy mouse cursor again and clicked the Cancel button. Now the mouse doesn't seem to move again and clicking isn't doing anything.

Please help!

I had similar problems. Cursor jumped around, in some menus mouse didn't work at all. The game froze all the time. Couldn't drop ufo:s because one of the menus where the mouse froze totally was interceptor battle-window. Ahh, and yes.. the game was so fast it was unplayable, especially in battlescape. Well anyways installed turbo for the speed issue (http://www.xcomufo.com/turbo.zip) and surprisingly it ended all the problems. I set it in 40% and ran the game. Freezing has stopped. Mouse works in every menu, cursor moves smoothy enough, battlescape is still a bit fast but playable. If I drop the speed to 30%, the game starts freezing again and if I set it to 50% the game is too fast. 40% is the magic number for me.

And yes, thanks BLADE! Excellent job! Blades patch + turbo = cure for vista
There's no need for a sig..

#35 Gimli

Gimli

    Sergeant

  • Forum Members
  • PipPipPip
  • 19 posts

Posted 20 August 2008 - 03:42 PM

Have you tried messing with the Options menu in the Battlescape? You can lower the scroll, movement and firing speeds.

#36 geneboy

geneboy

    Rookie

  • New Forum Members
  • Pip
  • 0 posts

Posted 24 August 2008 - 12:03 AM

Have you tried messing with the Options menu in the Battlescape? You can lower the scroll, movement and firing speeds.


I can't create a base as somehow my pc doesn't allow my keyboard to work in game - is there any way pass this?

#37 Gimli

Gimli

    Sergeant

  • Forum Members
  • PipPipPip
  • 19 posts

Posted 24 August 2008 - 08:33 AM

Have you tried using Turbo mentioned in post #34? It may just be that your keyboard has a lag (even if a very long one).

#38 Blastarr

Blastarr

    Rookie

  • New Forum Members
  • Pip
  • 0 posts

Posted 27 August 2008 - 11:44 PM

I had similar problems. Cursor jumped around, in some menus mouse didn't work at all. The game froze all the time. Couldn't drop ufo:s because one of the menus where the mouse froze totally was interceptor battle-window. Ahh, and yes.. the game was so fast it was unplayable, especially in battlescape. Well anyways installed turbo for the speed issue (http://www.xcomufo.com/turbo.zip) and surprisingly it ended all the problems. I set it in 40% and ran the game. Freezing has stopped. Mouse works in every menu, cursor moves smoothy enough, battlescape is still a bit fast but playable. If I drop the speed to 30%, the game starts freezing again and if I set it to 50% the game is too fast. 40% is the magic number for me.

And yes, thanks BLADE! Excellent job! Blades patch + turbo = cure for vista


Hrm... Well, I seem to have it working after reinstalling (note to anyone: if you install Blade's patch DO NOT run the game using a "fixer" that makes it work in XP/NT, if you do it seems to permanently screw up whatever Blade's patch does) but it's still too damn fast. I'm not sure that Turbo actually works on my hardware, since I set it and there's no noticeable slowdown (even at 2%!). Is there another option?

#39 Gimli

Gimli

    Sergeant

  • Forum Members
  • PipPipPip
  • 19 posts

Posted 28 August 2008 - 03:36 AM

Do you have a dual core processor?

#40 Blastarr

Blastarr

    Rookie

  • New Forum Members
  • Pip
  • 0 posts

Posted 28 August 2008 - 08:38 AM

Do you have a dual core processor?

Yep. Intel Core 2 6600@2.4GHz.

#41 Gimli

Gimli

    Sergeant

  • Forum Members
  • PipPipPip
  • 19 posts

Posted 29 August 2008 - 02:28 AM

Start by setting the affinity to one core:

Use this.

Alternatively, you can also do it manually, but that would need to be done every time. Start the game, Alt-Tab out of it and open the task manager (Ctrl+Alt+Delete). Click on the Processes tab and find the process that matches the name of the game, then right click on it and select to set affinity to disable CPU1.

Once you did either of these, it will hopefully slow the game down. If it's not enough try doing the Turbo thing on top of it. I would be interested if this helps, so I would appreciate it if you could post if it works.

Edited by Gimli, 29 August 2008 - 02:28 AM.


#42 Blastarr

Blastarr

    Rookie

  • New Forum Members
  • Pip
  • 0 posts

Posted 31 August 2008 - 11:25 AM

Start by setting the affinity to one core:

Use this.

Alternatively, you can also do it manually, but that would need to be done every time. Start the game, Alt-Tab out of it and open the task manager (Ctrl+Alt+Delete). Click on the Processes tab and find the process that matches the name of the game, then right click on it and select to set affinity to disable CPU1.

Once you did either of these, it will hopefully slow the game down. If it's not enough try doing the Turbo thing on top of it. I would be interested if this helps, so I would appreciate it if you could post if it works.



I have now tried both, and really all that happens is that the music starts stuttering and skipping sometimes. The speed of the geoscape is relatively unchanged and still much faster than it should be (the 5sec speed is about equal to the supposed 1min setting, so a minute in-game per second in real time) and even with scroll speed at a minimum it's nigh impossible to see what's going on without constantly centering on things. I'm thinking that, unless there's a program out there that allows you to set at what exact speed you want the game to run (like setting the cycles in DOSBox), it will always be this fast...

#43 Crazy Taco

Crazy Taco

    Rookie

  • New Forum Members
  • Pip
  • 0 posts

Posted 31 August 2008 - 12:22 PM

Start by setting the affinity to one core:

Use this.

Alternatively, you can also do it manually, but that would need to be done every time. Start the game, Alt-Tab out of it and open the task manager (Ctrl+Alt+Delete). Click on the Processes tab and find the process that matches the name of the game, then right click on it and select to set affinity to disable CPU1.

Once you did either of these, it will hopefully slow the game down. If it's not enough try doing the Turbo thing on top of it. I would be interested if this helps, so I would appreciate it if you could post if it works.


This was a good suggestion. I'm running Windows Vista 64-bit (maybe the thread title should be changed from Vista 32 bit to just Vista) on a dual core Athlon 64 X2 3600+, and I was having the same problems he was.

I did what you said and set the affinity of the game to CPU0 (using the manual method above rather than the util). That alone actually didn't fix it, but I then decided to take it one step further and try setting the affinity of turbo to CPU0 as well. Up to this point, turbo hadn't apparently been slowing anything down, and even at 1% I could see no discernable difference, but once I gave it a CPU affinity so that it was only running on one CPU, it started working (for that CPU only). I found that at about 20%, with scroll speed set on 1, my game became reasonably playable, though I may have to take it down to 15%. Note: There's no way the music will work, at least for me... it seems to not depend on clock cycles, unlike the actual scrolling, because it is very slow and choppy with turbo on.

It looks like we are going to have to find another program to replace turbo soon though... my CPU is several years old, and I wonder if even 1% on turbo would make this game playable on the latest CPUs. You'd probably need it restricted to oen core at .0001% or something :D.

#44 Crazy Taco

Crazy Taco

    Rookie

  • New Forum Members
  • Pip
  • 0 posts

Posted 31 August 2008 - 12:25 PM

Start by setting the affinity to one core:

Use this.

Alternatively, you can also do it manually, but that would need to be done every time. Start the game, Alt-Tab out of it and open the task manager (Ctrl+Alt+Delete). Click on the Processes tab and find the process that matches the name of the game, then right click on it and select to set affinity to disable CPU1.

Once you did either of these, it will hopefully slow the game down. If it's not enough try doing the Turbo thing on top of it. I would be interested if this helps, so I would appreciate it if you could post if it works.



I have now tried both, and really all that happens is that the music starts stuttering and skipping sometimes. The speed of the geoscape is relatively unchanged and still much faster than it should be (the 5sec speed is about equal to the supposed 1min setting, so a minute in-game per second in real time) and even with scroll speed at a minimum it's nigh impossible to see what's going on without constantly centering on things. I'm thinking that, unless there's a program out there that allows you to set at what exact speed you want the game to run (like setting the cycles in DOSBox), it will always be this fast...


Hey, try what I did above, where you set the affinity of Turbo to one CPU as well. That fixed it for me.

Sorry I didn't get this posted faster... I think you beat me by less than an hour. Would have been great if you could have tried it right away to test if it works on multiple machines and not just mine.

#45 Blastarr

Blastarr

    Rookie

  • New Forum Members
  • Pip
  • 0 posts

Posted 01 September 2008 - 09:04 AM

Sorry I didn't get this posted faster... I think you beat me by less than an hour. Would have been great if you could have tried it right away to test if it works on multiple machines and not just mine.

Well, setting both Turbo and X-COM to one processor did actually work like you said it would: Things slowed down just enough that setting minimum scroll speeds means it's controllable. It's still not running at "actual speed" but it's playable, so thanks. Hopefully this'll help others with the same problem. Might even help it work on a quad, but then again that might be even trickier.

#46 Bariel

Bariel

    Rookie

  • New Forum Members
  • Pip
  • 0 posts

Posted 11 September 2008 - 05:01 PM

Just to say that I have been scouring the net for a solution for this game on Vista 64 with a Quad Core, and by following the steps above I got it to work - thanks sooo much :)

I still need to play with the turbo settings for optimum play, but I had pretty much all the issues listed here - initially black screen with music, and then inability to intercept UFOs, but now it all works just great - makes me glad I bought my new machine ;)

Edited by Bariel, 11 September 2008 - 05:01 PM.


#47 Shockwave

Shockwave

    Squaddie

  • Forum Members
  • PipPip
  • 1 posts

Posted 01 October 2008 - 09:29 PM

Just another one to say that the patch by BladeFireLight works to get vista running this amazing classic.

I've installed the game and got a black screen, ran the patch. That problem was fixed.

Then set the affinity for X-com to CPU 0 as well the affinity for turbo. Interception is not a problem.

Though one problem i do fine though, on the Battlescape, the same scrolling issue as mentioned above. With the turbo set to 1%

#48 Torgen

Torgen

    Sergeant

  • Forum Members
  • PipPipPip
  • 14 posts

Posted 06 October 2008 - 12:07 PM

Dell laptop here, T2330 dual core, 2GB RAM, Vista Home Premium. Turbo and game set to CPU0. I have to set Turbo to 1% and the in-game scroll speed to 1 to ave any chance at all at scrolling and not having the cursor shoot off to the edge of the map. Unfortunately, these settings also make the the game freeze up for a couple of seconds fairly often. I have music, except of course when the game pauses.

#49 Guest_AJ Rimmer Bsc.Ssc._*

Guest_AJ Rimmer Bsc.Ssc._*
  • Guests

Posted 06 October 2008 - 01:41 PM

googled
came
problem solved

my thanks to all who helped the guys etc here and thus myself too.

also glad to see we still exist as a tribe,this genre is getting to be niche and almost occultish ;)

vive la TB`ers

#50 king

king

    Rookie

  • New Forum Members
  • Pip
  • 0 posts

Posted 07 December 2008 - 12:14 PM

This is the fix with a basic installer.
It only works if the file naming matches that of the X-Com Collectors Edition that I have (Terror From The Deep.exe and UFO Defense.exe)
It also requires Admin rights to install but will not work if you right click and say run as admin. you have to let UAC do it's job (assuming you have not turned it off)

Xcomutil is not the least bit compatible with this patch nor does it play well with vista's file virtualization. So I'm working on that next. It will be included in future versions of Xcomutil, assuming that it works as well for others as it does for me :)


-Blade FireLight

help it tell me im not aloud to download



Reply to this topic