Jump to content


XCOMHACK v3 beta 3 now ready

  • Please log in to reply
3 replies to this topic

#1 hatfarm


    Sound Department

  • Xenocide Sound Department
  • 133 posts

Posted 20 December 2009 - 07:59 PM

Alrighty, the third beta of XCOMHACK3 is available for testing. Please let me know of any problems or bugs here and I will work on getting them fixed in the next beta. The next beta may be the final barring any huge problems. This version includes the alien containment editor as well as all research related "quick fixes." If there are any features or anything you'd like to see added, please let me know and I'll add it to my list of things to consider adding. Thanks ahead of time.

EDIT: Okay, the new beta should have the errors fixed, as well as the loading problems. Yay!

Attached Files

Edited by hatfarm, 21 December 2009 - 02:57 AM.

#2 Zombie



  • Xenocide Creative-Text Departmen
  • 2,947 posts

Posted 20 December 2009 - 10:41 PM

Some issues. I got an Unhandled Exception error after using the editor one time. So I redownloaded .NET Framework 3.5 SP1 and repaired my copy and also uninstalled your beta editor, downloaded it and reinstalled. Basically a clean slate. Then I copied the X-Com Hack v3 - beta3 exe and the xcomhack icon and dumped it into my CE game directory. Ran it, pointed the program to my CE executable and it behaved properly. However, when I exited the program and tried to run the hack again I got another Unhandled Exception error.

Then I noticed there was a file in my directory named XCH30 which contained the path to my game directory. On a whim, I deleted it and ran the hack again. Ran fine, but as soon as I exit, that XCH30 path file is back which causes a crash the next time I try to start it up again.

Why do I need to explicitly tell the hack where my CE executable is when both files are residing in the same directory. Can't you auto detect it?

The installer works fine, but if I run the hack from the standard folder it creates and then decide to remove it from the Control Panel, it only removes the hack exe and icon. That XCH30 path file still exists and so do all the other parent directories, so I had to go back into the program files to manually delete them.

Other than that, the program looks pretty good hatfarm. Everything appears to work fine. :)

By the way, the directory where my CE game is located in is: C:\Documents and Settings\X-COM Archive\. Is that a problem?

- Zombie

Edited by Zombie, 20 December 2009 - 10:43 PM.

The Mr. Grognard of X-COM

Zombie: Empirical data's your only man, when formulating a research plan.
A soldier's death is never in vain if it makes the formula more plain.
A few dozen make a better case for refining that third decimal place.
They call me Zombie because I don't sleep, as I slowly struggle to climb this heap,
of corpses, data points, and trials, but from the top - I'll see for miles!

#3 hatfarm


    Sound Department

  • Xenocide Sound Department
  • 133 posts

Posted 21 December 2009 - 01:34 AM

Hmmm... okay, I may have to pull this down and post it again when I can fix this problem. I was getting unhandled exception errors before I made a change and then it stopped happening to me, but maybe that was a fluke for the few times I ran it. I'll try to step through the startup and see if I can't pin down the problem. The reason I want it to explicitly be told where your game is because I want you to be able to install it to whatever directory you want. However, it should automatically check the directory it's currently installed in first, so if it's in the game directory, it should detect the game. The only time it should prompt you is if it doesn't detect a game at that location...

Maybe that's causing the error too. I'll look again at that code. Thanks for the quick reply.

#4 hatfarm


    Sound Department

  • Xenocide Sound Department
  • 133 posts

Posted 21 December 2009 - 02:56 AM

The new version should be good to go. Thanks for the heads up on the error, the reason for it was that I missed commenting out some code for loading the resources and it was trying to do that but unable at the same time. Not sure why it didn't cause errors every startup, or why it didn't cause problems when I was debugging it, but it's working now. Also, it shouldn't prompt you for your directory if you install it to your x-com directory.