Jump to content


Photo

Mapview Update


  • Please log in to reply
13 replies to this topic

#1 DaiShiva

DaiShiva

    Sergeant

  • Moderators
  • PipPipPip
  • 25 posts

Posted 12 January 2004 - 01:24 AM

1.10 released - major update: Copy/Paste functionality. See the website for more information

1.07 released, see the website for more information

MapView 1.06 is released, only one 'crash' bug was fixed (only one found) and various tweaks were made.

- Fixed 'map always changed' annoying bug
- Fixed 'TileView off by one' minor bug
- Fixed 'Create group -> crash in paths editor' bug
- Added ability to 'save' your image dependency list in the paths editor. Now you dont have to reorganize the same images for multiple files of the same tileset - Feature request thats now implemented

Website

Edited by DaiShiva, 10 March 2004 - 05:31 PM.


#2 DaiShiva

DaiShiva

    Sergeant

  • Moderators
  • PipPipPip
  • 25 posts

Posted 05 March 2004 - 02:01 AM

bump for 1.07 release

#3 stewart

stewart

    Programming Department

  • [Xenocide Senior Members]
  • 10,527 posts

Posted 05 March 2004 - 07:33 AM

Don't forget to work on the change the ship profile view in the interception box feature.
Posted Image
I'm starting to like the heavy cannon more and more.

#4 DaiShiva

DaiShiva

    Sergeant

  • Moderators
  • PipPipPip
  • 25 posts

Posted 05 March 2004 - 10:49 AM

ah yes thats right =)

#5 DaiShiva

DaiShiva

    Sergeant

  • Moderators
  • PipPipPip
  • 25 posts

Posted 06 March 2004 - 03:17 AM

bump for 1.10 release

#6 j'ordos

j'ordos

    Alien Concept Task Force

  • Xenocide Artwork Department
  • 5,059 posts

Posted 06 March 2004 - 04:09 AM

*checks date between release of 1.07 and 1.10*
:o 1 day?!

would that be called 'fast' or do we need to define a whole new category for that? :P
"You can't trust your eyes if your imagination's out of focus" - Mark Twain
"The mind is like an umbrella, it functions best when open" - Walter Gropius
Posted Image
SNEKK BLOG U-LAR MEKHH! GAHGHH! RK!
GRRGH RGGHH SNORRTT GHACKHGG

Now presented in DoubleVision™ (where drunk)

#7 DaiShiva

DaiShiva

    Sergeant

  • Moderators
  • PipPipPip
  • 25 posts

Posted 06 March 2004 - 11:46 AM

Heh heh =)

#8 Wiseman

Wiseman

    Rookie

  • Forum Members
  • Pip
  • 0 posts

Posted 07 March 2004 - 07:32 PM

Hmm, glitch. This version finds some Alien Ufos (ufos 000 010 and 01a) that the other didn't. They don't work. They seem to have their texture mixed up and cause an error that shuts down mapview. The message it gives is along these lines "Index was out of range. Must be non-negative and less than the size of the collection. Parameter name: index." I'm attatching the details incase it helps ya.

And is there a good way to keep the paths I was using in the other version? I:
A: am fairly lazy.
B: don't feel like adding them one by one.
C: wouldn't know which parts of which files to move/copy.
Update: I just went into the old mapedit.dat and copied my new little section to the new mapedit.dat, and edited it so it looked more or less the same. That's seems to have worked. Which brings me to a diferent question. What do the blanks do? The new version doesn't seem to have a blanks directory (yet anyway), but it seems to work fine.. Oh and thanks for allowing to fill an area. It was annoying to right click 400 times on a 20x20 before. ^_^

Attached Files


Edited by Wiseman, 08 March 2004 - 10:39 AM.


#9 DaiShiva

DaiShiva

    Sergeant

  • Moderators
  • PipPipPip
  • 25 posts

Posted 08 March 2004 - 10:43 AM

The other ufos are there because someone said that they were not there, but i dont know the image order for them.

You should be able to use your old mapedit.dat for the new version

if you HAVE to change anything, there are 6 or so lines at the top of the mapedit.dat file that say where the main directories are (maps,rmps and blanks)

blank files are something that the editor creates in order to make it draw faster on slower machines.

#10 SupSuper

SupSuper

    Programming Department

  • Xenocide Programming Department
  • 2,418 posts

Posted 10 March 2004 - 03:20 AM

the .net framework thingy is getting kind annoying :P
it would be just easier to put on top of the downloads page:
You need the .NET Framework to use the applications!!!
:LOL:

Edited by SupSuper, 10 March 2004 - 03:21 AM.

too bad, now you will never know the ancient secrets of supsupers long gone avatar ;)

Posted Image

Posted Image

#11 j'ordos

j'ordos

    Alien Concept Task Force

  • Xenocide Artwork Department
  • 5,059 posts

Posted 10 March 2004 - 06:54 AM

Hmm, glitch. This version finds some Alien Ufos (ufos 000 010 and 01a) that the other didn't.  They don't work. They seem to have their texture mixed up and cause an error that shuts down mapview.  The message it gives is along these lines "Index was out of range. Must be non-negative and less than the size of the collection. Parameter name: index." I'm attatching the details incase it helps ya.

And is there a good way to keep the paths I was using in the other version? I:
A: am fairly lazy.
B: don't feel like adding them one by one.
C: wouldn't know which parts of which files to move/copy.
Update: I just went into the old mapedit.dat and copied my new little section to the new mapedit.dat, and edited it so it looked more or less the same. That's seems to have worked.  Which brings me to a diferent question.  What do the blanks do? The new version doesn't seem to have a blanks directory (yet anyway), but it seems to work fine..  Oh and thanks for allowing to fill an area.  It was annoying to right click 400 times on a 20x20 before. ^_^

I'm not sure, but I had the impression they are created by xcomutil, so if you don't have that, it won't work. I'm not sure, I'll check it :)
"You can't trust your eyes if your imagination's out of focus" - Mark Twain
"The mind is like an umbrella, it functions best when open" - Walter Gropius
Posted Image
SNEKK BLOG U-LAR MEKHH! GAHGHH! RK!
GRRGH RGGHH SNORRTT GHACKHGG

Now presented in DoubleVision™ (where drunk)

#12 DaiShiva

DaiShiva

    Sergeant

  • Moderators
  • PipPipPip
  • 25 posts

Posted 10 March 2004 - 05:22 PM

it would be just easier to put on top of the downloads page:
You need the .NET Framework to use the applications!!!


Well, it used to be there, but apparently it wasnt large enough, because nobody read it. Ill revert the page back to normal, but its going right back up if someone says 'it doesnt run, i get this error' because they didnt read it =)

#13 SupSuper

SupSuper

    Programming Department

  • Xenocide Programming Department
  • 2,418 posts

Posted 15 March 2004 - 03:36 AM

i was gonna put "oh no i get this error" but then i remember i reinstalled my computer. why does the .net framework have to be 23,2mb?!?!?! it's gonna take forever!!! :crying:

too bad, now you will never know the ancient secrets of supsupers long gone avatar ;)

Posted Image

Posted Image

#14 j'ordos

j'ordos

    Alien Concept Task Force

  • Xenocide Artwork Department
  • 5,059 posts

Posted 20 March 2004 - 07:11 AM

I have another suggestion for your next update: a button in the paths editor 'revert to default' for when you changed the map files or image files and can't remember which were the original ones, nor in what order they need to be :wacko:
"You can't trust your eyes if your imagination's out of focus" - Mark Twain
"The mind is like an umbrella, it functions best when open" - Walter Gropius
Posted Image
SNEKK BLOG U-LAR MEKHH! GAHGHH! RK!
GRRGH RGGHH SNORRTT GHACKHGG

Now presented in DoubleVision™ (where drunk)