Jump to content


Photo

Enemy Unknown (ce) Et Version 28/03/2005


286 replies to this topic

#101 Kirill

Kirill

    Captain

  • Forum Members
  • PipPipPipPip
  • 129 posts

Posted 31 October 2004 - 04:20 PM

Max, your mod/fix RULEZ!!! Thx for everything :)
Would you plz release the next update with an option to disable the geoscape timepatch? I love light speeds :)

Thx again, and again and again!!! The small community of xcom fans here in Argentina loves u :D

#102 qcvar

qcvar

    Rookie

  • Forum Members
  • Pip
  • 0 posts

Posted 29 November 2004 - 06:32 PM

Hmm... researching the sectoid medic makes it crash for me now... but other than that, fantastic work!

#103 j'ordos

j'ordos

    Alien Concept Task Force

  • Xenocide Artwork Department
  • 5,059 posts

Posted 30 November 2004 - 10:58 AM

Hmm... researching the sectoid medic makes it crash for me now... but other than that, fantastic work!

<{POST_SNAPBACK}>

researching medic is a known bug of xcom, not because of ET
http://www.xcomufo.c...?showtopic=2745
(it's about a floater, but it's the same)

Edited by j'ordos, 30 November 2004 - 10:59 AM.

"You can't trust your eyes if your imagination's out of focus" - Mark Twain
"The mind is like an umbrella, it functions best when open" - Walter Gropius
Posted Image
SNEKK BLOG U-LAR MEKHH! GAHGHH! RK!
GRRGH RGGHH SNORRTT GHACKHGG

Now presented in DoubleVision™ (where drunk)

#104 max

max

    Sergeant

  • Forum Members
  • PipPipPip
  • 21 posts

Posted 01 December 2004 - 07:38 AM

Hi, please post save games with crashes.
Kirill, will release a version without the geoscape patch, or perhaps adjust it to be much faster?

#105 teukros

teukros

    Sergeant

  • Forum Members
  • PipPipPip
  • 40 posts

Posted 07 December 2004 - 03:55 PM

Great stuff! I'm halfway through an ET game right now and it has been smooth. I'm loving the XGrenades with the proximity fuses, the autosell feature, and, of course, the non-ludicrous speed!

Only problems are the occasional crash to the desktop (no more frequent than before I started using ET) and the mouse pointer wandering off on its own to the right of and below the screen... :blink:

Now if I could only use this with Xcomutil I would be a happy man. :D

Thanks!
runs with primed grenades

#106 Kirill

Kirill

    Captain

  • Forum Members
  • PipPipPipPip
  • 129 posts

Posted 07 December 2004 - 05:37 PM

Hi, please post save games with crashes.
Kirill, will release a version without the geoscape patch, or perhaps adjust it to be much faster?


Sorry, i dont understand your question

If it is a choice, ill stay with no geoscape patch :)

#107 Guest_:-\_*

Guest_:-\_*
  • Guests

Posted 10 December 2004 - 06:21 PM

This patch doesn't seem to work... when I run it, I hear the intro music, but the screen is black and remains black all the time; I have to Alt-Tab to manually kill the game to do anything.

The Xcom1fix "patch" works, but this one does not. :\

#108 max

max

    Sergeant

  • Forum Members
  • PipPipPip
  • 21 posts

Posted 13 December 2004 - 03:48 AM

Hi,
there are two versions, one for 24bit colour and the other 32bit, try the one which matches your graphic card capability. does this work?

#109 talon

talon

    Rookie

  • Forum Members
  • Pip
  • 0 posts

Posted 21 December 2004 - 02:37 AM

I'm having problems with bothe UFO and TFTD. i can install and run the game, but once im playing, the colors go psychodellic after a while. its not a set time really, it just happens to be random. i looked at some posts and it doesnt seem to be a problem with the sync rate, b/c i still maintain the same screen size and resolution. its just that the colors go all whacked and i cant really make out anything on the screen. any advice? i tried turning the color mode from 32 bit to 16 bit as well as disabling all hardware acceleration, but it still does it. im using the CE set. at first i thought it was a bug until i tried to run TFTD, and it occurs here too, so it must be a hardware problem.

im not sure what hardware this computer has, its my gf's and it was built by HP.

#110 j'ordos

j'ordos

    Alien Concept Task Force

  • Xenocide Artwork Department
  • 5,059 posts

Posted 21 December 2004 - 06:20 AM

try disabling any programs running in the background, like anti-virus programs and such.
"You can't trust your eyes if your imagination's out of focus" - Mark Twain
"The mind is like an umbrella, it functions best when open" - Walter Gropius
Posted Image
SNEKK BLOG U-LAR MEKHH! GAHGHH! RK!
GRRGH RGGHH SNORRTT GHACKHGG

Now presented in DoubleVision™ (where drunk)

#111 talon

talon

    Rookie

  • Forum Members
  • Pip
  • 0 posts

Posted 23 December 2004 - 09:00 AM

that didn't seem to work. is there anything else i could do? don't think i mentioned it, but im running XP. don't know if that will help any, but i saw a bunch of other problems with XP mentioned by others, but didn't see anything like mine.
i would like to take a screenshot so i could show what im talking about, but i don't know how.
also, the game closes itself sometimes when i try to do some things. its done it a few times when i try to equip soldiers on the skyranger. any help with this?

Edited by talon, 23 December 2004 - 09:12 AM.


#112 talon

talon

    Rookie

  • Forum Members
  • Pip
  • 0 posts

Posted 23 December 2004 - 06:16 PM

I didnt know you could download it from anywhere. im sure its not a corrupted version, since it worked fine on my computer before it died, and my comp was a heck of a lot better than this one. I was running XP on mine, with a AMD Athlon 1900+ and a Nvidia GeForce-2. I had to use turbo.exe on my comp b/c it was so damned fast. thats why i started posting here, b/c i couldn't figure out what was wrong.

#113 max

max

    Sergeant

  • Forum Members
  • PipPipPip
  • 21 posts

Posted 02 January 2005 - 03:34 AM

Update posted, added some graphic support, please post any problems, thanks.

(sorry Kirill, still no disabled geoscape patch.)

Edited by max, 02 January 2005 - 03:35 AM.


#114 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 02 January 2005 - 10:53 PM

Update posted, added some graphic support, please post any problems, thanks.

(sorry Kirill, still no disabled geoscape patch.)

<{POST_SNAPBACK}>


When you say "graphic support"...Are you reffering to support for additional hardware? If the game is working ok for us (no colour problems etc) will this patch add anything else?

#115 max

max

    Sergeant

  • Forum Members
  • PipPipPip
  • 21 posts

Posted 03 January 2005 - 06:09 AM

nothing else added, except for TFTD version, geoscape was updated for that et version.
There have been posts of game crashes but no game uploads so, there are no new fixes.

#116 Guest_Guest_Tim_*_*

Guest_Guest_Tim_*_*
  • Guests

Posted 03 January 2005 - 05:56 PM

Update posted, added some graphic support, please post any problems, thanks.

(sorry Kirill, still no disabled geoscape patch.)

<{POST_SNAPBACK}>


Fair enough...Again, thanks for all the work on the games man...

Are there any other games that you've tweaked / adapted like what you are doing with TFTD and EU?

#117 max

max

    Sergeant

  • Forum Members
  • PipPipPip
  • 21 posts

Posted 04 January 2005 - 05:06 AM

Guest_Tim_*,

I learnt while working on 'Hardwar Enhanced' - we added the enhanced bit to an up-till-now unsupported game.

#118 Kirill

Kirill

    Captain

  • Forum Members
  • PipPipPipPip
  • 129 posts

Posted 10 January 2005 - 11:54 AM

i hav all the time of my existence

#119 NKF

NKF

    Commander

  • [Global Moderators]
  • PipPipPipPipPipPip
  • 4,795 posts

Posted 17 January 2005 - 05:27 AM

While I haven't been actively following this topic, one thought did occur to me that I thought I'd share before I forget about it entirely:

UFO has 6 unused weapon slots. These are used in TFTD for the gauss clips and the drills.

UFO has these slots in the bases and the ship data files, so they can definitely be brought into a battlescape mission. So, would it be possible to make them appear in the purchase screen and also visible in the ship item transfer screen so that they can be loaded into the ships?

In the regular game, these items would be useless (especially those three almost identical laser chain-gun-like weapons left in obdata.dat. Needs a few minor tweaks to become usable), but for those who want to use weapon mods and keep all the original weapons, these six slots could come in handy.

- NKF
Lord High Generalissimo Ruler Supreme of Norm's Anti Pedant Society (NAPS).

Number of members: 1

#120 Guest_Arcador_*

Guest_Arcador_*
  • Guests

Posted 22 January 2005 - 05:02 AM

How actually is the patch working? I used the Sai.exe and seems the speed problems are gone, still not tested the other features (auto sell and stuff)
I will report back.

Pretty good work max :) I hated that Turbo stuff, now I can scroll normaly the map and research the alient medic crashy stuff (well, still not tested that).

#121 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 22 January 2005 - 09:16 AM

Does not work with the max's patch. Only the slowdown works, the new features as autosell (I guess and the bugfixes) are not there.

Anyway I (we?) will be happy to make the Sai (or similar) filter in the next version avaible threw exe or command line.

(I am saying that as its easy../me noob)

#122 Guest_Lightman_*

Guest_Lightman_*
  • Guests

Posted 23 January 2005 - 09:01 PM

This patch looks good, but it doesn't correct the pitch problem and isn't compatible with the loader patch that does. Isn't there a way to get it to work. That pitch problem is really frustrating and stupid in a commercial product :P

#123 Guest_Lightman_*

Guest_Lightman_*
  • Guests

Posted 23 January 2005 - 09:04 PM

This patch looks good, but it doesn't correct the pitch problem and isn't compatible with the loader patch that does. Isn't there a way to get it to work. That pitch problem is really frustrating and stupid in a commercial product :P Not to mention the crashes, but that might be because I have to use the loader just to get the thing to run properly!

#124 Rovlad

Rovlad

    Sergeant

  • Forum Members
  • PipPipPip
  • 12 posts

Posted 02 February 2005 - 04:19 PM

When alien throws a grenade, fire speed resets to 1, which is painfully slow with your new and improved (in terms of speed as well ;)) battlescape. Any chance that this will be fixed? Not much of a problem, but still frustrating sometimes.

Lightman
You can fix this manually by disabling DirectDraw acceleration in your dxdiag program. Just don't forget to set it back when you're done playing. Not much of a fix, but does the trick anyway.

Edited by Rovlad, 02 February 2005 - 04:22 PM.


#125 Kloreep

Kloreep

    Sergeant

  • Forum Members
  • PipPipPip
  • 47 posts

Posted 04 February 2005 - 09:08 PM

BTW Max, I thought I might mention I saw something similiar to the reaction fire bug mentioned in the TFTD Et thread. I had my soldiers out on a mission and a lot of them got killed by a blaster bomb. Following this, one of the surviving soldiers began reaction firing continuously - over 30 shots, nearly emptying the HP clip. It did stop before the gun ran out, but it was far more than the soldier should have been able to make, even at full TU, which he wasn't.

Unfortunately, I have nothing for you to go about fixing this with; I did have a save just before, but I couldn't duplicate this again by repeatedly ending the same turn from that save, even when the blaster bomb was used again.

So, if you find out what went wrong with the TFTD version, you might want to check if it applies to UFO as well.

When alien throws a grenade, fire speed resets to 1, which is painfully slow with your new and improved (in terms of speed as well ;)) battlescape. Any chance that this will be fixed? Not much of a problem, but still frustrating sometimes.


Strange, this doesn't happen for me.

#126 Guest_GateMUD_*

Guest_GateMUD_*
  • Guests

Posted 08 February 2005 - 07:48 PM

[quote name='Kloreep' date='Feb 4 2005, 10:08 PM']
BTW Max, I thought I might mention I saw something similiar to the reaction fire bug mentioned in the TFTD Et thread. I had my soldiers out on a mission and a lot of them got killed by a blaster bomb. Following this, one of the surviving soldiers began reaction firing continuously - over 30 shots, nearly emptying the HP clip. It did stop before the gun ran out, but it was far more than the soldier should have been able to make, even at full TU, which he wasn't.

Unfortunately, I have nothing for you to go about fixing this with; I did have a save just before, but I couldn't duplicate this again by repeatedly ending the same turn from that save, even when the blaster bomb was used again.

So, if you find out what went wrong with the TFTD version, you might want to check if it applies to UFO as well.

Hey there, new to this forum! I've had the same thing happen when multiple soldiers were fragged by aliens in a short time frame in my UFO Def CE, unpatched version... Personally I thought it was a cool mini-touch to modern day shell shock/PTSD/losing it. Since when the soldier started capping off anything on-screen when his/her buddies were offed, it looked realistic. Also if you watched their stats after the mission, they are worthless for several missions, and are more subject to mental takeover 4ever thereafter. Just my two pfennigs. :) ~GateMUD~

#127 Unkind

Unkind

    Rookie

  • Forum Members
  • Pip
  • 0 posts

Posted 13 February 2005 - 01:35 AM

I have a savegame with intercept crash here... Description is as follows:
Can't describe the situation that caused the bug too exactly, but will try to best of my abilities and memory... Detected an alien terror ship coming... Decided to let it land and attack. 1 base had more expirienced soldiers and skyranger ready, other had less expirienced and skyranger refueling. But the one with refueling skyranger was much closer to presumed landing location. So i sent ready skyranger just in case and started waiting for the other one to refuel. As soon as it refueled i sent it at the terror ship also. Alas it took off. The other skyranger(with weaker soldiers meant for training) also started puruing it. It moved out of their range and range of hyperwave detectors, then came back, so the second skyranger engaged it, i think...(didn't have much of weapons, only the deafault cannon). It landed again, the skyranger with less expirienced soldiers was closer so i just advanced time and started battle. It was later that i found something strange's happened. Winning the battle resulted in camera insta-zooming out really far and game crashing. Aborting it with losing the ship and without losing the ship yields different results.Losing the battle:
Both second skyranger and ufo are kinda stuck in intercept state, with ufo being on the ground and skyranger stuck in place. Sometimes ufo still leaves when i lose the ship, but that happened 1 time in 15, all other times i advanced time several day and it was still there on the ground. If i try to maximize intercept, the game crashes.
So i found out 2 things cause the game to crash with that strange zoom-out-geoscape-really-far in this situation:
1.Maximizing intercept.
2.Ordering the skyranger to go back to base.
It's ordered to go back to base if i win the mission automatically, that's why the game insta-crashes after winning. It also stays there until it runs out of fuel, after that it's also auto-ordered to go back to base and the game crashes.
If i abort the mission but don't lose the ship, skyranger-2 and ufo are not stuck in place, ufo even leaves, but that phantom minimized intercept is still there and clicking it still crashes the game. Selecting skyranger-2 and ordering it to at the any target again(like the same ufo or alien base) crashes the game in the same zoom-out manner(just pointing it to new waypoint doesn't, and sometimes i can even see the intercept maximized(with no ufo there) before the game crashes if i first point it to waypoint, so generally it's ordering it to do anything that crashes the game, except patrolling or going to waypoint. Skyranger-1 also has some problems returning to base it seems, but still manages to after much longer time than supposed. I don't need the game fixed, i've since loaded from game_4 and progressed much further, so this is just for your crash&bug fixing efforts. GAME_5 is the game crashing, GAME_4 is saved right at terror ship detection, though i doubt it can be reproduced to study the exact moment of bug happening, providing just in case since it's so small when compressed anyway.

Attached Files



#128 Cmndr

Cmndr

    Rookie

  • Forum Members
  • Pip
  • 0 posts

Posted 15 February 2005 - 07:50 AM

I've got a question about the one feature I miss the most in UFO after playing TFTD:

Is there a way to make it happen that you can open doors without going through them, say like like in TFTD, by standing next to the door and clicking right on the space behind the door?

Also: I've tried using this mod along with XCOMutil, but while I had no crashes, I had no changes, either....

Any suggestions?

#129 Unkind

Unkind

    Rookie

  • Forum Members
  • Pip
  • 0 posts

Posted 15 February 2005 - 01:09 PM

It does work perfectly well with xcomutil. Uninstall your ce, do a fresh install. REPLACE original UFO Defense.exe with ufoeuet modified one, ofcourse don't forget the extra no-extension file... Now run xcusetup, choose NO to enable fodder's loader(to be on the safe side after running setup delete loader.exe and patchxc1 and patchxc2 dlls). Now just run RunXcomW. This is the way i recommend to do it since otherwise you must know specifics of xcomutil and delete&modify appropriate ini-files to stop it from trying to use fodder's loaders etc... Just reinstall...
Btw i also recommend to modify runxcomw to always launch geoscape and battlescape with /low switch so the priority is auto-set to low, because of perverted(but still the best of all available) way this patch fixes timer which involves increasing cpu usage to 99%. This is VERY bad generally and i hope author or someone else sometime finds even better way, for now if you don't include /low switch, you'll have a real pain task-switching while the game is running unless you have hyperthreading or multi-cpu system and click-pause bugs'll occur MUCH more often unfortunately(i don't think this patch or mok's ever fixed them anyway, only fodder probably)... Prolly'll be quite surprised to watch your top-notch athlon 64 3800 brought to kneels with this :)

#130 Cmndr

Cmndr

    Rookie

  • Forum Members
  • Pip
  • 0 posts

Posted 15 February 2005 - 04:38 PM

Thanks for the help, I'll try that tomorrow.

This problem was more an aside of my request for the door feature, but any solution is ever so welcome.
:D

#131 max

max

    Sergeant

  • Forum Members
  • PipPipPip
  • 21 posts

Posted 17 February 2005 - 03:45 AM

I am not sure about the blank screen problem, currently the graphics are being re-written. I can't release another patch until completed, I expect this issue to be resolved with the next release.

The last patch has 24/32 patches inlcuded in one file. It does not take into account 'pitch' which may be the cause of the remaining graphics problems.

The patch does not artificially slow the game.

I will look into a fix for the reaction firing.
and Unkind, thank you for the save.

#132 max

max

    Sergeant

  • Forum Members
  • PipPipPip
  • 21 posts

Posted 19 February 2005 - 03:41 AM

Hi,
the last release 2005_02_19 has graphics 'rewritten' and includes 'pitch'.
Unkind, thanks again for the save, the last patch responds better to those situations, and you may be able to continue playing as normal from the posted savegame. We'll add that cpu usage thing to 'to-do list'.
Cmndr, that is a great idea, hope I can learn how...

Please post any problems or feedback, savegames are very helpful. thanks.

#133 Guest_Taoist_*

Guest_Taoist_*
  • Guests

Posted 20 February 2005 - 05:44 PM

Hi,
the last release 2005_02_19 has graphics 'rewritten' and includes 'pitch'.
Unkind, thanks again for the save, the last patch responds better to those situations, and you may be able to continue playing as normal from the posted savegame. We'll add that cpu usage thing to 'to-do list'.
Cmndr, that is a great idea, hope I can learn how...

Please post any problems or feedback, savegames are very helpful. thanks.

<{POST_SNAPBACK}>


Hello,

I installed the 2005_02_19 patch, but I am now having problems intercepting UFO's. Basically, when I click on the UFO, it only brings up a generic waypoint, not the UFO. So, I am unable to intercept them. Any help or suggestions would be appreciated. Thanks.

#134 max

max

    Sergeant

  • Forum Members
  • PipPipPip
  • 21 posts

Posted 21 February 2005 - 02:06 AM

Hi,
this may have been caused by 'fixes' in the patch, could you post your savegame for me to try, thanks.

#135 Guest_Guest_*

Guest_Guest_*
  • Guests

Posted 21 February 2005 - 04:42 PM

I'm getting the same problem. I also can't move the Geoscape by clicking on the globe anymore.

#136 Guest_IRS_*

Guest_IRS_*
  • Guests

Posted 25 February 2005 - 06:34 AM

I've got the same Geoscape problem with the latest patch. It doesn't even need a save game to encounter it- I just started a new game, and discovered that I can't even place my first base. Left clicks seem to not register at all, or the game's looking at an area that has nothing but ocean (since a right click would end up moving the globe to the middle of the pacific, where you obviously can't place a base). The only method to rotate the globe was through the direct rotation controls on the command sidebar, though the effects were largely symbolic as any left click produced no response on the map proper, and a right click brought the geoscape right back to the middle of the pacific.

Workaround: Don't do anything that requires you to click on the map in Geoscape. Do everything from the command sidebar or popup windows.

Speculation on cause: A loss or corruption of whatever routine catches the location of the mouse pointer relative to the geoscape map, either fixing an x or y value, or ignoring one.

#137 max

max

    Sergeant

  • Forum Members
  • PipPipPip
  • 21 posts

Posted 02 March 2005 - 08:39 AM

Hi,
apologies, update posted. Although we can't recreate this problem ourselves, it's likely the latest crash fix added. I don't think using the word 'fix' is a good idea anymore...
Please post if the problem is still there, thanks.

Edited by max, 02 March 2005 - 08:53 AM.


#138 Penta

Penta

    Sergeant

  • Forum Members
  • PipPipPip
  • 45 posts

Posted 02 March 2005 - 06:20 PM

No change.

#139 max

max

    Sergeant

  • Forum Members
  • PipPipPip
  • 21 posts

Posted 04 March 2005 - 11:18 AM

Hi,
I would like to fix this. But I cannot reproduce the problem, even starting several new games etc, we can always place a base.

Selecting a UFO sometimes will not respond, but after a right click to recentre, the UFO can be selected.

Has anyone got the patch to work, placed a base etc?

Also, which release first 'introduced' the clicking problem?

-Thanks for the feedback.

Edited by max, 04 March 2005 - 11:23 AM.


#140 Guest_Anders_*

Guest_Anders_*
  • Guests

Posted 04 March 2005 - 11:45 AM

Hi, justed wanted to say that I have the exact same problem. Starting a new game and pointing out where the base will be that is. I dont know if it helps but my system is:

Windows Xp SP2
AMD A64 2800+
Old Geforce 256 ddr
Asus K8N motherboard

And also : Keep up the awesome work. When I saw this patch I litterarily jumped with joy. I would gladly help investigate this problem if you told me how.


Ps. I wish one could have the Gravis Ultrasound sound back ;).

#141 max

max

    Sergeant

  • Forum Members
  • PipPipPip
  • 21 posts

Posted 04 March 2005 - 12:51 PM

Hi,
thanks, could you try each of the patches below, if possible, and including the January one from the first page, and report which produces the click problem. Thank you.

Attached Files



#142 Penta

Penta

    Sergeant

  • Forum Members
  • PipPipPip
  • 45 posts

Posted 04 March 2005 - 01:44 PM

OK.

2004_07_21: Click problem appears.

2004_08_24: No problem (with placing first base, anyway...tis all I tested).

2005_02_01: No problem (caveats as above).

2005_02_03: Problem.

#143 Guest_SF_lt_*

Guest_SF_lt_*
  • Guests

Posted 05 March 2005 - 05:35 AM

question to max:

you are adding new features, fixing bugs - do you have complete UFO I & UFO II sources?
I don't know other way for the fixing, adding that rewrite/modify source codes - these games have no plugin architecture.
Could you make a public statement :-)

#144 misiek

misiek

    Sergeant

  • Forum Members
  • PipPipPip
  • 50 posts

Posted 05 March 2005 - 06:19 AM

Hi,

There is another way - decompilation of executable into source code, changing this code and compilation into new executable.

I'm also courious how it's done - Max, can you tell us? :) And if you use decompiler can you tell what decompiler(or at least into what language it decompiles) it is?

Thanks

#145 max

max

    Sergeant

  • Forum Members
  • PipPipPip
  • 21 posts

Posted 05 March 2005 - 08:51 AM

Hi,
its great that there is interest in the technique.
This is how we do it. find functions we need to change, write code that replaces them, and then patch the functions.

Could you test the patches posted, re post #145 and post your results, see Pentas post #146.

Thank you for your assistence.

#146 Guest_SF_lt_*

Guest_SF_lt_*
  • Guests

Posted 05 March 2005 - 10:20 AM

max:
this means, that you are working with an assembler code - hard way to start (for starters), but not for experienced ones.
There is no way to get good/full C code from the machine code - what you write in one C line, you get one page of assembler code. Analysis takes a lot time also ;)
But max releases patches, so he is very familiar with the code... aleluja

#147 Guest_SF_lt_*

Guest_SF_lt_*
  • Guests

Posted 11 March 2005 - 04:55 AM

max, 2001-02-03 patch isn't playable - planes/ufos/destination points can't be selected, totally mess.

suggesting to remove this patch or release working patch :)

#148 Guest_SF_lt_*

Guest_SF_lt_*
  • Guests

Posted 11 March 2005 - 05:03 AM

forgot to say, that it would be great to change colors for bases (maybe green), also plane indicators - one of the patches had better signs (targeting crosses)

also 02-03 patch has base information bugs - living quaters displayed as negative numbers (-9321); bases wiht no scientist & engineers has negative numbers
base statistics shows nonsence

#149 max

max

    Sergeant

  • Forum Members
  • PipPipPip
  • 21 posts

Posted 11 March 2005 - 11:52 AM

Hi, thanks for your feedback. I may remove the links.

I can't reproduce any of the mentioned bugs.

SF_It please post your savegame with the living quaters negative numbers, it may help.

Thanks.

#150 Guest_IRS_*

Guest_IRS_*
  • Guests

Posted 13 March 2005 - 10:24 AM

AMD Sempron
Win98 SE
GeForce 2 MX400
512MB DDR RAM

Hmm... So the patch works fine for some people, but not for others, and base stats occasionally go screwy. It looks like a bad memory reference problem (which would also explain the completely ludicrous [multi-million alien scores with them having done almost nothing succesfully] score reports I've gotten on most patches). I've seen this sort of behavior in my own programming experience, and I'd hazard that whatever memory structure is being used might benefit from a more exact declaration of size, or greater attention paid towards the incerementing of any pointers to the memory. In my experience, you can't trust code that hasn't laboriously detailed every last byte allocated, as Very Strange Things occur. These are rather infuriating to fix, as the problem often won't manifest until you try it on a different machine since everything can and often does fall perfectly into place by sheer chance.

All told, it is an all-around great job at making a good game even better. The fast Geoscape timer has long been a feature I wanted to see, and the autosell makes one of the more forgettable bookkeeping tasks easy as cake. To the swift quashing of bugs! :beer:



Reply to this topic