Jump to content


Missing Some Features

  • Please log in to reply
5 replies to this topic

#1 ChrisEvans



  • Forum Members
  • Pip
  • 0 posts

Posted 02 April 2007 - 01:13 PM

I'm new to xcomutil and I'm having real difficulty getting it to work. I've had a look round and I can see anyone else complaining of the same problems so I'm starting a new thread.

I'm using X-COM Collectors Edition to play UFO Defence with XcomUtils 9.6 on Windows XP Pro SP2

The only features I'm intrested in are:

1) Automatic renaming of soldiers

2) Automatic re-equiping of soldiers

3) Automatic sorting of soldiers

4) Alternative starting base

At first, XCUSETUP.BAT didn't work at all, then I noticed that the DOS box was spitting out an error, "Could not execute command C:\GAMES\XCOM\UFO DEFENCE\SDUMP.EXE", I tried renaming the "UFO DEFENCE" folder to "UFO" and then it worked. I worry this may have broken something else, but I can't change the install path beyond C:\GAMES\XCOM and I have to rename the ufo sub-directory to make it work at all.

Anyway, the problem I have now is after XCUSETUP.BAT and selecting the features I want I run the game with RUNXCOMW.BAT. The alternative base feature works, but nothing else does. My soldiers havn't been rename, even after a mission, or saving and re-running XCUSETUP.BAT. The same is true of re-equiping and sorting, simply doesn't work. So far, only the alternative base and new ship stats are working, although soldier facings in the landing craft are unchanged. I looked at the XCOMUTIL.LOG file and it's empty. I uninstalled and re-installed everything, but it made no diffrence. Anyone have any ideas?

I'm not sure if this is related, but I have noticed something curious about XCUSETUP.BAT that seems wrong to me. When I apply a feature that is not applied, the .BAT script gives me a "Patch Applied" message, likewise, if I say no to feature that is applied I get "Patch Disabled" message. While if I apply or a patch that is already applied, or disable a patch that is already diabled I get no message at all. Seems sensible enough. However, my XCUSETUP.BAT does not seem to remember which patches I have applied or disabled previously, I always say no to the improved tanks, yet it always gives me the "Patch Disabled" message. In fact, I get exactly the same permution of Enabled and Disabled messages no matter how many times XCUSETUP.BAT. This might be normal, I'm not sure, but it seems to indicate XCUSETUP.BAT simply isn't working.

I have no idea what to do next, I dearly hope that someone hear can help me


#2 NKF



  • [Global Moderators]
  • PipPipPipPipPipPip
  • 4,798 posts

Posted 02 April 2007 - 02:19 PM

I haven't got too much time on my hands, so I apologise if this seems short, but:

Are you running the game with runxcomw.bat as opposed to ufo.exe or ufo defense.exe? A lot of those features only work when running the game with the xcomutil batch file.

Also note that there are two batch files. runxcom.bat and runxcomw.bat. Since you're using the collectors edition, you'll want runxcomw.bat. The other is used for running the dos version of the game.

Lord High Generalissimo Ruler Supreme of Norm's Anti Pedant Society (NAPS).

Number of members: 1

#3 Hobbes


    UFO2000 Staff

  • Moderators
  • PipPipPipPip
  • 719 posts

Posted 02 April 2007 - 07:17 PM

Hey ChrisEvans,

I don't use CE right now but there was something that you needed to do before using it:

"To run the Windows version of XCOM or TFTD, you will need to create a
shortcut for RUNXCOMW.BAT. Right-click on any portion of the desktop
background, then select New, then select Shortcut, then select Browse. Go
to the directory in which the game is installed and select RUNXCOMW.BAT.
After you select the Next button twice, you will see a selection of icons.
Since this is a batch file, you get to choose the icon you want. I
recommend the one that looks like a satellite dish. Finally, select
Finish. You can not select the icon if you are running Windows NT or
Windows 2000".

Have you tried this?

If this doesn't work there is another way to do the resort, rename and reequip but it isn't automatic since you'll have to save, modify and load each battle.

Edited by Hobbes, 02 April 2007 - 07:24 PM.

#4 ChrisEvans



  • Forum Members
  • Pip
  • 0 posts

Posted 03 April 2007 - 04:35 AM

Cheers for the response guys,

Yeah I'm defineatly using RUNXCOMW.BAT, so far as I can see, the 'other' thing you have to do in the Readme.txt is just creating shortcut RUNXCOMW.BAT instead of the orginal exe. I'm, defineatly, defineatly, defineatly using the batch file that came with XcomUtils. It's obviously essential for processing the .cfg scripts inbetween the geoscape & tactical phases (hence the sperate .exe's). I think I'll give the DOS version a go, not sure if I get hold of it or even get it to work on XP, but worth a spin I suppose.

Any other ideas on what is going wrong?


#5 Hobbes


    UFO2000 Staff

  • Moderators
  • PipPipPipPip
  • 719 posts

Posted 03 April 2007 - 04:43 AM

Well this seems like a case to be reported to BladeFireLight (the current developer). It might take a while to get it fixed though.

Running the DOS version on XP is very easy: you simply have to get Dosbox (http://dosbox.sourceforge.com), it is an x86 emulator (plus the alien death sounds are much better on DOS)

#6 tftd



  • New Forum Members
  • Pip
  • 0 posts

Posted 04 May 2007 - 03:19 AM

Do u have any problems using the xcomutil? what bout using barracuda for crew missions? does it work then? it doesnt seem to work on mine